PDA

View Full Version : [ubuntu] Ubuntu 10.4 won't reconise some mp3s



2steps
May 30th, 2011, 06:17 PM
I have an external hard drive with most of my music on either mp3s or ripped from cds. I have imported the folders into gmusicbrowser but it doesn't show up some of the files. I have also tried rhythmbox and banshee media player but they all have the same problem. The files play fine on my other pc runnin xp pro so they are fine. Also some folders have nothing in under ubuntu but have mp3 files in (as they should) under xp. Can anyone help?

3xp10r3r|X13
May 30th, 2011, 06:26 PM
hello there,
your files are fine, you're right, but banshee etc. is missing a certain mp3 plugin. So I'll just assume that you are able to play wav files but not mp3s. If you try to play an mp3 file with banshee or amarok, it should offer you to install the missing plugin.

however, if it doesn't, this might be helpful or rather should be helpful:
http://packages.ubuntu.com/dapper/vdr-plugin-mp3

edit: in the top right corner, you are able to select the needed ubuntu version - sry for dapper :D

hope this helped

2steps
May 30th, 2011, 06:34 PM
Thank you. The rest of my mp3s are working fine, it's justs ome having the problem. Will give that a go

Chronon
May 30th, 2011, 06:45 PM
That link will take you to a package for Dapper Drake. Since you're running Lucid you probably don't want this version. Search for this plugin in your package manager instead. Also, after reading the description it seems to just be a plugin for a Video Disk Recorder application, so probably not what you want.

I usually just install ubuntu-restricted-extras, which should install codecs for mp3 and a few others.

3xp10r3r|X13
May 30th, 2011, 06:51 PM
sry, you're rigth --> mixed up the versions:

http://packages.ubuntu.com/natty/vdr-plugin-mp3

However, in the top right corner, you are able to select the wanted ubuntu version.

--> but chronon is right, installing the restricted extras is probably the easiest way to go

2steps
May 31st, 2011, 01:12 PM
Still not working :( Some of what are missing where ripped from cds, could that be a problem?

3xp10r3r|X13
June 1st, 2011, 08:07 PM
it shouldn't really be a problem...but we are talking about wav files aren't we, not about mp3s?

Chronon
June 1st, 2011, 08:42 PM
Did you install ubuntu-restricted-extras?

Do any mp3s play properly? Is there any common feature to the files that aren't working?

ufugu
June 1st, 2011, 09:08 PM
I have the same issue. 95% of my mp3 files play fine, no problem, but some files just don't play at all.

They won't play on my Android device either. They play fine in iTunes on Windows 7 at work (blech).

I have re-encoded them to ogg as a workaround, but I'm still curious as to what happened.

Chronon
June 2nd, 2011, 12:21 AM
Maybe something about the metadata is causing problems? Will the tracks play if you strip all metadata from them?