PDA

View Full Version : [ubuntu] nvidia drivers won't work



aryabhatt
May 29th, 2011, 04:45 AM
I recently bought Asus U31Jg laptop. I've installed Ubuntu 11.04 on it. The laptop comes with an nvidia GeForce GT 415M. Even though the drivers are installed, but I am not able to use it. If change xorg.conf generated by nvidia-xconfig, the X doesn't load. Xorg.0.log complains:

(EE) No devices detected

Someone please help.

--dinesh

Frantic_Earthling
June 4th, 2011, 01:15 PM
How do you know that the nVidia driver is installed properly?

Can you run:

dpkg -l|grep nvidia

For your information here is what I get on my Asus M70Vn:

ii nvidia-173 173.14.30-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-common 0.2.30 Find obsolete NVIDIA drivers
ii nvidia-current 270.41.06-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 270.29-0ubuntu1 Tool of configuring the NVIDIA graphics driver

divey
June 6th, 2011, 11:50 PM
I'm having the same issue with a GeForce 8400 graphics card. I installed nvidia-current, nvidia-current-modaliases, nvidia-settings.

Here is my xorg.conf:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 260.19.06 (buildmeister@builder101) Mon Sep 13 04:59:45 PDT 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "G98"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:d:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "G98"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


Here is my Xorg.0.log:


[ 13.121]
X.Org X Server 1.9.0
Release Date: 2010-08-20
[ 13.121] X Protocol Version 11, Revision 0
[ 13.121] Build Operating System: Linux 2.6.24-28-server x86_64 Ubuntu
[ 13.121] Current Operating System: Linux SUN-FIRE-X4170-M2-SERVER 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64
[ 13.121] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=f199bac1-10df-4bdc-9c28-53f26ef05f08 ro quiet splash
[ 13.121] Build Date: 09 January 2011 12:14:27PM
[ 13.121] xorg-server 2:1.9.0-0ubuntu7.3 (For technical support please see http://www.ubuntu.com/support)
[ 13.121] Current version of pixman: 0.18.4
[ 13.121] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 13.121] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 13.121] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun 6 17:48:37 2011
[ 13.122] (==) Using config file: "/etc/X11/xorg.conf"
[ 13.122] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 13.129] (==) ServerLayout "Layout0"
[ 13.129] (**) |-->Screen "Screen0" (0)
[ 13.129] (**) | |-->Monitor "Monitor0"
[ 13.130] (**) | |-->Device "G98"
[ 13.130] (**) |-->Input Device "Keyboard0"
[ 13.130] (**) |-->Input Device "Mouse0"
[ 13.130] (==) Automatically adding devices
[ 13.130] (==) Automatically enabling devices
[ 13.130] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 13.130] Entry deleted from font path.
[ 13.130] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
[ 13.130] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 13.130] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 13.130] (WW) Disabling Keyboard0
[ 13.130] (WW) Disabling Mouse0
[ 13.130] (II) Loader magic: 0x7d17a0
[ 13.130] (II) Module ABI versions:
[ 13.130] X.Org ANSI C Emulation: 0.4
[ 13.130] X.Org Video Driver: 8.0
[ 13.130] X.Org XInput driver : 11.0
[ 13.130] X.Org Server Extension : 4.0
[ 13.131] (--) PCI: (0:13:0:0) 10de:06e4:1682:229b rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xdc000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/131072
[ 13.131] (--) PCI:*(0:31:5:0) 1a03:2000:108e:484c rev 16, Mem @ 0xdf800000/8388608, 0xdf7e0000/131072, I/O @ 0x0000ec00/128
[ 13.131] (II) Open ACPI successful (/var/run/acpid.socket)
[ 13.131] (II) LoadModule: "extmod"
[ 13.144] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 13.144] (II) Module extmod: vendor="X.Org Foundation"
[ 13.144] compiled for 1.9.0, module version = 1.0.0
[ 13.144] Module class: X.Org Server Extension
[ 13.144] ABI class: X.Org Server Extension, version 4.0
[ 13.144] (II) Loading extension MIT-SCREEN-SAVER
[ 13.144] (II) Loading extension XFree86-VidModeExtension
[ 13.144] (II) Loading extension XFree86-DGA
[ 13.144] (II) Loading extension DPMS
[ 13.144] (II) Loading extension XVideo
[ 13.144] (II) Loading extension XVideo-MotionCompensation
[ 13.144] (II) Loading extension X-Resource
[ 13.144] (II) LoadModule: "dbe"
[ 13.144] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 13.144] (II) Module dbe: vendor="X.Org Foundation"
[ 13.144] compiled for 1.9.0, module version = 1.0.0
[ 13.144] Module class: X.Org Server Extension
[ 13.144] ABI class: X.Org Server Extension, version 4.0
[ 13.144] (II) Loading extension DOUBLE-BUFFER
[ 13.144] (II) LoadModule: "glx"
[ 13.144] (II) Loading /usr/lib/xorg/extra-modules/libglx.so
[ 13.407] (II) Module glx: vendor="NVIDIA Corporation"
[ 13.411] compiled for 4.0.2, module version = 1.0.0
[ 13.411] Module class: X.Org Server Extension
[ 13.411] (II) NVIDIA GLX Module 260.19.06 Mon Sep 13 04:54:41 PDT 2010
[ 13.411] (II) Loading extension GLX
[ 13.411] (II) LoadModule: "record"
[ 13.412] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 13.412] (II) Module record: vendor="X.Org Foundation"
[ 13.412] compiled for 1.9.0, module version = 1.13.0
[ 13.412] Module class: X.Org Server Extension
[ 13.412] ABI class: X.Org Server Extension, version 4.0
[ 13.412] (II) Loading extension RECORD
[ 13.412] (II) LoadModule: "dri"
[ 13.412] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 13.412] (II) Module dri: vendor="X.Org Foundation"
[ 13.412] compiled for 1.9.0, module version = 1.0.0
[ 13.412] ABI class: X.Org Server Extension, version 4.0
[ 13.412] (II) Loading extension XFree86-DRI
[ 13.412] (II) LoadModule: "dri2"
[ 13.412] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 13.412] (II) Module dri2: vendor="X.Org Foundation"
[ 13.412] compiled for 1.9.0, module version = 1.2.0
[ 13.412] ABI class: X.Org Server Extension, version 4.0
[ 13.412] (II) Loading extension DRI2
[ 13.412] (II) LoadModule: "nvidia"
[ 13.412] (II) Loading /usr/lib/xorg/extra-modules/nvidia_drv.so
[ 13.441] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 13.443] compiled for 4.0.2, module version = 1.0.0
[ 13.443] Module class: X.Org Video Driver
[ 13.455] (II) NVIDIA dlloader X Driver 260.19.06 Mon Sep 13 04:31:43 PDT 2010
[ 13.455] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 13.455] (++) using VT number 7

[ 13.457] (EE) No devices detected.
[ 13.457]
Fatal server error:
[ 13.457] no screens found
[ 13.457]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 13.457] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 13.457]


Tried specifying the BusID (from lspci) in the xorg.conf file but it didn't help :(.

I have two VGA devices in lspci, my 8400 GS and the Sun X4170 M2 server integrated graphics:



0d:00.0 VGA compatible controller: nVidia Corporation G98 [GeForce 8400 GS] (rev a1) (prog-if 00 [VGA controller])
Subsystem: XFX Pine Group Inc. Device 229b
Physical Slot: 1
Flags: bus master, fast devsel, latency 0, IRQ 24
Memory at de000000 (32-bit, non-prefetchable) [size=16M]
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at dc000000 (64-bit, non-prefetchable) [size=32M]
I/O ports at cc00 [size=128]
Expansion ROM at dbfe0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Kernel driver in use: nvidia
Kernel modules: nvidia, nvidia-current, nvidia-173, nouveau, nvidiafb

1f:05.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 10) (prog-if 00 [VGA controller])
Subsystem: Sun Microsystems Computer Corp. Device 484c
Flags: medium devsel, IRQ 10
Memory at df800000 (32-bit, non-prefetchable) [size=8M]
Memory at df7e0000 (32-bit, non-prefetchable) [size=128K]
I/O ports at ec00 [size=128]
Expansion ROM at <unassigned> [disabled]
Capabilities: [40] Power Management version 3


Anyone have any ideas?

Thanks,
Derek

Neoxhadowespio
June 7th, 2011, 12:51 AM
I've heard a lot of problems with Nvidia. Best of luck :)

fi2
June 11th, 2011, 09:24 AM
It looks like the problem is not with the nvidia drivers, but the dual nvidia-optimus video controller. There is a detailed explanation here:

http://ubuntuforums.org/showthread.php?t=1657660&highlight=nvidia+optimus

I haven't tried bumblebee yet, but on their site there is an ever growing compatibility list with some Asus models too.

StartedTheFire
July 25th, 2011, 02:53 AM
fi2, I'm so glad you posted that! I had the same problems as OP and finally it makes sense! Additionally, bumblebee seems to have completely solved it. This is the most successful I've ever been at anything.