PDA

View Full Version : [ubuntu] Bamboo Fun Stylus Not Being Recognized.



The_Orange
May 14th, 2011, 08:27 PM
Right before this most recent OS update, I had my Wacom Bamboo Fun working smoothly. Now it doesn't seem to be able to see the stylus.

What I mean by that is, I can use the stylus, but when options in GIMP are set for pressure sensitivity, it just doesn't do anything. When I go to Edit > Preferences in GIMP, it doesn't come up with a stylus option to edit for an input; just the "Wacbom BambooFun 4x5," which is currently set to screen. I tried both while using my touch pad and while using the stylus.

I've tried this: https://help.ubuntu.com/community/Wacom.fdi
And this: http://ubuntuforums.org/showthread.php?t=967147&highlight=wacom+tablet

I have a feeling it has something to do with this:

chelsea@chelsea-laptop:~$ dpkg -p wacom-tools | grep Version
Package `wacom-tools' is not available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

But I'm not sure what that means. Do I need to reinstall my tablet?

Favux
May 14th, 2011, 09:37 PM
Hi The_Orange,

Do you mean you upgraded from Maverick to Natty for example?

Post the outputs of xinput list and xsetwacom list entered in a terminal.

The_Orange
May 14th, 2011, 09:57 PM
Yes, Natty. I wasn't sure what it's name was. The old was was Maverick, I remember.

chelsea@chelsea-laptop:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Mouse id=11 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS GlidePoint id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Video Bus id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ Sleep Button id=8 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
↳ Dell WMI hotkeys id=13 [slave keyboard (3)]
↳ Laptop Integrated Webcam id=9 [slave keyboard (3)]
chelsea@chelsea-laptop:~$ xsetwacom list
The program 'xsetwacom' is currently not installed. You can install it by typing:
sudo apt-get install xserver-xorg-input-wacom

Favux
May 14th, 2011, 10:04 PM
Well that's weird. It's like either the wacom.ko or xf86-input-wacom isn't installed because the tablet isn't showing up in xinput list. Your tablet was plugged in when you ran xinput list, correct?

Check in Synaptic Package Manager or the Software Center that xf86-input-wacom is installed. It should have been by default so xsetwacom should be installed. Search wacom. The package is called xserver-xorg-input-wacom like the error message says.

The_Orange
May 14th, 2011, 10:12 PM
Sorry, no it wasn't. Plugged it in and ran them again:

chelsea@chelsea-laptop:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Mouse id=11 [slave pointer (2)]
⎜ ↳ AlpsPS/2 ALPS GlidePoint id=12 [slave pointer (2)]
⎜ ↳ Wacom BambooFun 4x5 id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Video Bus id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ Sleep Button id=8 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
↳ Dell WMI hotkeys id=13 [slave keyboard (3)]
↳ Laptop Integrated Webcam id=9 [slave keyboard (3)]

chelsea@chelsea-laptop:~$ xsetwacom list
The program 'xsetwacom' is currently not installed. You can install it by typing:
sudo apt-get install xserver-xorg-input-wacom



I don't ever use the Synaptic Manager, but I think it said it was installed. When I searched for it, it appeared on the left, but nothing appeared on the right. Though when I used the Software Center, I couldn't find it in Installed Items.

I'm going to venture that it's not installed?

Favux
May 14th, 2011, 10:38 PM
With it plugged in it is a least showing up in xinput list so you have the wacom.ko. I'm guessing it isn't installed because xsetwacom isn't. Which is weird because it should be installed by default. Just install it through either or enter in a terminal:

sudo apt-get install xserver-xorg-input-wacom
and reboot.

The_Orange
May 15th, 2011, 12:21 AM
Works like a dream. (= Thank you so much!

The_Orange
May 17th, 2011, 03:26 AM
Gah, apparently I was too fast to say it was working. Yes, it works as far as pressure sensitivity, but now I'm unable to pick different tools in the tool bar of GIMP; mouse pad or stylus, neither work. Doesn't make a difference if I open GIMP with the stylus or the mouse; I can't pick different tools.

Favux
May 17th, 2011, 05:16 AM
Not good. I'll have to look at that in Natty. It seems to me I was having problems with tool selection in Gimp with Maverick. The assignments didn't seem to stick like before. I assumed I was doing, or had done, something wrong with the Gimp Save file but didn't really look into it because with a little finagling I could get it to do what I wanted. So it could be a Gimp bug, or a GTK+ bug, or a xf86-input-wacom bug, or something else.

The_Orange
May 19th, 2011, 01:18 AM
Hope it's not too big of a bug! (=

Favux
May 19th, 2011, 06:21 PM
It seems a little balky to me. I'll have to change the focus off the tool palette sometimes before it will let me change tools.

I'm going to guess this is a Natty Unity problem. So it may go away if you chose Classic. And maybe turned off effects.

The_Orange
May 20th, 2011, 01:04 AM
I turned off the minimize effects a long time ago. I assume the drop shadow effect is with that, but I can't seem to remember where to go to get rid of it.