PDA

View Full Version : [ubuntu] Ping reply, but can not Remote Desktop Connect



lemon1707
May 8th, 2011, 05:19 AM
Hi everybody,
I'm in the process of setting up Cloud Coputing, Itís my thesis. I had installed CLC,CC,SC,Walrus,Nc on single machine, but that topology doesn't support for EBS ( Elastic Blocked Storage). I trying to setup Cloud on 2 machines with Ubuntu 11.04 Natty, each machine just have one Nic.
On Dell studio 1558 ( CC,CLC,SC,Walrus)
CC Interfaces :
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

auto br0iface br0 inet static address 192.168.1.35 network 192.168.1.0 netmask 255.255.255.0 broadcast 192.168.1.255 gateway 192.168.1.1 bridge_ports eth0 bridge_stp off bridge_fd 0 bridge_maxwait 0Eucalyptus.conf on Front end # Affects: All
# See: **NOTE** below
EUCALYPTUS="/"
EUCA_USER="eucalyptus"

# Affects: CLC, Walrus, SC
DISABLE_DNS="Y"
CLOUD_OPTS="-Xmx512m"

# Affects: SC
DISABLE_EBS="N"
DISABLE_ISCSI="N"

# Affects: CC, NC
# See: **NOTE** below
ENABLE_WS_SECURITY="Y"
LOGLEVEL="DEBUG"
VNET_PUBINTERFACE="eth0"
VNET_PRIVINTERFACE="eth0"
VNET_MODE="MANAGED-NOVLAN"

# Affects: CC
# See: **NOTE** below
CC_PORT="8774"
SCHEDPOLICY="ROUNDROBIN"
POWER_IDLETHRESH="300"
POWER_WAKETHRESH="300"
NC_SERVICE="axis2/services/EucalyptusNC"
VNET_DHCPDAEMON="/usr/sbin/dhcpd3"
VNET_DHCPUSER="dhcpd"
DISABLE_TUNNELLING="N"
NODES="192.168.1.34"
VNET_ADDRSPERNET="32"
VNET_SUBNET="172.19.0.0"
VNET_NETMASK="255.255.255.0"
VNET_DNS="192.168.1.1"
VNET_PUBLICIPS="192.168.1.100-192.168.1.200"

# Affects: NC
NC_PORT="8775"
HYPERVISOR="kvm"
MANUAL_INSTANCES_CLEANUP=0
VNET_BRIDGE="br0"
INSTANCE_PATH="/var/lib/eucalyptus/instances/"
USE_VIRTIO_NET="0"
USE_VIRTIO_DISK="1"
USE_VIRTIO_ROOT="0"
#MAX_MEM=2048
#MAX_CORES="2"
#MAX_DISK="100"
Eucalyptus.local.conf on Front end # /etc/eucalyptus/eucalyptus.local.conf

# This file is read and written by euca_conf
# WARNING: You should *never* edit this file directly.

# To modify Eucalyptus parameters, either use euca_conf( 8 , or
# edit /etc/eucalyptus/eucalyptus.conf according to eucalyptus.conf(5).


# network configuration from the input configuration file
VNET_MODE="MANAGED-NOVLAN"
VNET_SUBNET="172.19.0.0"
VNET_NETMASK="255.255.255.0"
VNET_DNS="192.168.1.1"
VNET_ADDRSPERNET="32"
VNET_PUBLICIPS="192.168.1.100-192.168.1.200"

On Dell studio 1555( Node Controller)
Interfaces file
Vim /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

auto br0iface br0 inet static address 192.168.1.34 network 192.168.1.0 netmask 255.255.255.0 broadcast 192.168.1.255 gateway 192.168.1.1 bridge_ports eth0 bridge_stp off bridge_fd 0 bridge_maxwait 0 Eucalyptus.conf
# /etc/eucalyptus/eucalyptus.conf
#
# These are the Ubuntu Enterprise Cloud's default Eucalyptus parameters.

# Affects: All
# See: **NOTE** below
EUCALYPTUS="/"
EUCA_USER="eucalyptus"

# Affects: CLC, Walrus, SC
DISABLE_DNS="Y"
CLOUD_OPTS="-Xmx512m"

# Affects: SC
DISABLE_EBS="N"
DISABLE_ISCSI="N"

# Affects: CC, NC
# See: **NOTE** below
ENABLE_WS_SECURITY="Y"
LOGLEVEL="DEBUG"
VNET_PUBINTERFACE="br0"
VNET_PRIVINTERFACE="br0"
VNET_MODE="MANAGED-NOVLAN"

# Affects: CC
# See: **NOTE** below
CC_PORT="8774"
SCHEDPOLICY="ROUNDROBIN"
POWER_IDLETHRESH="300"
POWER_WAKETHRESH="300"
NC_SERVICE="axis2/services/EucalyptusNC"
VNET_DHCPDAEMON="/usr/sbin/dhcpd3"
VNET_DHCPUSER="dhcpd"
DISABLE_TUNNELLING="N"
NODES="192.168.1.34"
VNET_ADDRSPERNET="32"
#VNET_SUBNET=""
#VNET_NETMASK=""
#VNET_DNS=""
#VNET_PUBLICIPS="Ē

# Affects: NC
NC_PORT="8775"
HYPERVISOR="kvm"
MANUAL_INSTANCES_CLEANUP=0
VNET_BRIDGE="br0"
INSTANCE_PATH="/var/lib/eucalyptus/instances/"
USE_VIRTIO_NET="0"
USE_VIRTIO_DISK="1"
USE_VIRTIO_ROOT="0"
#MAX_MEM=2048
#MAX_CORES="2"
#MAX_DISK="100"

cat eucalyptus.local.conf
cloud@uec02:/etc/eucalyptus$ cat eucalyptus.local.conf
# /etc/eucalyptus/eucalyptus.local.conf

# This file is read and written by euca_conf( 8 )
# WARNING: You should *never* edit this file directly.

# To modify Eucalyptus parameters, either use euca_conf( 8 ) , or
# edit /etc/eucalyptus/eucalyptus.conf according to eucalyptus.conf(5).

When I run image with Hybridfox, the instance have 2 IPs : public 192.168.1.100, private 172.19.1.2, but when I view the nc.log on Node, something appear like the instane canít get public IP. The instance is always running state and I can Ping 192.168.1.100 from the other computer, but I can not Remote Desktop Connection to the instance. ( I enabled the remote desktop for image when I bundle It and open port to RDP)
Any ideas for this solution ?
The view of nc.log
[Sun May 8 10:45:02 2011][EUCADEBUG] dodescribeInstances(): instanceId=i-2C0706DA publicIP=0.0.0.0 privateIp=172.19.1.2 mac=D0 : 0D : 2C : 07 : 06 : DA vlan=10 networkIndex=2

kim0
May 10th, 2011, 01:46 PM
All ports are by default closed for security reasons. So, you probably want to use euca-authorize to open RDP ports?

lemon1707
May 11th, 2011, 04:01 AM
thank for replying kim0,
I had already opened RDP port ( also http,ssl, icmp ports ). I think I didn't install kvm-pxe package, It allows VMs connect to Internet and the machine outsite can connect into VMs. But when I reinstall, the VMs always pending state and then terminated. I didn't create br0 as above configuration. Is that problem ?

Please clarify it !!!

kim0
May 12th, 2011, 03:59 PM
Hi,
I don't think the kvm-pxe package is related to the problems you're seeing. Also I'm not clear what's the status .. Does the instance boot, does it get an IP, is it reachable from CC/CLC, is it reachable from outside .. etc

lemon1707
May 13th, 2011, 03:31 AM
Sorry kim0,
I had reinstalled system, and then maked another problem in http://ubuntuforums.org/showthread.php?t=1756331. Can you give me some infomation to solve that ?