PDA

View Full Version : 2.6.39 doesn't not obey „text“ switch...



zika
May 5th, 2011, 08:08 AM
I've noticed this morning that 2.6.39 (-999, -0.5{server, generic}) do not uset „text“ switch in kernel line, that is present in grub.cfg in all lines...
Anyone else?
Update: Same is with 2.6.38-lowlatency, so it looks like a change is somewhere else. It worked in NN...
Not to mention that (automatic) choice of older kernel(s), that did not work since a long time is, still, not working...

dino99
May 5th, 2011, 08:37 AM
i dont use it from the "daily" but either from repo or ppa: i've not seen such issue, and will have rc6 soon

zika
May 10th, 2011, 03:20 PM
i dont use it from the "daily" but either from repo or ppa: i've not seen such issue, and will have rc6 soonIt happens with any kernel, as far as I've tried. While awaiting a solution I've commented „gdm“ in /etc/X11/default-display-manager... :)

sisco311
May 11th, 2011, 06:01 PM
In natty and oneiric you can disable an upstart job with a .override file:

echo manual | sudo tee -a /etc/init/gdm.override

See:
http://upstart.ubuntu.com/cookbook/#ubuntu-natty-override-files-ubuntu-transient
and
http://upstart.at/2011/03/11/override-files-in-ubuntu-natty/

zika
May 11th, 2011, 07:00 PM
In natty and oneiric you can disable an upstart job with a .override file:

echo manual | sudo tee -a /etc/init/gdm.overrideSee:
http://upstart.ubuntu.com/cookbook/#ubuntu-natty-override-files-ubuntu-transient
and
http://upstart.at/2011/03/11/override-files-in-ubuntu-natty/
Nice. Thank You! I'll try it!

Update: I gave it a try and it works very nice... Good tip and I, really, appreciate it... Thank You, again...
I've been turning services off, without un-installing them, by moving .conf files from /etc/init... This is much easier and more transparent for bookkeeping...

zika
May 13th, 2011, 02:43 PM
In natty and oneiric you can disable an upstart job with a .override file:

echo manual | sudo tee -a /etc/init/gdm.overrideSee:
http://upstart.ubuntu.com/cookbook/#ubuntu-natty-override-files-ubuntu-transient
and
http://upstart.at/2011/03/11/override-files-in-ubuntu-natty/What about /etc/init.d ... ?

(Apart from #update-rc.d -f apparmor remove...
I use, there, still, method of moving files from that folder to somewhere „safe“...)

MAFoElffen
May 19th, 2011, 07:56 AM
I've noticed this morning that 2.6.39 (-999, -0.5{server, generic}) do not uset „text“ switch in kernel line, that is present in grub.cfg in all lines...
Anyone else?
Update: Same is with 2.6.38-lowlatency, so it looks like a change is somewhere else. It worked in NN...
Not to mention that (automatic) choice of older kernel(s), that did not work since a long time is, still, not working...
Syntax? I run that switch as " text " and has been working fine... Been coming up fine in TTY Text console.

zika
May 19th, 2011, 02:11 PM
Syntax? I run that switch as " text " and has been working fine... Been coming up fine in TTY Text console.
Lucky You. I think it is the same even after reinstall, not sure, I've made gdm.override as one of the first things after reinstalling to NN, after udev breakage and need to get the control over the whole disk (Win is definitely gone after almost 2 years of just taking the space, not more than two entries, just to upgrade, from boredom ...)

dino99
May 19th, 2011, 03:12 PM
so check about locale settings (utf8 ?)

NormanFLinux
May 19th, 2011, 06:01 PM
The nice thing about upgrading the kernel is it fixed Broadcom card hell and gave me back a usable Natty desktop.

zika
May 19th, 2011, 06:52 PM
so check about locale settings (utf8 ?)Check... It's not that...
I do not, even, mind about that glitch... :)