PDA

View Full Version : [SOLVED] 11.04 Natty wireless issue - Acer - Device not ready



abisdad
May 1st, 2011, 04:03 AM
:-) Hi - I've tried looking through other posts but haven't found a solution as yet, so sorry to put this one out there...

I've an Acer TravelMate TM8372T with 802.11 a/b/g/n and have had 10.10 on which worked fine before, but then windows stuffed up, and my IT dept re-imaged it with Win 7:( After I reinstalled and upgraded to 11.04 I cannot get wireless on 11.04 (but on Win 7, it works fine!)...

Initially my wireless light was off.

According to the drop down networking icon initially it was
wireless turned offbut after trying the Fn+F3 button a few times and the wireless button that changed, so it now states
Wireless Networks device not readyalthough sometimes it changes for a second to
Connect to hidden network & Create new wireless networkwhile pressing the Fn+F3, but changes back too fast to select...


I have also ticked Enable Wireless in the list too.


I typed lspci and had this:

01:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM57760 Gigabit Ethernet PCIe (rev 01)



If I do ifconfig I can see:

wlan0 Link encap:Ethernet HWaddr 00:27:10:0x:0x:0x
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

which I take to mean that I have an device which is recognized.


I have run Addition Drivers, but it tells me there are no proprietary drivers in use on the system.


I can get the wireless LED to come on by entering
sudo ifconfig wlan0 up and to go off using
sudo ifconfig wlan0 downbut this doesn't help me to connect.


I have also tried
sudo ifconfig wlan0 up but that didn't seem to do anything.


I've set up a Wireless Network Connection with a WPA & WPA2 Personal key, which I copied from another Ubuntu machine I have, and I have double checked the key, but I don't think this is relevant as the Network drop down list still has
Wireless Networks device not ready grayed out.


I think that my card has been found and drivers installed, but is somehow turned off. If anyone can help me I'll be very grateful.

Thanks,

Rob.

UPDATE 14/5/2011.

Still not working, but I've found that if you do a sudo rfkill list all, then it shows:

0: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no

If I use the Fn+F3 button, while watching the output from "rfkill event" I see it change to:

13053645xx.xxxxxx: idx 0 type 1 op 2 soft 0 hard 0
13053645xx.xxxxxx: idx 2 type 1 op 2 soft 0 hard 0
13053645xx.xxxxxx: idx 2 type 1 op 2 soft 0 hard 0
13053645xx.xxxxxx: idx 0 type 1 op 2 soft 1 hard 0

(Do this by opening two different Terminal screens, and run "sudo rfkill event" in one, and then you can do other rfkill commands in the other one, while watching the output in the first screen.)

It's as if it is being turned on, but then something is automatically re-soft blocking almost immediately I unblock it, by either using the "Fn+F3" or "sudo rfkill unblock all".


Please help as it's a bit embarrassing, I'm trying to get a class of gifted kids into linux on desktops and their teacher can't even connect to the wireless! :oops:


UPDATE 15/5/2011.

Just read this post: "Wireless disabled by hardware switch" bug? - Natty (http://ubuntuforums.org/showthread.php?t=1753072&highlight=rfkill) and have got this output for "dmesg | grep iwl":


rob@robtintech:~$ dmesg | grep iwl
[ 15.925638] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[ 15.925643] iwlagn: Copyright(c) 2003-2010 Intel Corporation
[ 15.925717] iwlagn 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 15.925728] iwlagn 0000:01:00.0: setting latency timer to 64
[ 15.925766] iwlagn 0000:01:00.0: Detected Intel(R) Centrino(R) Advanced-N 6200 AGN, REV=0x74
[ 15.942097] iwlagn 0000:01:00.0: device EEPROM VER=0x436, CALIB=0x6
[ 15.942102] iwlagn 0000:01:00.0: Device SKU: 0Xb
[ 15.943197] iwlagn 0000:01:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[ 15.943283] iwlagn 0000:01:00.0: irq 41 for MSI/MSI-X
[ 16.068803] iwlagn 0000:01:00.0: loaded firmware version 9.221.4.1 build 25532
[ 16.083562] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[ 199.600594] iwlagn 0000:01:00.0: RF_KILL bit toggled to enable radio.
[ 200.095805] iwlagn 0000:01:00.0: Failing on timeout while stopping DMA channel 1 [0xa5a5a5a2]
[ 200.101538] iwlagn 0000:01:00.0: Failing on timeout while stopping DMA channel 3 [0xa5a5a5a2]
[ 200.107182] iwlagn 0000:01:00.0: Failing on timeout while stopping DMA channel 4 [0xa5a5a5a2]
[ 200.112915] iwlagn 0000:01:00.0: Failing on timeout while stopping DMA channel 6 [0xa5a5a5a2]
[ 245.597524] iwlagn 0000:01:00.0: RF_KILL bit toggled to disable radio.
[ 247.674860] iwlagn 0000:01:00.0: RF_KILL bit toggled to enable radio.

...and this for: "lsmod | grep -e acer -e wmi"


rob@robtintech:~$ lsmod | grep -e acer -e wmi
snd_rawmidi 25269 1 snd_seq_midi
acer_wmi 23123 0
sparse_keymap 13666 1 acer_wmi
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 55295 13 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec ,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,s nd_seq_device


Still think something is turning it off all the time...

Any suggestions gratefully considered... [-o<

chili555
May 14th, 2011, 05:29 PM
Please let us see:
sudo rmmod -f acer-wmi
sudo rfkill unblock all
rfkill list allDoes your wireless work now? We can amend two files and make it permanent.

abisdad
May 14th, 2011, 05:47 PM
Chili555 - you're magic! I thought it was something easy! I'm now using the link, instead of copying stuff to post by USB! :-)


rob@robtintech:~$ sudo rfkill unblock all
rob@robtintech:~$ sudo rfkill list all
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

So how do I make this permanent? (and what did you just get me to do?)

Also will this affect my wired LAN when I get back to work?

Thanks again! :-)

Rob.

herry12
May 14th, 2011, 05:55 PM
Wow.... Nice Tips. These tips are ver useful. Thanks for sharing this informative information. Please keep sharing more and more information.

Thanks
Have a nice time ahead.


krogen krogragg dating festa (http://www.krogragg.com/)

chili555
May 14th, 2011, 06:10 PM
So how do I make this permanent? (and what did you just get me to do?)
sudo su
echo "blacklist acer-wmi" >> /etc/modprobe.d/blacklist.conf
gedit /etc/rc.localAdd one line above Exit 0
rfkill unblock allProofread, save and close gedit.
exitI got you to remove the mis-behaving acer-wmi module that is supposed to recognize the press of the wireless key and translate its meaning to the kernel. It sometimes doesn't work so well, so we simply remove it. I doubt it will have any effect on wired ethernet.

abisdad
May 14th, 2011, 06:47 PM
Hi Chili555, did that:

blacklist.conf:



# Added with typo by Rob 15/5/2011 to fix wireless as per chili555
[-X
backlist acer-wmi

******* N.B. I've edited this the next morning to highlight typo in RED - moral = got to bed earlier... ********

and in rc.local


# Added by Rob 15/5/2011 to fix wireless as per chili555
rfkill unblock all


then rebooted, but still didn't work until I did:
sudo rmmod -f acer-wmi
sudo rfkill unblock all


:-( Sorry, but any other ideas how to make it permanent?

Thanks,

Rob - being dragged to bed by grumpy, loving wife - it's 03.15am! Check again tomorrow...

chili555
May 14th, 2011, 06:50 PM
but any other ideas how to make it permanent?Just one:
# Added by Rob 15/5/2011 to fix wireless as per chili555
backlist acer-wmi
# Added by Rob 15/5/2011 to fix wireless as per chili555
blacklist acer-wmi

abisdad
May 15th, 2011, 02:14 AM
Chili555 you're a :KS,

:guitar:

Thank you soooooooooooo much!

That is fantastic, and now works a dream - once I fixed the typo! :redface:

Rob.

GMNesje
May 21st, 2011, 04:10 PM
Thanks, great!!

this also works for Lenovo Ideapad S12 (atom)

shokalabutcha
June 14th, 2011, 09:22 AM
I had a similar problem: Whenever I did "rfkill unblock all", my wireless would go from
Soft blocked: Yes
Hard blocked: No

to

Soft blocked: No
Hard blocked: Yes

Tantalizing, isn't it? In the end, I created the following script as a (barely acceptable) solution:

sudo rmmod -f ath5k
sudo rfkill unblock all
sudo odprobe ath5k

I hope this script helps someone. In the time being, if anybody knows how to make this permanent, that will be much appreciated.

I am using a Natty Narwhal, (Ubuntu 11.04) running on Fujitsu Siemens Amilo PA3515 with an Atheros AR5001 wireless module.

Hope this helps,
Shoka

Soec
June 14th, 2011, 10:19 AM
I had a similar problem: Whenever I did "rfkill unblock all", my wireless would go from
Soft blocked: Yes
Hard blocked: No

to

Soft blocked: No
Hard blocked: Yes

Tantalizing, isn't it? In the end, I created the following script as a (barely acceptable) solution:

sudo rmmod -f ath5k
sudo rfkill unblock all
sudo odprobe ath5k

I hope this script helps someone. In the time being, if anybody knows how to make this permanent, that will be much appreciated.

I am using a Natty Narwhal, (Ubuntu 11.04) running on Fujitsu Siemens Amilo PA3515 with an Atheros AR5001 wireless module.

Hope this helps,
Shoka
I have almost the same problem, but your script doesn't help me... :( It happened to me whenever I disabled/enabled wireless again. Thank you anyway.

More info: http://ubuntuforums.org/showthread.php?t=1781350

chili555
June 14th, 2011, 01:16 PM
It's not tantalizing; it's maddening! However, it is wonderful that you found a fix. I think you will help a lot of searchers.
In the time being, if anybody knows how to make this permanent, that will be much appreciated.Please do:
sudo gedit /etc/rc.localAdd your three lines above exit 0 without sudo:
rmmod -f ath5k
rfkill unblock all
modprobe ath5kProofread carefully, save and close gedit. Reboot and tell us if it's working as expected.

shokalabutcha
June 21st, 2011, 11:26 AM
Thanks Chili, just added those to rc.local, and it works perfectly.

I had thought that rc.local wasn't supposed to be used, that we all should use update-rc.d, but I guess whatever works, works.

daydream
July 8th, 2011, 05:25 PM
This has worked like a charm for me too!

Thanks so much for your help shokalabutcha and chili555! :KS :KS :KS
Wifi missing was a real nightmare

vijaym
July 11th, 2011, 10:00 PM
Finally... thanks for the fix chili555. My acer tm8372t now has wifi.

vycas
September 17th, 2011, 07:01 PM
Please let us see:
sudo rmmod -f acer-wmi
sudo rfkill unblock all
rfkill list allDoes your wireless work now? We can amend two files and make it permanent.

Hey Chilli, I need your help. I had the same issue with acer-wmi blocking my sony-wifi in software switch. I followed your commands:



sudo rmmod -f acer-wmi
sudo rfkill unblock all
rfkill list all

and it worked, and i could see my wireless and it was working and everything was working and fine.

In order to make it permanent i then did


sudo gedit /etc/modprobe.d/blacklist.conf

added line in the end


blacklist acer-wmi


sudo gedit /etc/rc.local
rfkill unlock all

and when i rebooted. I do not see any phy0 in 'rfkill list all' output and there is no wireless option in panel.

It seems my drivers are gone or what i do not know.

Here is the current rfkill list all output:

vycas@vycas-VPCYA15FG:~$ rfkill list all
1: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
2: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Also the lspci output (it sees the ath9k wireless)



vycas@vycas-VPCYA15FG:~$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Atheros Communications AR8131 Gigabit Ethernet (rev c0)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
vycas@vycas-VPCYA15FG:~$


It worked with those 3 commands. The moment i tried to make it permanent. it messed up.

Vycas

Wild Man
September 17th, 2011, 07:06 PM
Hi, so it is not working at all now? this

rfkill unlock all
should have been this

rfkill unblock all
Thank you

Wild Man
September 17th, 2011, 07:08 PM
Hi, so it is not working at all now? this

rfkill unlock all
should have been this

rmmod -f ath5k
rfkill unblock all
modprobe ath5k
Thank you

vycas
September 17th, 2011, 08:49 PM
Hi, so it is not working at all now? this

rfkill unlock all
should have been this

rmmod -f ath5k
rfkill unblock all
modprobe ath5k
Thank you

Ok i tried the

modprobe ath9k (since i have ath9k)

it reinstalled the phy0 and then i did the sudo rmmod -f acer-wmi

and it works, but only for few minutes after that it just looses too much packets. I pinged my router and it lost 70% of packets and i am literally 2 feet away from it.

After rebooting acer-wmi always appears, so i have added these commands in following sequence in /etc/rc.local

sudo rmmod -f acer-wmi
sudo modprobe ath9k

My wifi shows internet is connected, but it doesn't work. ping works but its too slow and latency is way too high.

Vycas

Wild Man
September 17th, 2011, 09:18 PM
Hi, make sure you did it just like post 12 says.

Set your router to wpa2 and not mixed mode or wep, then post back and we will go from there.
Thank you

vycas
September 18th, 2011, 02:55 AM
Hi, make sure you did it just like post 12 says.

Set your router to wpa2 and not mixed mode or wep, then post back and we will go from there.
Thank you

Hey i tried your code in /etc/rc.local


rmmod -f ath5k
rfkill unblock all
modprobe ath5k

here is the output after rebooting (net doesn't work without removing acer-wmi and installing ath9k modules) followed by my commands to make it work:

vycas@vycas-VPCYA15FG:~$ rfkill list all
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no
2: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
3: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
vycas@vycas-VPCYA15FG:~$ sudo rmmod -f acer-wmi
[sudo] password for vycas:
vycas@vycas-VPCYA15FG:~$ sudo modprobe ath5k
vycas@vycas-VPCYA15FG:~$ rfkill list all
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
2: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
3: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
vycas@vycas-VPCYA15FG:~$ sudo modprobe ath9k
vycas@vycas-VPCYA15FG:~$ rfkill list all
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
2: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
3: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
4: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
vycas@vycas-VPCYA15FG:~$

================================================== ===================

If i change the commands in /etc/rc.local to:



sudo modprobe ath9k
sudo rmmod -f acer-wmi

NOTE: i do not need
sudo rfkill unblock all since that command doesn't change anything.

then it says connected when i login and all the bars are up in my network strength, but in chrome it just don't load homepage of google. Gets stuck at sending request.

When i do nothing in /etc/rc.local .i.e. revert the changes i make and keep it back to original exit 0 state and manually enter the commands in the following sequence it works:



sudo modprobe ath9k
sudo rmmod -f acer-wmi

I do not what's the difference in manually entering the above commands or putting it in /etc/rc.local which anyway runs it automatically when i login. WONDERING


Regarding changing my router to wpa2 nand not mixed. Well i have no encryption on my router, i use mac address filtering to control access.

My problem is more like this thread and i noticed almost all of them have SONY VAIO:

http://ubuntuforums.org/showthread.php?t=1428858&highlight=atheros+9285+slow&page=2

My wireless works good when i am within 10 ft from my router. But as i start moving away, my latency in pinging to my router jumps from usual ~2ms to ~2000ms and the signal strengths starts dropping and as soon as i loose one bar .i.e. only 3 bars out of 4 are highlighted. It just stops working even though it says connected with 3 bars and starts loosing like ~50% plus packets.

Another peculiar thing is that, i got win 7 and ubuntu 11.04 on same hard drive. And when i reboot in windows after running ubuntu, the wireless don't work. In order to make the wireless work after running ubuntu, i have to physically remove the battery after shutting down ubuntu and then booting WIN 7 and it works perfectly fine and i can reboot it as many times and it works perfectly as long as iam rebooting it always in WIN 7. But the moment i boot in ubuntu and then if i reboot in WIN 7 then to make wireless work in WIN 7, i gotta remove the battery.

NOTE: In windows my wireless work even like 40 feet away from router. So i know its not the limitation of the wireless card.

I think the wireless error is in the ath9k driver with some buffer issue or something.

Any insights?

Vycas

Wild Man
September 18th, 2011, 03:03 AM
Hi, you have several things going on lets take care of them one by one.

sudo su
echo "blacklist acer-wmi" >> /etc/modprobe.d/blacklist.conf
exit

sudo su
echo ath9k >> /etc/modules
exit

sudo ifconfig wlan0 down
sudo rmmod -f ath9k
sudo modprobe ath9k nohwcrypt=1
sudo ifconfig wlan0 up
run the commands one at a time then unplug your wired connection and restart your computer and it should work.
Thank you

vycas
September 18th, 2011, 11:18 AM
Ok good news is that now my wireless work even after rebooting. Thanks a relief from manually entering the commands each time (Blacklisting acer-wmi helped).

Bad news is that ifconfig commands have no effect on wlan0 .i.e. even after doing



sudo ifconfig wlan0 down

net is still connected and working.

and the problem is persitent of moving away more than 10 feet. Worse part is that if i move back in, like 2 ft from the router the signal strength get back to all 4 from 3 but the network ping and losses stays the same .i.e. 2000ms for router ping.

The normal working for wired network is 1ms and for wireless is 2ms for my home network.

Vycas

bkratz
September 18th, 2011, 11:34 AM
Post removed--iwconfig does not have the up down commands. See

man ifconfig

and

man iwconfig

Wild Man
September 18th, 2011, 04:17 PM
Hi, that command brought my wireless down, but not for long mine is set to auto connect and in about 10 seconds it connected back.

Please post the results of this command:

lspci -nn | grep -e 0280 -e 0200
Thank you

vycas
September 19th, 2011, 06:19 PM
Sorry for the delay, was busy exploring my ubuntu. Man this thing is awesome.

Back to issue:

Here is the output for the command:


lspci -nn | grep -e 0280 -e 0200


vycas@vycas-VPCYA15FG:~$ lspci -nn | grep -e 0280 -e 0200
02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
03:00.0 Ethernet controller [0200]: Atheros Communications AR8131 Gigabit Ethernet [1969:1063] (rev c0)
vycas@vycas-VPCYA15FG:~$


By the way i think blacklisting acer-wmi solved the issue of pulling battery out everytime i boot in ubuntu and then boot in WIN 7 to make my wireless work.

I booted my WIN 7 yesterday and wireless worked flawlessly without any needs.

Vycas

Wild Man
September 19th, 2011, 06:37 PM
Hi, that is good are you still having issues with having to be close to the router? Did you run these commands then see how it worked?

sudo ifconfig wlan0 down
sudo rmmod -f ath9k
sudo modprobe ath9k nohwcrypt=1
sudo ifconfig wlan0 up
do you want to make it permanent?
Thank you

vycas
September 20th, 2011, 03:42 AM
No my wireless works flawlessly if i am within 10 ft of the router and the 4 bars green for signal strength. I have been using it all night and day. Only problem happens when i move away and signal strength drops to 3 bars. Then i have to do this again:



sudo rmmod -f ath9k
sudo modprobe ath9k



and it works back to normal again if i am within 10 ft of router.

Vycas

Wild Man
September 20th, 2011, 03:49 AM
Hi, that is what I was afraid of I just found out that those cards have poor signal strength at least in ubuntu if not all systems.

That card was tricky to get to work at all, so I guess we should be happy.

If I have been a little helpful would you consider clicking on the red link in my signature and supporting me for ubuntu membership? Also if you are happy would you please go to the top of the page and mark this thread solved by clicking on thread tools. Thank you so much.