PDA

View Full Version : [SOLVED] Samsung N130 Wireless not working in Natty



Shake 'n' Bake
April 30th, 2011, 05:19 PM
Hello, everyone.

I've installed Natty on my Samsung N130. It has the Realtek card. It's pretty good, except the wireless does not always work. It seems like it's 5 minutes on, 5 minutes off. I have already tried most of the solutions offered for previous versions of Ubuntu. The one thing I haven't tried is using ndiswrapper to install the Windows drivers because I can't find the drivers anywhere.

I had this working perfectly in Maverick using this (http://www.greenhughes.com/content/installing-ubuntu-1010-samsung-nb30-touchscreen-netbook) solution. There is no samsung-wireless for Natty (yet), so I tried using the package for Maverick to no avail. If it makes a difference, the wireless was working perfectly during the installation.

Any help is appreciated. Thank you.

jcr1
April 30th, 2011, 08:34 PM
Sorry no solution here, but I am going to be keeping an eye on this one as I have the same netbook and the same problem. Just upgraded to Natty and no wireless.

Hippytaff
April 30th, 2011, 08:35 PM
if you post the results.txt generated by the wireless script (link below) people will be able to assist :-)

Shake 'n' Bake
April 30th, 2011, 09:57 PM
I'll run that script in an hour or two. I've got to go take care of a fallen tree right now. Thanks for that.

Shake 'n' Bake
May 1st, 2011, 12:02 AM
Here are the results:



Version: 1.1 (Development)
Sat Apr 30 18:59:52 EDT 2011

************************************************** *********************************************
Running networking services
************************************************** *********************************************
NetworkManager is running
************************************
Ubuntu release
************************************

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"

************************************
Kernel
************************************

Linux NP-N130 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux
************************************
List of drivers
************************************

Module Size Used by
arc4 12473 2
easy_slow_down_manager 12985 0
parport_pc 32111 0
ppdev 12849 0
binfmt_misc 13213 1
snd_hda_codec_realtek 255820 1
snd_hda_intel 24140 2
snd_hda_codec 90901 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13274 1 snd_hda_codec
snd_pcm 80244 2 snd_hda_intel,snd_hda_codec
joydev 17322 0
snd_seq_midi 13132 0
snd_rawmidi 25269 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
snd_timer 28659 2 snd_pcm,snd_seq
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 55295 13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec, snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,sn d_seq_device
samsung_laptop 13148 0
i915 450944 3
drm_kms_helper 40745 1 i915
drm 180037 4 i915,drm_kms_helper
uvcvideo 66851 0
psmouse 73312 0
videodev 75143 1 uvcvideo
serio_raw 12990 0
soundcore 12600 1 snd
i2c_algo_bit 13184 1 i915
snd_page_alloc 14073 2 snd_hda_intel,snd_pcm
video 18951 1 i915
r8192_pci 248297 0
lp 13349 0
parport 36746 3 parport_pc,ppdev,lp
r8169 42534 0

************************************
pci wireless devices
************************************

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192E Wireless LAN Controller [10ec:8192] (rev 01)
Subsystem: Askey Computer Corp. Device [144f:7160]
Kernel driver in use: rtl819xE
Kernel modules: r8192_pci, r8192se_pci, r8192e_pci

************************************
usb wireless devices
************************************


************************************
List of network devices
************************************

*-network
description: Wireless interface
product: RTL8192E Wireless LAN Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 01
serial: 00:26:b6:31:49:e3
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl819xE ip=192.168.2.10 latency=0 multicast=yes wireless=802.11bgn
resources: irq:16 ioport:2000(size=256) memory:f0100000-f0103fff
*-network
description: Ethernet interface
product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
logical name: eth0
version: 02
serial: 00:13:77:bf:52:5e
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical
configuration: broadcast=yes driver=r8169 latency=0 multicast=yes
resources: irq:42 ioport:3000(size=256) memory:f0510000-f0510fff memory:f0500000-f050ffff memory:f0520000-f053ffff


************************************
network info
************************************

eth0 Link encap:Ethernet HWaddr 00:13:77:bf:52:5e
inet6 addr: 2002:48e2:1606:1234:213:77ff:febf:525e/64 Scope:Global
inet6 addr: fe80::213:77ff:febf:525e/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:973 errors:0 dropped:0 overruns:0 frame:0
TX packets:982 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:286342 (286.3 KB) TX bytes:129156 (129.1 KB)
Interrupt:42 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:112 errors:0 dropped:0 overruns:0 frame:0
TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9065 (9.0 KB) TX bytes:9065 (9.0 KB)

wlan0 Link encap:Ethernet HWaddr 00:26:b6:31:49:e3
inet addr:192.168.2.10 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: 2002:48e2:1606:1234:226:b6ff:fe31:49e3/64 Scope:Global
inet6 addr: fe80::226:b6ff:fe31:49e3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:16 Memory:f8040000-f8040100


************************************
Wireless specific network info
************************************

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11bgn ESSID:"Gerald"
Mode:Managed Frequency=2.412 GHz Access Point: 00:1C:DF:D4:93:68
Bit Rate=65 Mb/s
Retry:on RTS thr:off Fragment thr:off
Encryption key:7239-A0D0-1F90-1C65-E81E-0578-FF Security mode:open
Power Management:off
Link Quality=86/100 Signal level=-54 dBm Noise level=-113 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

************************************
Rfkill Blocks
************************************

0: samsung-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no

************************************

************************************************** ***********************
interfaces
************************************************** ***********************
auto lo
iface lo inet loopback


************************************************** ************************
resolv.conf
************************************************** ************************
# Generated by NetworkManager
domain Belkin
search Belkin
nameserver 192.168.2.1

************************************************** ************************
Modules file
************************************************** ************************
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
r8192_pci

************************************************** ***********************
Blacklist file
************************************************** ***********************
# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
blacklist i2c_i801

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_eda
blacklist r8192se_pci
blacklist r8192e_pci

************************************************** ************************
Files in folder /etc/modprobe.d/*
************************************************** ************************
/etc/modprobe.d/alsa-base.conf
/etc/modprobe.d/blacklist-ath_pci.conf
/etc/modprobe.d/blacklist.conf
/etc/modprobe.d/blacklist-firewire.conf
/etc/modprobe.d/blacklist-framebuffer.conf
/etc/modprobe.d/blacklist-modem.conf
/etc/modprobe.d/blacklist-oss.conf
/etc/modprobe.d/blacklist-rare-network.conf
/etc/modprobe.d/blacklist-watchdog.conf
/etc/modprobe.d/blacklist-wifi.conf

************************************************** *************************
NetworkManager.state
************************************************** *************************

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

************************************************** **************************
nm_applet_file
************************************************** **************************
/etc/NetworkManager/nm-system-settings.conf does not exist

************************************************** *************************
Route info
************************************************** *************************
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 wlan0

************************************************** ****************************
Using nm-tool
************************************************** ****************************

NetworkManager Tool

State: connected

- Device: wlan0 [Auto Gerald] -------------------------------------------------
Type: 802.11 WiFi
Driver: rtl819xE
State: connected
Default: yes
HW Address: 00:26:B6:31:49:E3

Capabilities:
Speed: 65 Mb/s

Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points (* = current AP)
*Gerald: Infra, 00:1C:DF:D4:93:68, Freq 2412 MHz, Rate 44 Mb/s, Strength 88 WEP

IPv4 Settings:
Address: 192.168.2.10
Prefix: 24 (255.255.255.0)
Gateway: 192.168.2.1

DNS: 192.168.2.1


- Device: eth0 -----------------------------------------------------------------
Type: Wired
Driver: r8169
State: unavailable
Default: no
HW Address: 00:13:77:BF:52:5E

Capabilities:
Carrier Detect: yes

Wired Properties
Carrier: off



************************************************** ****************************
Using iwlist scan
************************************************** ****************************
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:1C:DF:D4:93:68
ESSID:"Gerald"
Protocol:IEEE802.11N-24G
Mode:Master
Channel:1
Encryption key:on
Bit Rates:300 Mb/s
Extra: Rates (Mb/s): 1 2 5.5 6 11 9 12 18 24 36 48 54
Quality=87/100 Signal level=-54 dBm Noise level=-113 dBm
Extra: Last beacon: 153ms ago


************************************************** ******************************
Checking connectivity
************************************************** ******************************
sucessfully pinged 192.168.2.1
PING 192.168.2.1 (192.168.2.1) from 192.168.2.10 wlan0: 56(84) bytes of data. 64 bytes from 192.168.2.1: icmp_req=1 ttl=64 time=1.22 ms 64 bytes from 192.168.2.1: icmp_req=2 ttl=64 time=0.893 ms 64 bytes from 192.168.2.1: icmp_req=3 ttl=64 time=0.905 ms --- 192.168.2.1 ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 401ms rtt min/avg/max/mdev = 0.893/1.008/1.228/0.159 ms
sucessfully pinged 8.8.8.8
PING 8.8.8.8 (8.8.8.8) from 192.168.2.10 wlan0: 56(84) bytes of data. 64 bytes from 8.8.8.8: icmp_req=1 ttl=48 time=48.9 ms 64 bytes from 8.8.8.8: icmp_req=2 ttl=48 time=35.9 ms 64 bytes from 8.8.8.8: icmp_req=3 ttl=48 time=36.9 ms --- 8.8.8.8 ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 399ms rtt min/avg/max/mdev = 35.927/40.593/48.907/5.895 ms

************************************************** ***********************
nslookup test
************************************************** ***********************
sucessfully looked up www.google.com
Server: 192.168.2.1 Address: 192.168.2.1#53 Non-authoritative answer: www.google.com canonical name = www.l.google.com. Name: www.l.google.com Address: 74.125.115.105 Name: www.l.google.com Address: 74.125.115.106 Name: www.l.google.com Address: 74.125.115.147 Name: www.l.google.com Address: 74.125.115.99 Name: www.l.google.com Address: 74.125.115.103 Name: www.l.google.com Address: 74.125.115.104

************************************************** *****************************
wget test
************************************************** *****************************
sucessfully retrieved file www.google.com

Finished <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

http://wireless.kernel.org/en/users/Drivers


And the .txt below.

jcr1
May 1st, 2011, 09:53 AM
Hey at least your's shows wlan0

Mine doesn't even show that!

Shake 'n' Bake
May 3rd, 2011, 12:46 AM
Anybody got anything? The only thing I can think of is the wrong drivers are being loaded.

Shake 'n' Bake
May 3rd, 2011, 01:39 AM
I just tried installing the Windows drivers with ndiswrapper after finding them on the Samsung site. That didn't work. So I tried that in addition to all the other things I have done and that didn't work. If this problem can't get solved by next Sunday, I'm probably going back to 10.10, just because it works.

northd_tech
May 3rd, 2011, 02:19 AM
************************************************** *********************************************
NetworkManager is running
************************************
Ubuntu release
************************************

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"

************************************
Kernel
************************************

Linux NP-N130 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux
************************************
List of drivers
************************************

Module Size Used by
r8192_pci 248297 0
r8169 42534 0

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192E Wireless LAN Controller [10ec:8192] (rev 01)
Subsystem: Askey Computer Corp. Device [144f:7160]
Kernel driver in use: rtl819xE
Kernel modules: r8192_pci, r8192se_pci, r8192e_pci

*-network
description: Wireless interface
product: RTL8192E Wireless LAN Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 01
serial: 00:26:b6:31:49:e3
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl819xE ip=192.168.2.10 latency=0 multicast=yes wireless=802.11bgn
resources: irq:16 ioport:2000(size=256) memory:f0100000-f0103fff


wlan0 Link encap:Ethernet HWaddr 00:26:b6:31:49:e3
inet addr:192.168.2.10 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: 2002:48e2:1606:1234:226:b6ff:fe31:49e3/64 Scope:Global
inet6 addr: fe80::226:b6ff:fe31:49e3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:16 Memory:f8040000-f8040100


************************************
Wireless specific network info
************************************
wlan0 802.11bgn ESSID:"Gerald"
Mode:Managed Frequency=2.412 GHz Access Point: 00:1C:DF:D4:93:68
Bit Rate=65 Mb/s
Retry:on RTS thr:off Fragment thr:off
Encryption key:7239-A0D0-1F90-1C65-E81E-0578-FF Security mode:open
Power Management:off
Link Quality=86/100 Signal level=-54 dBm Noise level=-113 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

************************************
Rfkill Blocks
************************************

0: samsung-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no

************************************

************************************************** ************************
Modules file
************************************************** ************************
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
r8192_pci

************************************************** ***********************
Blacklist file
************************************************** ***********************
# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

blacklist r8192se_pci
blacklist r8192e_pci

************************************************** ************************
Files in folder /etc/modprobe.d/*
************************************************** ************************
/etc/modprobe.d/alsa-base.conf
/etc/modprobe.d/blacklist-ath_pci.conf
/etc/modprobe.d/blacklist.conf
/etc/modprobe.d/blacklist-firewire.conf
/etc/modprobe.d/blacklist-framebuffer.conf
/etc/modprobe.d/blacklist-modem.conf
/etc/modprobe.d/blacklist-oss.conf
/etc/modprobe.d/blacklist-rare-network.conf
/etc/modprobe.d/blacklist-watchdog.conf
/etc/modprobe.d/blacklist-wifi.conf

************************************************** *************************
NetworkManager.state
************************************************** *************************

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

************************************************** **************************
nm_applet_file
************************************************** **************************
/etc/NetworkManager/nm-system-settings.conf does not exist

************************************************** *************************
Route info
************************************************** *************************
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 wlan0

************************************************** ****************************
Using nm-tool
************************************************** ****************************

NetworkManager Tool

State: connected

- Device: wlan0 [Auto Gerald] -------------------------------------------------
Type: 802.11 WiFi
Driver: rtl819xE
State: connected
Default: yes
HW Address: 00:26:B6:31:49:E3

Capabilities:
Speed: 65 Mb/s

Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points (* = current AP)
*Gerald: Infra, 00:1C:DF:D4:93:68, Freq 2412 MHz, Rate 44 Mb/s, Strength 88 WEP

IPv4 Settings:
Address: 192.168.2.10
Prefix: 24 (255.255.255.0)
Gateway: 192.168.2.1

DNS: 192.168.2.1


- Device: eth0 -----------------------------------------------------------------
Type: Wired
Driver: r8169
State: unavailable
Default: no
HW Address: 00:13:77:BF:52:5E

Capabilities:
Carrier Detect: yes

Wired Properties
Carrier: off

************************************************** ****************************
Using iwlist scan
************************************************** ****************************
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:1C:DF:D4:93:68
ESSID:"Gerald"
Protocol:IEEE802.11N-24G
Mode:Master
Channel:1
Encryption key:on
Bit Rates:300 Mb/s
Extra: Rates (Mb/s): 1 2 5.5 6 11 9 12 18 24 36 48 54
Quality=87/100 Signal level=-54 dBm Noise level=-113 dBm
Extra: Last beacon: 153ms ago

That's my old "friend"- a Realtek 8192E! The good news- you do have wireless connectivity and that wireless is a LOT easier under 32-bit.

It looks to me like we need to get rid of that conflicting "r8169" Realtek module that I highlighted in red. Try the following terminal commad:


sudo rmmod r8169Then disconnect your ethernet cable and see if your wireless connection behaves better. If so, we will need to blacklist "r8169" in your /etc/modprobe.d/blacklist.conf file. Sometimes it takes a few minutes for the wireless changes to take effect.

I've got a copy of a relative's "blacklist.conf" file with the changes that I needed to make to get the Realtek 8192E working under 64-bit Ubuntu, but I'll need to locate a couple of USB thumb drives first.

NOTE: One thing you will want to watch- the Realtek 8192E is quite different from the Realtek 8192SE (as well as the USB Reatlek 8192SU). This affects the driver modules, and your blacklisting, etc.

EDIT: Here are the lines that I added to my relative's Realtek 8192E /etc/modprobe.d/blacklist.conf file to finally get wireless working (under both 32-bit and 64-bit Ubuntu 10.xx and 9.xx):
# Attempting to get Realtek 8192E WiFi working under 32 bit 9.04
# blacklist r8192e_pci
# blacklist r8192se_pci
# working per "nyash" on Feb 22 2011 at post #32
# http://ubuntuforums.org/showpost.php?p=10484465&postcount=32
# http://ubuntuforums.org/showthread.php?t=1689148&page=4
blacklist r8192e_pci
blacklist r8192se_pci

Shake 'n' Bake
May 3rd, 2011, 08:09 PM
Thank you so much! I did both "sudo rmmod r8169" and the blacklist changes and the wireless is working perfectly, so far. I'll mark it solved if it's still working ten minutes or so from now.

Shake 'n' Bake
May 3rd, 2011, 10:19 PM
It appears I've spoken too soon. After about half an hour of working, it just stopped. So I did a fresh install and I'm trying everything over again. None of it has worked, unfortunately.

I did notice that when I blacklist r8169 with the two others (and I'm testing on its own now), my wireless card is not even recognized.

EDIT: When I blacklist just "r8169", the wireless appears, but does not connect. When I blacklist just "r8169_pci", the wireless simply does not appear.

northd_tech
May 4th, 2011, 05:35 AM
How did you make your blacklist changes exactly? The sudo/su thing might have prevented the changes from being saved (most editors like gedit and Kate will open the "system" files as read only if you don't "promote" the file permissions).

It might be good to post the results of this command (and review the changes in your system fairly often to see if/which modules disappear and/or reappear while your wireless is/isn't working):


lsmod | grep 81Have you tried building the module(s) directly from the Realtek sourcecode that was in the #comments of my recent blacklist post? That's the ONLY way that I was able to get that Realtek 8192E working (but that was under both Ubuntu 9.xx and 10.xx).

Once again, that sourcecode was at post #34 by "eldergs":
http://ubuntuforums.org/showpost.php?p=10487458&postcount=34

I summarized my blacklisting stuff at post #44 on that same thread:
http://ubuntuforums.org/showpost.php?p=10760256&postcount=44

northd_tech
May 4th, 2011, 06:42 AM
If this problem can't get solved by next Sunday, I'm probably going back to 10.10, just because it works.

If you eventually plan to reinstall anyway, I'd consider 10.04 LTS (with LTS meaning Long Term Support, read by me as "much less futzing with your kernel modules, drivers, etc." ;) ).

https://wiki.ubuntu.com/LTS

Just my $0.02 U.S....

Shake 'n' Bake
May 4th, 2011, 08:01 PM
Here are the results of "lsmod | grep 81":



r8192e_pci 251260 0
r8169 42534 0
I'm going to try building the modules right now. Thanks again for your help.

EDIT: Building the module from scratch seems like it has worked perfectly (for now). I'm going to install some software and if it keeps working I'd say its fixed. Thanks.

EDIT 2: It is working perfectly. Thank you so much for your help.