PDA

View Full Version : [SOLVED] 10.04, Toshiba Satellite C655, speakers don't mute when headphones are plugged in.



abeam
April 19th, 2011, 03:16 AM
I seem to remember my speakers muting before when I plugged my headphones in, but not anymore. By searching the forums I found this link:

https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules

. . . and I followed it through until I got to this command:

sudo apt-get install linux-alsa-driver-modules-$(uname -r)

. . . at which point it told me that it could not find the needed package (linux-alsa-driver-modules-2.6.32-30-generic). I've got no leads and I'm flying early tomorrow, so it'd be really nice if I could get my headphones working before then.

varunendra
April 19th, 2011, 08:22 AM
Well, apparently the module for 2.6.32-30-.... isn't there:
http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu/pool/main/l/linux-alsa-driver-modules-2.6.32/

So it suggests to me that you may need to upgrade your kernel to 2.6.32-35-..... (or downgrade to 2.6.32-29.... - which is not recommendable I guess)

I am using 2.6.32-35-28, and the driver module exists for it there : http://ppa.launchpad.net/ubuntu-audio-dev/ppa/ubuntu/pool/main/l/linux-alsa-driver-modules-2.6.35/

So it seems they missed (only) your version there.. :(

Hopefully a kernel upgrade may fix things for you.

abeam
April 19th, 2011, 09:58 AM
Excuse my inexperience please, but how do I upgrade my kernel?

varunendra
April 19th, 2011, 12:38 PM
Excuse my inexperience please, but how do I upgrade my kernel?
Go through the top left menu on your desktop as follows:
System > Administration > Update Manager

Do this while being connected to internet, you may have to click "Check" button.

This will check for all available updates including newer kernel.

<Edited for correction> The kernel update is listed as linux-image-(available version)-generic. Its size is typically around 30 MB (while a complete kernel size is typically about 95-100MB) . Depending upon size of other updates, the download size may typically go upto 200 - 400 MB (assuming you haven't updated quite in a while). <Edited for correction>

You may 'uncheck' other updates to reduce download size, but all the updates are recommended if you have time for downloading all the updates.

Hope it helps.


PS:
I just figured out that perhaps the latest kernel available for Lucid (Ubuntu-10.04) is 2.6.32-30, not any higher (as per what my update manager in Lucid virtual machine is showing). So if you are using Lucid, then you may not have the option to upgrade to a higher kernel. Besides, I'm not sure if that could fix your original issue since the latest kernel update for any currently supported distro is supposed to already include all existing bug-fixes.

I guess the kernel version 2.6.35..... line is for Maverick (Ubuntu 10.10) and higher only. I may be wrong though.

abeam
April 19th, 2011, 03:36 PM
Alright, updated the kernel drivers, but no good for my issue. The problem is, as you pointed out, the alsa modules stop at 29, and I'm 30.

varunendra
April 19th, 2011, 04:00 PM
Alright, updated the kernel drivers, but no good for my issue. The problem is, as you pointed out, the alsa modules stop at 29, and I'm 30.

Pity on these everlasting sound issues!

If you still have time and good downloading speeds, why don't you try 10.10 (Maverick)? It's pretty stable now and kernel series 2.6.35..... is available for it for which better support is available including the alsa driver modules (if that could fix your problem at all!)

If you can, try its Live CD and see whether your hardware likes it or not !

Another thing is that if the auto mute was working previously, then maybe it was the kernel update that got this problem. If so, and if you haven't removed older kernels manually, then they should be sitting there to be used in case of such problems.

If you can access advanced grub menu then you may try to boot an older kernel from the boot menu list. If the advanced menu does not come up by default then you may have to press & hold 'shift' button at startup (If I remember correctly)

Temüjin
April 19th, 2011, 05:08 PM
http://ubuntuforums.org/showthread.php?t=1681577

abeam
April 23rd, 2011, 04:47 AM
Pity on these everlasting sound issues!

. . .

Another thing is that if the auto mute was working previously, then maybe it was the kernel update that got this problem. If so, and if you haven't removed older kernels manually, then they should be sitting there to be used in case of such problems.

If you can access advanced grub menu then you may try to boot an older kernel from the boot menu list. If the advanced menu does not come up by default then you may have to press & hold 'shift' button at startup (If I remember correctly)

Yeah, GRUB comes up by default, and I've got options 2.6.32-29 and .32-28. If I boot up with one of those, should my problems be fixed?

I wish I had thought of that.

varunendra
April 23rd, 2011, 04:57 AM
I'd say - just try it yourself. It 'should' work if it earlier did, but is not guaranteed.

That is, if some crucial packages have been changed during update in such a way that they are supported only by the latest kernel, then they may pose another set of problems, but it is least likely IMHO, since modules are often designed with consideration to backward compatibility as far as possible.

Besides, unless you make physical changes to your existing modules (uninstall / replace them), you can always safely return to your current kernel without affecting current functionalities.

So go ahead.


PS: Did you check out the link Temüjin (http://ubuntuforums.org/member.php?u=327594) suggested? It's a thread of his own dedicated to such issues. You may wish to try it.

abeam
May 2nd, 2011, 06:18 AM
Sorry I left this for so long, but switching to the earlier kernel solved the problem. Thanks for all of the advice.:)