PDA

View Full Version : [ubuntu] Upgrading to Skype 2.2 broke video and causes Gtk_WARNING



tomtom12
April 7th, 2011, 10:24 AM
I just upgraded to Skype 2.2 on Ubuntu 10.10 64bit and got:

tom@tom-Q330:~$ skype

(<unknown>:6501): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:6501): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:6501): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:6501): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:6501): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:6501): Gtk-WARNING **: Loading IM context type 'ibus' failed

Reinstalling ia32-libs did not help. Problems in skype are now: bad or no video :sad: I thought this issue was solved..

Last time we started skype with 'skype-wrapper' but that does not work anymore :(

See also https://bugs.launchpad.net/ubuntu/+source/skype/+bug/754162

MrEgg
April 7th, 2011, 10:41 AM
Try :

env LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype
and see how this goes. This is how I get my webcam supported.

tomtom12
April 7th, 2011, 10:58 AM
Thank you. I tried it and got same result.

tom@tom-Q330:~$ env LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype
(<unknown>:6795): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

[ and so on ...]

GsL9vBab
April 7th, 2011, 02:49 PM
Hi. Just confirmed that the workaround works.

llenchikk
April 7th, 2011, 07:05 PM
If put this command in menu shortcut skype logo became empty.
There is skype logo icon?
Workaround working for me too. Thank you!

P.S. I found it! /usr/share/icons/skype.png

tomtom12
April 7th, 2011, 08:14 PM
Still does not work for me:( How can it that it works for others? Might I have the wrong lib?

jawilljr
April 7th, 2011, 09:23 PM
Doing the below does not work for me either:


env LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skypeThe only thing that worked was to downgrade to the earlier version.

Jerry

tomtom12
April 7th, 2011, 11:05 PM
@jerry: how did you downgrade ?

jawilljr
April 8th, 2011, 02:14 AM
I read This post (http://forum.skype.com/index.php?showtopic=809765&view=findpost&p=3366039) on the Skype forum. I downloaded it and found out it was for Intrepid. So I searched for another one and couldnt find one and since it was the same Skype version for Maverick I decided to install it... it works fine.

Here is the direct link (http://uploading.com/files/a6b9144a/skype-ubuntu-intrepid_2.1.0.81-1_amd64.deb/)

BTW I uninstalled the new first.

Jerry

tomtom12
April 8th, 2011, 08:22 AM
@jerry: thanks will give it a try later if no one can help to solve this mystery...

Why does Skype 2.2 work for some people and not for others? I just did regular upgrade via Ubuntu Software Centre... that should not break things, should it? .... :(

plucky
April 8th, 2011, 08:50 AM
Please subscribe to Bug Report (https://bugs.launchpad.net/ubuntu/+source/skype/+bug/754162) might get it fixed faster.

Good Luck

ottosykora
April 8th, 2011, 12:40 PM
I had this 2.1 from the skype site, then it went updated by the ubuntu repos. Now I have 2.2, but it works strange. I can use it, but lot of strange terminal windows pop up for short time, with lot of errors in it. Somehow unusual all that. i think I will try to remove this one and replace it with the 2.1 from skype site again.

tomtom12
April 8th, 2011, 03:04 PM
After downgrade I got same problem now :( Seems something else caused the trouble recently ?

ItalOz
April 10th, 2011, 08:13 AM
I have troubles with new version of skype in the computer of my parents, their video disappeared after upgrading and now I am in a lot of problems because I am trying to fix it from my house in a remote assistance and we live in different continents,

I think it has been a very bad move from skype to post an upgrade that is causing so many problems, skype should be out of the repositories like it wsas once so there is no risk of automatic upgrade with software that does not work.

Now I am downloading a few versions here and there and I'll try to see which one works in my parents' computer.

Very disappointing

tomtom12
April 11th, 2011, 07:40 PM
Ok, seeing a lot of issues around Skype 2.2. Was a mistake to make it as standard Update in Ubuntu.... I rely heavily on Skype... and now see myself using a Windows laptop just for Skype. And that while I did not touch a Windows PC in 4 years !

tomtom12
April 11th, 2011, 08:31 PM
Ok tip: Download older version of Skype like 3.0 and install in VirtualBox on Windows XP... that works. Not elegant.. still hate Windows after all these years... but at least there they have some decent video-library strategy...

ItalOz
April 12th, 2011, 01:20 PM
following the instructions given in this link (http://forum.skype.com/index.php?showtopic=810077) from the skype forums I have been able to fix my parent's skype webcam using remote assistance.

Thanks to LINUX...

Ah... and I have locked the version of skype!

AKADAP
April 17th, 2011, 08:41 PM
following the instructions given in this link (http://forum.skype.com/index.php?showtopic=810077) from the skype forums I have been able to fix my parent's skype webcam using remote assistance.

Thanks to LINUX...

Ah... and I have locked the version of skype!

None of those solutions work for me.

$ skype

(<unknown>:4635): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:4635): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:4635): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:4635): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:4635): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:4635): Gtk-WARNING **: Loading IM context type 'ibus' failed
^C
$ env LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

(<unknown>:4700): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:4700): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:4700): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:4700): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:4700): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:4700): Gtk-WARNING **: Loading IM context type 'ibus' failed
^C
$ env LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype

(<unknown>:5791): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:5791): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:5791): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:5791): Gtk-WARNING **: Loading IM context type 'ibus' failed

(<unknown>:5791): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so: wrong ELF class: ELFCLASS64

(<unknown>:5791): Gtk-WARNING **: Loading IM context type 'ibus' failed
^C


Skype runs, test call works, test video works, but it won't let me share my video when I'm in an actual call. I can see & hear the other party, and they can hear me, but clicking on the share my video button gets ignored.

psuresh0207
December 24th, 2011, 07:53 PM
I also had the same problem with skype 2.2 in lucid 11.04, but downgraded to 2.1.0.81-1 and droidcam works fine :). Thanks guys.