View Full Version : I updated last night, and now my mouse won't work. How do I fix that?

April 3rd, 2011, 04:32 PM
So last night, ubuntu popped up with some updates. It was like...56mb or so worth. So I downloaded them. Once they were done, my mouse stopped working. (trackpad on my netbook) I restarted using the keyboard a couple times, shut it off, pulled the battery...but the mouse won't work. I havent tried an external yet, but I hope it will work so I can fix the trackpad problem. So, I loaded into Windows to check the mouse there, and it works fine. Is it a simple fix? Or, is it not so simple?


April 4th, 2011, 06:33 AM
Okay, so I tried a few things. I loaded it, and the trackpad still didnt work at all. With a mouse plugged in, I can move the cursor, but only about 30% of the stuff actually activates when I click on it. So, I can open programs...like mozilla or my application menu, but I cant click on anything in them. I can't exit, go to file, nothing. I managed to download Klam antivirus just to see...and I can access everything but the scan button...which makes it useless.

As I messed around with a couple things, I got a weird message at one point. It said something similar to... "There is Malware trying to access your computer, or you are trying to access it. Cannot access trackpad." It wasnt that exactly, but it was similar. I got the idea I either had Malware, or the update killed my trackpad.

Is there a way to fix it? Or do I have to settle with Windows?