PDA

View Full Version : [ubuntu] Chromium and Flash 10.2 video acceleration (Stage Video)



thecapsaicinkid
March 3rd, 2011, 08:25 PM
Ubuntu 10.10 64bit
Chromium and Flash 10.2 from the repos
Nvidia GT210
VDPAU working as expected

Right clicking on YouTube videos which supposedly have Stage Video acceleration enabled (link below) and viewing video info shows 'Software Rendering' and cpu is still around 60%.

http://www.youtube.com/watch?v=Ou6_MkIvKOo&feature=player_embedded

Has anyone got this working? 60% cpu hints that it's not working.

Curiously, the Big Buck Bunny test video on Adobe's site shows Stage Video = true (cpu still around 60%) yet the same video on YouTube maxes the cpu.

thecapsaicinkid
March 5th, 2011, 08:51 PM
Any ideas?

Temüjin
March 6th, 2011, 03:22 AM
Stage video doesn't work with 64-bit Flash. I'm not sure if it works using the 32-bit Flash and nspluginwrapper.

thecapsaicinkid
March 8th, 2011, 12:49 PM
Forgot to mention I was using the 32bit version with nspluginwrapper.

Not sure if this is an issue with Chromium, the flash binary or some other problem caused with by using a 32bit binary on a 64bit system.

kerry_s
March 8th, 2011, 01:04 PM
Forgot to mention I was using the 32bit version with nspluginwrapper.

Not sure if this is an issue with Chromium, the flash binary or some other problem caused with by using a 32bit binary on a 64bit system.

32 does the same thing.
go into about:flags & enable the gpu accel stuff, just in case.

thecapsaicinkid
April 3rd, 2011, 12:41 PM
Flash just been updated and it STILL doesn't work.

thecapsaicinkid
May 1st, 2011, 09:36 AM
Still no hardware acceleration.

thecapsaicinkid
May 29th, 2011, 07:14 PM
Does anyone have VDPAU accelerated Flash working with Chromium?? Yet more Flash binary updates and it STILL does't work.

Temüjin
May 29th, 2011, 08:03 PM
I'm assuming you have the 32-bit version of libvdpau since you posted in this thread: http://ubuntuforums.org/showthread.php?t=1636333
Is that correct?

thecapsaicinkid
May 29th, 2011, 08:10 PM
I'm guessing it's 64bit. There's no mention of 32bit.

0.4.1-2ubuntu1

Temüjin
May 29th, 2011, 08:18 PM
Follow the instructions in that thread to get the 32-bit libvdpau using getlibs.

thecapsaicinkid
May 29th, 2011, 08:39 PM
That worked, thankyou so much!


I'm not sure I understand how getlibs works. It doesn't add a visible package to the package system, in Synaptic I still see just the original 64bit libvdpau1 package. I'm guessing I have both 32/64bit now and native 64bit apps like mplayer will still use the 64bit vdpau?

EDIT: Browser became unresponsive after a while, will reboot and try again.


Thanks again.

Temüjin
May 29th, 2011, 10:07 PM
getlibs just extracts the shared libraries out of the package and places them in /usr/lib32. That violates Debian packaging policy and you might need to do it again if you choose to upgrade the system. It's not the cleanest solution for the 64-bit user (that would be a chroot), but I haven't seen complaints about getlibs borking peoples' systems either (even when we had a 64-bit subforum and a lot more need for getlibs).