PDA

View Full Version : [SOLVED] how do I remove the icon on my desktop of 2nd mounted HD?



Old Jimma
March 1st, 2011, 11:03 AM
Hi Ubuntu Community:

I have a second hard drive, /dev/sdb1

I mount it automatically using /etc/fstab

The line in /etc/fstab that mounts the drive is:

/dev/sdb1 /media/WIDSOM ext4 defaults 0 2

An icon of that hard drive shows up on my desktop... see the upper right hand corner of the attachment (those are my sons in the picture).

I do not want that icon to show on my desktop because it can accidentally be unmounted.

How do I get that icon to vanish without unmounting the device?

Thanks,
Phil Smith
DUluth, GA

YesWeCan
March 1st, 2011, 11:08 AM
The automatic desktop icon is particular to /media. Just mount the drive somewhere else, such as /mnt.

pressko
March 1st, 2011, 11:13 AM
HI ,

Or just install ubuntu tweak and there is an option on desktop section : Do not show mounted device on desktop . Mark it and u are done :)

mcduck
March 1st, 2011, 11:17 AM
HI ,

Or just install ubuntu tweak and there is an option on desktop section : Do not show mounted device on desktop . Mark it and u are done :)

Of course you don't need Ubuntu Tweak to do that (the option is in gconf-editor, which is installed by default) and doing that will not only hide the single selected drive, but instead all drives, removable drives/devices and optical media.

If you just want to avoid getting a desktop icon for a particular drive, then mounting it anywhere else than in /media is the best way.

Old Jimma
March 1st, 2011, 12:07 PM
Thank you!