View Full Version : [SOLVED] configure anjuta to include sdl libraries to a project

February 28th, 2011, 06:20 AM
Hi everyone, no one know how to configure anjuta to include SDL libraries to a project? Thanks

February 28th, 2011, 11:29 PM
You can find the relevant documentation of the IDE here:


March 1st, 2011, 03:33 PM
Good, I added my dependencies but all SDL function is "undefined reference" What should I do?

March 1st, 2011, 11:49 PM
I got this output on build in the IDE:

Building in directory: /home/master/chipper/Debug
/bin/bash ./config.status --recheck
running CONFIG_SHELL=/bin/bash /bin/bash /home/master/chipper/configure --enable-maintainer-mode CFLAGS=-g -O0 CXXFLAGS=-g -O0 JFLAGS=-g -O0 FFLAGS=-g -O0 --no-create --no-recursion
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
configure: error: source directory already configured; run "make distclean" there first
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
make: *** [config.status] Error 1
Completed unsuccessfully
Total time taken: 1 secs

no one know what is this?

March 3rd, 2011, 11:07 PM

March 4th, 2011, 12:08 PM
The error message is clear: You are supposed to run "make distclean" in your source directory.

March 5th, 2011, 12:15 AM
I run it but I got always undefined reference to all SDL function... I added my modules and libraries: 185099

March 5th, 2011, 08:42 PM
so... no one know where is the compiler and linker settings?

March 6th, 2011, 07:33 PM

March 7th, 2011, 12:56 PM
It look like noone is using Anjuta in conjunction with SDL here. I can only advise you to seriosly consider trying to build your application from the terminal first and see where things go wrong. Try to run the configure scripts from the terminal and observe how g++ is being called when building the project. Check which are the options given and see if the ones needed to get your project compiling with SDL are actually given.