PDA

View Full Version : [ubuntu] apt-get install



ljw5491
February 27th, 2011, 09:45 PM
I am having no luck at all adding packages to my ubuntu server. I can update, so there is definitely connectivity - but whenever I type in a command, for instance:


sudo apt-get install vsftpdI get back:


Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package vsftpdIs there anyone who can get me on the right track with this? I've been running ubuntu server 10.10 for about a month now and know just enough to be dangerous - Thanks -

snowpine
February 27th, 2011, 09:47 PM
You need to refresh your list of available packages with:


sudo apt-get update

then you can:


sudo apt-get install vsftpd

ljw5491
February 27th, 2011, 11:35 PM
Yeah, I can get the update just fine - but when I enter the second command I get the result shown above. Not sure why I'm having so much trouble.

Here is the contents of /etc/apt/sources.list:



#deb cdrom:[Ubuntu-Server 10.10 _Maverick Meerkat_ - Release i386 (20101007)]/ $

#deb cdrom:[Ubuntu-Server 10.10 _Maverick Meerkat_ - Release i386 (20101007)]/ $

deb http://security.ubuntu.com/ubuntu maverick-security main
deb-src http://security.ubuntu.com/ubuntu maverick-security main
deb http://security.ubuntu.com/ubuntu maverick-security universe
deb-src http://security.ubuntu.com/ubuntu maverick-security universe
deb http://security.ubuntu.com/ubuntu maverick-security multiverse
deb-src http://security.ubuntu.com/ubuntu maverick-security multiverse


Are these the correct repositories??

snowpine
February 27th, 2011, 11:46 PM
It looks like you have only the "security" repo enabled. I think that vsftpd is in "main". I would also recommend enabling "updates".

You may find this sources.list generator helpful: http://repogen.simplylinux.ch/

Sef
February 27th, 2011, 11:59 PM
It looks like you have only the "security" repo enabled.

If that is all that the OP has, then some repositories are missing.

ljw5491
February 28th, 2011, 10:47 AM
Worked like a charm - many thanks!