PDA

View Full Version : [ubuntu] Ati radeon 5600 on 11.04?



JAM3SoN
February 26th, 2011, 12:02 PM
Hi guys, my graphics card is Ati radeon HD 5600 Series. Yesterday I performed upgrade to Ubuntu 11.04 and I am not able to install driver.

I went to AMD page, found this download: "AMD Catalyst™ 11.2 Proprietary Linux x86 Display Driver" but when I install it, my computer won't boot. I see loading screen, then it goes back to "console mode" and last thing I see is "Checking battery state [OK]". Then it hangs on black screen. I must uninstall this driver using recovery mode and work without it. I tried even 11.1 driver but that is not working as well.

Weird thing is that when I go to System - Additional drivers, it doesn't find anything. I don't remember exactly but it used to find some graphics driver.

What should I try? :)

Thanks in advance!

Edit: When I run installer through console it gives me error message "DKMS part of installation failed. Please refer to /usr/share/ati/fglrx-install.log for details". This is in log:
Creating symlink /var/lib/dkms/fglrx/8.801/source ->
/usr/src/fglrx-8.801

DKMS: add Completed.
You can use the --kernelsourcedir option to tell DKMS where it's located, or you could install the linux-headers-2.6.38-5-generic-pae package.
[Error] Kernel Module : Failed to build fglrx-8.801 with DKMS
[Error] Kernel Module : Removing fglrx-8.801 from DKMS

------------------------------
Deleting module version: 8.801
completely from the DKMS tree.
------------------------------
Done.
[Reboot] Kernel Module : update-initramfs

Temüjin
February 26th, 2011, 02:56 PM
http://wiki.cchtml.com/index.php/Ubuntu_Natty_Installation_Guide#Xserver_1.10_Incom patibility_Warning

JAM3SoN
February 26th, 2011, 11:34 PM
Thank you, I ended on last step with following info:
$ sudo dpkg -i fglrx*.deb
Vyberá sa predtým zrušený balík fglrx-amdcccle.
(Číta sa databáza ... momentálne je nainštalovaných 160699 súborov alebo adresárov.
Rozbaľuje sa fglrx-amdcccle (z fglrx-amdcccle_8.801-0ubuntu1_i386.deb) ...
Vyberá sa predtým zrušený balík fglrx-dev.
Rozbaľuje sa fglrx-dev (z fglrx-dev_8.801-0ubuntu1_i386.deb) ...
Vyberá sa predtým zrušený balík fglrx-modaliases.
Rozbaľuje sa fglrx-modaliases (z fglrx-modaliases_8.801-0ubuntu1_i386.deb) ...
Vyberá sa predtým zrušený balík fglrx.
Rozbaľuje sa fglrx (z fglrx_8.801-0ubuntu1_i386.deb) ...
Nastavuje sa balík fglrx-modaliases (2:8.801-0ubuntu1) ...
dpkg: problémy so závislosťami zabránili konfigurácii balíka fglrx:
xserver-xorg-core (2:1.9.99.902-2ubuntu1) kazí fglrx (<= 2:8.801-0ubuntu2) a je inštalovaný.
Verzia fglrx, ktorá sa má konfigurovať, je 2:8.801-0ubuntu1.
dpkg: chyba pri spracovávaní fglrx (--install):
problémy so závislosťami - po necháva sa nenakonfigurované
dpkg: problémy so závislosťami zabránili konfigurácii balíka fglrx-amdcccle:
fglrx-amdcccle závisí na fglrx; aj keď:
Balík fglrx ešte nie je nakonfigurovaný.
dpkg: chyba pri spracovávaní fglrx-amdcccle (--install):
problémy so závislosťami - po necháva sa nenakonfigurované
dpkg: problémy so závislosťami zabránili konfigurácii balíka fglrx-dev:
fglrx-dev závisí na fglrx; aj keď:
Balík fglrx ešte nie je nakonfigurovaný.
dpkg: chyba pri spracovávaní fglrx-dev (--install):
problémy so závislosťami - po necháva sa nenakonfigurované
Spracúvajú sa spúšťače ureadahead ...
ureadahead will be reprofiled on next reboot
Spracúvajú sa spúšťače man-db ...
Vyskytli sa chyby počas spracovania:
fglrx
fglrx-amdcccle
fglrx-dev

It seems that configuration mistake in fglrx broke instalation of next modules and this is simple translation of error message:
dpkg: dependency problems prevented configuration of package fglrx:
xserver-xorg-core (2:1.9.99.902-2ubuntu1) breaks fglrx (<= 2:8.801-0ubuntu2) and is installed.
Version of fglrx, that has to be configured, is 2:8.801-0ubuntu1.

Dunno how to fix it :(

Temüjin
February 27th, 2011, 12:53 AM
fglrx is not going to work with natty/11.04 right now. That was the point of the big red warning I linked you to....
Anyway, this is how to recover: http://wiki.cchtml.com/index.php/Ubuntu_Maverick_Installation_Guide#Removing_Cataly st.2Ffglrx

JAM3SoN
February 27th, 2011, 01:00 AM
Many times thanks again. That info was quite confusing as I thought that patching will help. So I should possibly wait for 11.3 that should be compatible.

Temüjin
February 27th, 2011, 01:25 AM
Yes, wait for 11.3