PDA

View Full Version : [SOLVED] installing tweak



wordmaster
February 24th, 2011, 05:59 PM
When I try to install the .deb package of ubuntu tweak, I get the following error;

Error: Dependency is not satisfiable: python (>= 2.7)


Please help.

Artificial Intelligence
February 24th, 2011, 06:08 PM
Which version of ubuntu do you use?

_0R10N
February 24th, 2011, 08:09 PM
That's odd! Where did you get that .deb? I have python 2.6.6.3 and selected tweak 3.01 for installation and it didn't require anything extra. Also, which version of Tweak are you trying to install?

If you're trying to install from a repo, maybe you added an experimental repo to your sources.list file, check for any no-traditional repo in that file


Kind regards!

lkjoel
February 24th, 2011, 11:57 PM
When I try to install the .deb package of ubuntu tweak, I get the following error;

Error: Dependency is not satisfiable: python (>= 2.7)


Please help.
Try this in a Terminal window:

sudo apt-get install ubuntu-tweak

It will install ubuntu-tweak from the Ubuntu repos.

rburkartjo
February 25th, 2011, 02:44 PM
word if what lkj says doesnt work go to the ubuntu tweak website and download the newest deb install. then install that

philinux
February 25th, 2011, 02:46 PM
Try this in a Terminal window:

sudo apt-get install ubuntu-tweak

It will install ubuntu-tweak from the Ubuntu repos.

It's not in ubuntu repo's you have to get it from their site.

http://ubuntu-tweak.com/

rburkartjo
February 25th, 2011, 02:58 PM
yea phil i sure wish they would add this to the repos.

rburkartjo
February 25th, 2011, 02:59 PM
he could always add the ppa to the software sources

philinux
February 25th, 2011, 03:04 PM
yea phil i sure wish they would add this to the repos.

The developers of Tweak would have to go through this process.

https://wiki.ubuntu.com/UbuntuDevelopment/NewPackages

ClyN3il
April 5th, 2011, 05:49 AM
Why is this thread marked solved? There is no working solution in the thread. I am having this same problem (trying to install Ubuntu Tweak version 0.5.10-1, on Natty Beta 1) using the deb downloaded from their website. Ubuntu Tweak, as has been pointed out, is not in the Ubuntu repositories. I clearly have the necessary python installed (python 2.6, and 2.7, and 3..).

5149.5
April 5th, 2011, 06:00 AM
Here is how I installed tweak:


sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

ClyN3il
April 5th, 2011, 09:21 AM
It seems to work now... (Using the PPA method as above.) I installed a bunch of updates, and I think some of them were python-related...maybe that's what did it.

PS: For others' reference, if you're using Natty beta, you should probably use the PPA...it looks like the deb you get when you download from Ubuntu Tweak's main page is the one that's supposed to be for Maverick (0.5.10-1...the PPA gave me 0.5.11-1~natty1).

greylion
May 15th, 2011, 05:41 PM
Installed a fresh xubuntu 10.10 i386, installed all updates.

Downloaded from ubuntu tweak website, got the exact same problem; dependency error for python (=>) 2.7
Only then did I notice it was the natty version.
Googled the error, found this thread.

Installing from PPA works, but it's odd that the website offers a natty .deb to a maverick install.

c0rrupt0r
May 26th, 2011, 11:17 AM
I had this same problem while trying to download and install the deb off of Ubuntu Tweak website but then again did some thinking after reading Greylion's Post above and on the ubuntu tweak website it says just under the button to download it "Old versions (for Ubuntu 10.10 and before)" So I clicked that and it brought me to another page for the version I needed and here you go. https://launchpad.net/ubuntu-tweak/+download Make sure you get the one for maverick and it installs flawlessly for me.