PDA

View Full Version : [ubuntu] Ubuntu showing incorrect battery state



roman161
February 22nd, 2011, 03:53 AM
Hello, I have a Lenovo Y560 newly installed with ubuntu 10.10 x64. The power icon in the indicator applet shows incorrect battery state.
While the device is plugged in, I get "battery is charged", regardless of if the battery capacity is 50%.
While the device is running on battery power, the icon displays "laptop battery is charging".
I can fwts battery and didn't receive any odd messages. Can anyone advise me on getting my laptop to show the correct battery information?

While plugged in (ON AC power)

$ sudo upower --dump
Device: /org/freedesktop/UPower/devices/line_power_ACAD
native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/ACPI0003:00/power_supply/ACAD
power supply: yes
updated: Mon Feb 21 21:46:26 2011 (48 seconds ago)
has history: no
has statistics: no
line-power
online: yes

Device: /org/freedesktop/UPower/devices/battery_BAT1
native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0A:00/power_supply/BAT1
vendor: SANYO
model: L09S6D16
power supply: yes
updated: Mon Feb 21 21:47:02 2011 (12 seconds ago)
has history: yes
has statistics: yes
battery
present: yes
rechargeable: yes
state: fully-charged
energy: 58.2444 Wh
energy-empty: 0 Wh
energy-full: 61.5492 Wh
energy-full-design: 60.6528 Wh
energy-rate: 0 W
voltage: 12.372 V
percentage: 94.6306%
capacity: 100%
technology: lithium-ion

Daemon:
daemon-version: 0.9.5
can-suspend: yes
can-hibernate yes
on-battery: no
on-low-battery: no
lid-is-closed: no
lid-is-present: yesA few minutes later on battery power

sudo upower --dump
Device: /org/freedesktop/UPower/devices/line_power_ACAD
native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/ACPI0003:00/power_supply/ACAD
power supply: yes
updated: Mon Feb 21 21:51:05 2011 (33 seconds ago)
has history: no
has statistics: no
line-power
online: no

Device: /org/freedesktop/UPower/devices/battery_BAT1
native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0A:00/power_supply/BAT1
vendor: SANYO
model: L09S6D16
power supply: yes
updated: Mon Feb 21 21:51:11 2011 (27 seconds ago)
has history: yes
has statistics: yes
battery
present: yes
rechargeable: yes
state: charging
energy: 56.2356 Wh
energy-empty: 0 Wh
energy-full: 61.5492 Wh
energy-full-design: 60.6528 Wh
energy-rate: 31.752 W
voltage: 11.909 V
time to full: 10.0 minutes
percentage: 91.3669%
capacity: 100%
technology: lithium-ion
History (charge):
1298342991 92.929 unknown
1298343032 92.118 charging
History (rate):
1298342991 30.359 unknown
1298343035 31.832 charging

Daemon:
daemon-version: 0.9.5
can-suspend: yes
can-hibernate yes
on-battery: no
on-low-battery: no
lid-is-closed: no
lid-is-present: yes

roman161
February 22nd, 2011, 05:11 AM
Bump with more info

fwts debug information

0001 21/01/11 15:40:21 fwts Results generated by fwts: Version V0.18.04 (built Wed Sep 15
0002 21/01/11 15:40:21 fwts 10:41:31 BST 2010).
0003 21/01/11 15:40:21 fwts
0004 21/01/11 15:40:21 battery Battery Tests.
0005 21/01/11 15:40:21 battery ------------------------------------------------------------
0006 21/01/11 15:40:21 battery This test reports which (if any) batteries there are in the
0007 21/01/11 15:40:21 battery system. In addition, for charging or discharging batteries,
0008 21/01/11 15:40:21 battery the test validates that the reported 'current capacity'
0009 21/01/11 15:40:21 battery properly increments/decrements in line with the charge
0010 21/01/11 15:40:21 battery discharge state. This test also stresses the battery state
0011 21/01/11 15:40:21 battery reporting codepath in the ACPI BIOS, and any warnings given
0012 21/01/11 15:40:21 battery by the ACPI interpreter will be reported.
0013 21/01/11 15:40:21 battery Battery BAT1 model L09S6D16 is currently charging.
0001 21/01/11 21:35:20 fwts Results generated by fwts: Version V0.18.04 (built Wed Sep 15
0002 21/01/11 21:35:20 fwts 10:41:31 BST 2010).
0003 21/01/11 21:35:20 fwts
0004 21/01/11 21:35:20 battery Battery Tests.
0005 21/01/11 21:35:20 battery ------------------------------------------------------------
0006 21/01/11 21:35:20 battery This test reports which (if any) batteries there are in the
0007 21/01/11 21:35:20 battery system. In addition, for charging or discharging batteries,
0008 21/01/11 21:35:20 battery the test validates that the reported 'current capacity'
0009 21/01/11 21:35:20 battery properly increments/decrements in line with the charge
0010 21/01/11 21:35:20 battery discharge state. This test also stresses the battery state
0011 21/01/11 21:35:20 battery reporting codepath in the ACPI BIOS, and any warnings given
0012 21/01/11 21:35:20 battery by the ACPI interpreter will be reported.
0013 21/01/11 21:35:20 battery Battery BAT1 model L09S6D16 is currently charged.
0014 21/01/11 21:35:26 battery Got 2 interrupt(s) on GPE gpe02.
0015 21/01/11 21:35:26 battery Got 147 interrupt(s) on GPE gpe16.
0016 21/01/11 21:35:26 battery Got 155 interrupt(s) on GPE gpe_all.
0017 21/01/11 21:35:26 battery PASSED: test 1, Detected ACPI battery events.
0018 21/01/11 21:35:26 battery PASSED: test 1, Detected ACPI event for battery BAT1.
0019 21/01/11 21:35:28 battery PASSED: test 1, Battery BAT1 charge is decrementing as
0020 21/01/11 21:35:28 battery expected.
0021 21/01/11 21:36:05 battery Got 1 interrupt(s) on GPE gpe02.
0022 21/01/11 21:36:05 battery Got 99 interrupt(s) on GPE gpe16.
0023 21/01/11 21:36:05 battery Got 104 interrupt(s) on GPE gpe_all.
0024 21/01/11 21:36:05 battery PASSED: test 1, Detected ACPI battery events.
0025 21/01/11 21:36:05 battery PASSED: test 1, Detected ACPI event for battery BAT1.
0026 21/01/11 21:38:07 battery FAILED [MEDIUM]: test 1, Battery BAT1 claims it's charging
0027 21/01/11 21:38:07 battery but no charge is added
0028 21/01/11 21:38:07 battery
0029 21/01/11 21:38:07 battery ================================================== ==========
0030 21/01/11 21:38:07 battery 5 passed, 1 failed, 0 warnings, 0 aborted.
0031 21/01/11 21:38:07 battery ================================================== ==========

0033 21/01/11 21:38:07 summary
0034 21/01/11 21:38:07 summary Summary: 5 passed, 1 failed, 0 warnings, 0 aborted.
0035 21/01/11 21:38:07 summary
0036 21/01/11 21:38:07 summary Test Failure Summary
0037 21/01/11 21:38:07 summary ====================
0038 21/01/11 21:38:07 summary
0039 21/01/11 21:38:07 summary Critical failures: NONE
0040 21/01/11 21:38:07 summary
0041 21/01/11 21:38:07 summary High failures: NONE
0042 21/01/11 21:38:07 summary
0043 21/01/11 21:38:07 summary Medium failures: 1
0044 21/01/11 21:38:07 summary battery test at log line 26:
0045 21/01/11 21:38:07 summary "Battery BAT1 claims it's charging but no charge is added"
0046 21/01/11 21:38:07 summary
0047 21/01/11 21:38:07 summary Low failures: NONE
0048 21/01/11 21:38:07 summary
0049 21/01/11 21:38:07 summary Other failures: NONE
0050 21/01/11 21:38:07 summary

roman161
February 24th, 2011, 05:14 AM
bump

Anyone have any insight?

vasilk
February 25th, 2011, 02:12 PM
Hi!

I also have the same problem for my new battery!
Here is what says for me:


:~$ sudo upower --dump
Device: /org/freedesktop/UPower/devices/line_power_C1AB
native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/ACPI0003:00/power_supply/C1AB
power supply: yes
updated: Fri Feb 25 10:53:41 2011 (11235 seconds ago)
has history: no
has statistics: no
line-power
online: yes

Device: /org/freedesktop/UPower/devices/battery_C1AC
native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0A:00/power_supply/C1AC
vendor: Hewlett-Packard
model: Primary
serial: 00001 2011/01/10
power supply: yes
updated: Fri Feb 25 14:00:46 2011 (10 seconds ago)
has history: yes
has statistics: yes
battery
present: yes
rechargeable: yes
state: fully-charged
energy: 3.848 Wh
energy-empty: 0 Wh
energy-full: 29.6 Wh
energy-full-design: 29.6 Wh
energy-rate: 29.5556 W
voltage: 15.89 V
percentage: 13%
capacity: 100%
technology: lithium-ion

Daemon:
daemon-version: 0.9.5
can-suspend: yes
can-hibernate yes
on-battery: no
on-low-battery: no
lid-is-closed: no
lid-is-present: yes

Also, I have installed the patch from here: https://bugs.launchpad.net/system76/+bug/629258/comments/95 and still didn't fix anything (in relation to this matter).

I am using HP530 and what I have noticed yesterday is that when it does not charge, I need to pull out the battery and place it back again - then it will charge for 10 min and stop... then, I need to repeat this in order to have it fully charged!

Any hint?

Thank you!
Vasil

roman161
March 2nd, 2011, 07:16 PM
Bump, should I report this as a bug?

Angelontu22
March 6th, 2011, 01:22 AM
You're not alone brother. I also have a Lenovo Ideapad Y560 with intel core i5-450m and ati radeon hd 5730 with switch-able graphics. I disabled to discrete graphics only in order to install the proprietary drivers so because of that I thought I was the only one.

Here's what I get on terminal;




angel@angel-Rev-1-0:~$ sudo upower --dump
Device: /org/freedesktop/UPower/devices/line_power_ACAD
native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/ACPI0003:00/power_supply/ACAD
power supply: yes
updated: Sat Mar 5 19:13:42 2011 (30 seconds ago)
has history: no
has statistics: no
line-power
online: no

Device: /org/freedesktop/UPower/devices/battery_BAT1
native-path: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0A:00/power_supply/BAT1
vendor: SONY
model: L09N6D16
power supply: yes
updated: Sat Mar 5 19:13:48 2011 (24 seconds ago)
has history: yes
has statistics: yes
battery
present: yes
rechargeable: yes
state: charging
energy: 16.146 Wh
energy-empty: 0 Wh
energy-full: 62.0568 Wh
energy-full-design: 60.6528 Wh
energy-rate: 19.332 W
voltage: 10.793 V
time to full: 2.4 hours
percentage: 26.0181%
capacity: 100%
technology: lithium-ion
History (charge):
1299370428 26.018 charging
1299370426 26.053 charging
1299370422 26.070 charging
1299370420 26.105 charging
1299370390 26.349 charging
1299370359 26.610 charging
1299370358 26.627 charging
1299370354 26.645 charging
1299370351 26.697 charging
History (rate):
1299370351 17.204 unknown
1299370390 16.116 charging

Daemon:
daemon-version: 0.9.5
can-suspend: yes
can-hibernate yes
on-battery: no
on-low-battery: no
lid-is-closed: no
lid-is-present: yes
angel@angel-Rev-1-0:~$
How come the vendor is Sony?
Charging? My laptop is unplugged :/

TIIUNDER
May 9th, 2011, 07:37 PM
Same problem here with my new Lenovo Y560.

I installed Ubuntu 11.04 Natty Narwhal and the problem still exists.

Somebody has a solution for it?
Is it already reported as bug?

TIIUNDER
May 10th, 2011, 12:49 PM
I found another thread and this trick seams to work:
http://ubuntuforums.org/showpost.php?p=10181837&postcount=10