PDA

View Full Version : [SOLVED] compiz troubleshoot



Einstein86
February 21st, 2011, 05:13 PM
This is problem of mine: I have turned on 'brightness, saturation and transparency' in compizconfig and cause that only can see desktop with shortcuts on it but nothing else. If I run any application or open window it does that but i cannot have a look of its like i'm blind. I know it's transparent 100%, but dunno what to do? Actually dunno how to restore because can't see where to click with mouse.

Please for help through concrete steps.

Forlong
February 21st, 2011, 10:06 PM
Boot into the failsafe GNOME session from GDM (login manager). It should boot GNOME without Compiz being enabled, so you can fix it.

Krytarik
February 24th, 2011, 02:39 AM
For anyone setting up those rules: The "New" dialogs for lists in Compiz don't offer a "Close" option, and even closing the window with the "X" button sets the new rule. So, if you want to cancel the creation of the rule, just enter something unreal, like "dgdfgd" ;-), otherwise your desktop can quickly go bust.

I had that just yesterday with the "Size" option in the "Window Rules" plugin, I guess it was filling up my swap space while trying to set all windows to negative size values (I wonder how that makes sense.). I had to use the recovery mode, because I have autologin enabled.

Also, don't confirm the "Add" dialogs, it doesn't set the value you may have entered or "grabbed" before, just the "class=" or whatever is selected with no value, resulting in ALL.

Greetings.

Einstein86
February 27th, 2011, 08:51 PM
thanks guys

stinkeye
February 28th, 2011, 02:26 AM
...and for others who run into this problem
you can use alt+mousewheel up/down to alter transparency when the mouse is
hovered over the window.

Krytarik
February 28th, 2011, 03:09 AM
...and for others who run into this problem
you can use alt+mousewheel up/down to alter transparency when the mouse is
hovered over the window.
When I had those transparency issue, I could simply press Alt+F2 and enter "metacity --replace" blindly ;-), but that wasn't even possible in my described case.