PDA

View Full Version : [ubuntu] problem with 'open with application'



granda
February 14th, 2011, 04:48 PM
help needed:

If I go to Places > Home Folder or Places > videos or places > desktop instead of the location opening I go immediately into into a video player

The problem is with the 'open with application' which by default on my system Ubuntu 10.10 is that the open with another application has by default already got the 'remember this application for this type of file' checked by default.

Is there any way of reversing this really annoying feature. having the dialogue window unchecked by default making it a conscious decision to open all similar files same way

Did I say really annoying. absolutely

Linyx
February 14th, 2011, 05:14 PM
Right-Click on any folder on a desktop and select the option "Open with other Application" and their Select the File-browser, and tick the Remember option below...



Better now..?

nick_goodfate
February 14th, 2011, 05:51 PM
Or you can use Ubuntu tweak (http://ubuntu-tweak.com/).
183455

vanadium
February 14th, 2011, 06:04 PM
This problem pops up all over the place. I guess this is due with the "Remeber" option being set by default in Ubuntu 10.10, which obviously was a bad idea.

nick_goodfate
February 14th, 2011, 06:13 PM
This problem pops up all over the place. I guess this is due with the "Remeber" option being set by default in Ubuntu 10.10, which obviously was a bad idea.

It's true. I was wondering why. And if the reason is what you said, why in every case folders open with media player? coincidence?

shunan
February 14th, 2011, 06:21 PM
well i did not get your question really...

so i am guessing...

you can right-click on any file/program and select properties and go to the tab "Open With" and add/remove all you want. So you don't have to select Open With -> Other Application... but select the application you just want...

nick_goodfate
February 14th, 2011, 06:36 PM
well i did not get your question really...

so i am guessing...

you can right-click on any file/program and select properties and go to the tab "Open With" and add/remove all you want. So you don't have to select Open With -> Other Application... but select the application you just want...

I think there is no "Open with" tab in folders properties ...

mc4man
February 14th, 2011, 06:51 PM
why in every case folders open with media player? coincidence?
Not really, it (the default folder handler), could be switched to anything, just that most people tend to use the 'Open With -> Other Application' on folders that contain media

The bug is that the "Remember this..." option changes the default to the app chosen - this occurs on both files and folders.
In the case of files most people probably don't notice, and is somewhat useful. (a 2nd way to change the default for that filetype

On folders the 'Remember this.. " option is of no value and causes immediate issues as seen.

(I spent 5 months trying to have this changed, did get the option to be disabled by default, unfortunately the patch was only applied to natty and unlikely to be in maverick unless there is a rebuild of nautilus, in that case the maintainer could apply the patch if he remembers.

shunan
February 14th, 2011, 07:07 PM
I think there is no "Open with" tab in folders properties ...

That is strange, I got it in mine... Nautilus 2.32.0!

Oops! I was using nautilus elementary and have been using it for so long...

https://launchpad.net/~am-monkeyd/+archive/nautilus-elementary-ppa

nick_goodfate
February 14th, 2011, 07:14 PM
That is strange, I got it in mine... Nautilus 2.32.0!

Oops! I was using nautilus elementary and have been using it for so long...

https://launchpad.net/~am-monkeyd/+archive/nautilus-elementary-ppa

I think you have not understand the problem of "granda". When he tries to open a folder(not a file) it opens with media player.

shunan
February 14th, 2011, 07:24 PM
I think you have not understand the problem of "granda". When he tries to open a folder(not a file) it opens with media player.

Ohh! thanks for clarifying, i never used open with feature on a folder, ever... but i can understand the annoyance...

it seems like this bug was raised and fixed
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/662194

nautilus (1:2.32.2-0ubuntu2) natty

jamesdonaldson
February 18th, 2011, 01:01 PM
Right-Click on any folder on a desktop and select the option "Open with other Application" and their Select the File-browser, and tick the Remember option below...



Better now..?

It certainly is thank you!

jamesdonaldson
February 18th, 2011, 01:02 PM
Right-Click on any folder on a desktop and select the option "Open with other Application" and their Select the File-browser, and tick the Remember option below...



Better now..?

It is thank you!