PDA

View Full Version : [SOLVED] uploading videos to youtube



dragon1111
February 14th, 2011, 03:50 PM
Hi i'm using ubuntu 10.10...I made a video using PiTiVi Video Editor and it turned out really good that i uploaded it to Youtube immediately.The audio seemed fine on Youtube but the images were horribly scrambled that i had to take it off.Is there anyway i can sort this out? Here's some details on the video:

Type: Ogg Theora video (video/x-theora+ogg)
Duration - 3 mins 28 sec

Video:
Dimension - 720x576
Codec - Theora
Framerate - 25 frames per second
Bitrate - N/A

Audio:
Codec - Vorbis
Channels - Stereo
Sample Rate - 44100 Hz
Bitrate - 112 kbps

mastablasta
February 14th, 2011, 03:56 PM
try a different codec type or use some software like handbrake to save it into propper codec that will give you a better picture.

dragon1111
February 14th, 2011, 03:59 PM
The video turned out really good...Its only on Youtube that the images appear scrambled

ron999
February 14th, 2011, 04:03 PM
...Its only on Youtube that the images appear scrambled


Hi
Yes, YouTube doesn't like the theora content.
These two methods worked for me:-


ffmpeg -i foo.ogv -vcodec libx264 -vpre medium -crf 24 -threads 0 -acodec copy foo.mkv



mencoder foo.ogv -o foo.avi -ovc lavc -oac mp3lame

dragon1111
February 14th, 2011, 04:26 PM
thanks....will try that

dragon1111
February 15th, 2011, 10:24 AM
The terminal says foo.ogv not found..Here are the screenshots for both the commands respectively:

ron999
February 15th, 2011, 10:29 AM
The terminal says foo.ogv not found..
Use your own filename!

dragon1111
February 15th, 2011, 10:37 AM
My filename is 'teamind'...Now the terminal says teamind.ogv not found :(

Paqman
February 15th, 2011, 10:43 AM
Or just install Arista Transcoder. It's a really good simple video transcoding app that has a preset for Youtube. Couple of clicks and you're done. It's in the repos.

dragon1111
February 15th, 2011, 11:10 AM
thanks it worked :)