PDA

View Full Version : [lubuntu] How to disable gnome-terminal transparency in compiz



bergamot
February 14th, 2011, 02:57 PM
I am running Ubuntu 10.04 with Compiz enabled (Visual Effects = Normal, in the System-Preferences-Appearance)

The gnome-terminals are transparent. I would like to disable the transparency, because I have a lot of terminals open at the same time and I don't want to be able to see one below another one.

In the gnome-terminal preferences, Background is set to "solid colour". However, Compiz seems to be over-riding this somehow.

I have the CompizConfig Settings Manager installed. I have looked through it but I can't find an option which disables the transparency for terminals. I tried the Opacity, Brightness and Saturation plugin, but it only allows you to vary the transparency level, not disable it entirely, and there doesn't seem to be a way of setting a default.

I like Compiz very much, so I don't want to disable the desktop effects. Does anyone know how to just disable the gnome-terminal transparency?

Thanks very much.


PS. I'm not using lubuntu. Somehow I selected that and I can't get rid of it now. I'm on Ubuntu with Gnome.

Frogs Hair
February 14th, 2011, 03:25 PM
I use Compiz with extra plug-ins , but my ability to change the terminal background from preferences is unchanged . A screen-shot of the ccsm may help to figure what effect you are using that I am not. Does the GTK theme include transparency ?

bergamot
February 14th, 2011, 03:54 PM
I am not using any extra plugins for Compiz, just the default set.

But anyway... I think I've fixed it actually...sort of.

In the gnome-terminal preferences, I can't get of the transparency by selecting Solid Colour, but I can select Transparent Background and pull the slider to the Max. That effectively disables the transparency. Which will do fine for me.

Thanks for your help anyway.

JOHNNYG713
February 14th, 2011, 04:33 PM
open Terminal, click Edit, profile prefferances, back ground, set as you like !