PDA

View Full Version : [ubuntu] 10.10 network doesn't work



victorming
February 12th, 2011, 03:58 AM
hi, guys,

I installed 10.10, and after reboot there are two FATAL errors: Could not load /lib/modules/2.6.35-22.generic/modules.deb. I fix this following the tips through below commands:
$sudo gedit /etc/initramfs-tools/initramfs.conf
and change the line "MODULES=most" to "MODULES=dep".

Then, two error messages gone, but I can't find the network manager icon on the system bar. And whatever configuration - DHCP, manul,... I tried in network manager, it seems the network doesn't work. Anybody can help?
Thanks!

victorming
February 12th, 2011, 08:19 AM
No one can reply this? or nobody ever encounters this issue? maybe I should reinstall Ubuntu.

grahammechanical
February 12th, 2011, 03:16 PM
If you have recently installed Ubuntu then you may not have a lot of data to lose. So, a re-installation would be simple to do. But what is the problem? You cannot see the Network Icon? Or, the Network does not work? These are two different problems.

1) Go to System>Preferences>Startup Applications and make sure that there is a tick mark against Network Manager.

2) Right click on the top panel and select Add to Panel from the menu. From the list that appears select Notification Area and click Add.

3) Shutdown and reboot.

If none of this works then we will need more information than that which you have provided. Is your machine a laptop? That will make a difference. Are you trying to connect by wireless or by ethernet cable? This information is useful. Without it, and other information, we could be telling you to do this or that and still not solve the problem. In fact, it could create other problems.

Regards.

victorming
February 21st, 2011, 02:25 AM
If you have recently installed Ubuntu then you may not have a lot of data to lose. So, a re-installation would be simple to do. But what is the problem? You cannot see the Network Icon? Or, the Network does not work? These are two different problems.

1) Go to System>Preferences>Startup Applications and make sure that there is a tick mark against Network Manager.

2) Right click on the top panel and select Add to Panel from the menu. From the list that appears select Notification Area and click Add.

3) Shutdown and reboot.

If none of this works then we will need more information than that which you have provided. Is your machine a laptop? That will make a difference. Are you trying to connect by wireless or by ethernet cable? This information is useful. Without it, and other information, we could be telling you to do this or that and still not solve the problem. In fact, it could create other problems.

Regards.

I used a laptop and connect by ethernet cable. I've solved this issue, partly since it will reappear if I update the system. It depends on whether you make your network setting Managed or Unmanaged. When I set the network managed, which is the default, I can't connect to the Internet. And if I make it unmanaged the network is OK. I don't know why it's designed like this and I found it weary.
Thanks again for your reply, anyway!