PDA

View Full Version : [mythbuntu] Nvidia, HDMI - resolution issue



el_Paraguayo
February 11th, 2011, 06:49 PM
I know this has been asked a thousand times.

I followed the instructions in this thread (http://ubuntuforums.org/showthread.php?t=884211) but it doesn't quite seem to work.

I still end up with massive fonts in the panel at the top of the screen e.g "Applications" and the clock and elsewhere. I could fix this by changing the font size in Appearance settings dialogue but that doesn't seem right to me (especially as if I then connect a screen via VGA instead, the fonts are minuscule!).

A couple of differences from the solution in that post:

@ 3 - I had to select CRT-0 to get the Acquire EDID option
@5 - I used DFP-1 as this was the option in Nvidia X Server Settings when using HDMI.

I've posted my xorg.conf below and would appreciate some comments.


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 260.19.06 (buildd@palmer) Mon Oct 4 16:01:38 UTC 2010

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "SAMSUNG"
HorizSync 15.0 - 46.0
VertRefresh 49.0 - 61.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "CustomEDID" "DFP-1:/home/anto/Nvidia/edid.bin"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 210"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Default Device"
Monitor "Monitor0"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSectionMany thanks.

BicyclerBoy
February 11th, 2011, 10:17 PM
In the /etc/X11/xorg.conf..
comment out the modules section
reboot

Post your /var/log/Xorg.0.log

I doubt you needed to use a custom EDID..just may have needed
Option "UseEDID" "FALSE"


Did you acquire EDID with display connected by VGA cable ?
Your display will (most likely) have a different (bad) video modes for VGA compared to HDMI.

el_Paraguayo
February 22nd, 2011, 09:43 AM
Bicycler Boy, apologies for the very slow reply - your comments are greatly appreciated.

For some strange reason the machine has, I think, decided to give me the correct resolution. Not quite sure why.

Thanks for your help.