PDA

View Full Version : [ubuntu] 10.10 - problem with videodrivers



ookami.kb
February 11th, 2011, 05:30 PM
I've installed Ubuntu 10.10 on notebook with integrated videocard. I can only set resolution to 800x600, although it must support 1366x768.
lspci | grep VGA shows it has SiS videocard, but in Xorg.0.log it appears as Vesa(0). I've installed xserver-xorg-video-sis but it makes no difference. Can someone tell me what can I do with that? Sorry for my English.

realzippy
February 11th, 2011, 05:41 PM
Have a look here (http://ubuntuforums.org/showpost.php?p=10448730&postcount=4),and try this.
And welcome to the forum..

ookami.kb
February 12th, 2011, 10:12 AM
Thanks.
Unfortunately, it didn't help. X refuses to load with these options.
System loads in console mode and startx doesn't help.
lspci shows:
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10) (prog-if 00 [VGA controller])
Subsystem: CLEVO/KAPOK Computer Device 0804
Flags: 66MHz, medium devsel, IRQ 5
BIST result: 00
Memory at c0000000 (32-bit, prefetchable) [size=256M]
Memory at d8000000 (32-bit, non-prefetchable) [size=128K]
I/O ports at 9000 [size=128]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>

how can I find, which driver is used?

grege
February 12th, 2011, 01:13 PM
Try this ...

Delete the /etc/X11/xorg.conf you created

then run this command

sudo Xorg :1 -configure

which will create xorg.conf.new in your home folder. Copy this file as root to /etc/X11 renaming it as xorg.conf

Then edit the line Driver "vesa" to Driver "sis" save and restart and see what happens.

grege
February 12th, 2011, 01:18 PM
ps

It is always worth installing midnight commander for copying and moving files in a terminal. Much easier than remembering all the syntax of cp and mv.

sudo apt-get install mc

run mc as a normal user for the first time and go Options -> Configuration and select use internal edit and then save

Then you can run sudo mc and move and copy and edit files as needed.

realzippy
February 12th, 2011, 01:30 PM
Try this ...

Delete the /etc/X11/xorg.conf you created

then run this command

sudo Xorg :1 -configure

which will create xorg.conf.new in your home folder. Copy this file as root to /etc/X11 renaming it as xorg.conf

Then edit the line Driver "vesa" to Driver "sis" save and restart and see what happens.

I do not know if sudo Xorg :1 -configure works;normally it is
sudo Xorg -configure..
And,important,you have to stop the running X session before:


press Alt+Ctrl+F1
log in with username+password
run:

sudo service gdm stop



sudo Xorg -configure

,,the created xorg.conf.new is in your homefolder,copy it to
/etc/X11/xorg.conf

realzippy
February 12th, 2011, 01:32 PM
Thanks.
Unfortunately, it didn't help. X refuses to load with these options.
System loads in console mode and startx doesn't help.
lspci shows:
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10) (prog-if 00 [VGA controller])
Subsystem: CLEVO/KAPOK Computer Device 0804
Flags: 66MHz, medium devsel, IRQ 5
BIST result: 00
Memory at c0000000 (32-bit, prefetchable) [size=256M]
Memory at d8000000 (32-bit, non-prefetchable) [size=128K]
I/O ports at 9000 [size=128]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>

how can I find, which driver is used?

...have you deleted the xorg.conf as also described in given link
in the case of not booting?

how can I find, which driver is used?

type

lshw -C Display

under "configuration" loaded driver is listed.

ookami.kb
February 12th, 2011, 03:55 PM
lshw -C Display shows next:
*-display UNCLAIMED
description: VGA compatible controller
product: 771/671 PCIE VGA Display Adapter
vendor: Silicon Integrated Systems [SiS]
physical id: 0
bus info: pci@0000:01:00.0
version: 10
width: 32 bits
clock: 66MHz
capabilities: pm agp agp-3.0 vga_controller cap_list
configuration: latency=0
resources: memory:c0000000-cfffffff memory:d8000000-d801ffff ioport:9000(size=128)

Xorg -configure generates next file:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "glx"
Load "dri"
Load "dri2"
Load "extmod"
Load "record"
Load "dbe"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
### <percent>: "<f>%"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "Rotate" # <str>
#Option "fbdev" # <str>
#Option "debug" # [<bool>]
Identifier "Card0"
Driver "fbdev"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

with this file startx refuses to start, writes screen found, but no usable configuration
if I change driver to "sis" it writes that no device found

and, yes, if i remove xorg.conf it starts normally but only 800x600 resolution

realzippy
February 12th, 2011, 05:51 PM
....try this minimal version:


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
Option "DPMS"
EndSection

Section "Device"
Identifier "Card0"
Driver "fbdev"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection


If no success,post your /var/log/Xorg.0.log file.

ookami.kb
February 12th, 2011, 06:04 PM
By playing a little with xorg.cong i've started xserver with "vesa" driver and 1024x768 resolution. But now problem is - my notebook has widescreen (mus have 1366x768 resolution) and it seem to me, that vesa driver doesn't support this resolution.
I've downloaded several drivers versions of SIS but no one works correctly - it writes either "didn't find proper sync/refresh rate", although it's written in xorg conf, or shows colour strips and other artefacts on monitor.

realzippy
February 12th, 2011, 06:09 PM
Found something interesting in the german ubuntu forum (http://forum.ubuntuusers.de/topic/grafikaufloesung-aender-grafikkarte-sis-771-/#post-2751628).
This guy (http://ajoliveira.com/ajoliveira/uk/software/xorg.php) has a driver for your card..

if you need help for these instructions,I can "translate" them for you.
Need to know if you run 32 or 64 bit Ubuntu...

ookami.kb
February 12th, 2011, 06:20 PM
On this driver it shows an error:
No valid modes found - check VertRefresh/HorizSync

realzippy
February 12th, 2011, 06:26 PM
On this driver it shows an error:
No valid modes found - check VertRefresh/HorizSync

..so make the "monitor" section in xorg.conf like this:



Section "Monitor"
Identifier "Configured Monitor"
HorizSync 28-72
VertRefresh 43-60
EndSection


...if done already,increase Hsync/Vrefresh values.

ookami.kb
February 12th, 2011, 06:38 PM
Yeah, I've tried that. No effect.
With VESA driver and these settings it looks normal, if I increase these setting, it looks bad even with vesa driver.
Also I've tried that xorg.config with vesa driver - it look normal on 1024x768, but if I change to 1366x768 or 1280x800 the picture is disturbed very much.

realzippy
February 12th, 2011, 07:39 PM
If your display is garbled at start you may want to try this (#bug 539582)

# sudo echo blacklist vga16fb > /etc/modprobe.d/blacklist-vga16fb.conf
# sudo update-initramfs -u 'all'


Have you ? Guess so.

ookami.kb
February 12th, 2011, 07:43 PM
Yeah, that I've tried too )))
No effect...

realzippy
February 12th, 2011, 08:24 PM
..so what happens when setting resolutions with xrandr?
(after generating modeline ,adding mode,aso...)
And the Xorg.0.log file?

ookami.kb
February 13th, 2011, 07:35 PM
xrandr settings don't help - when I'm trying to apply 1366x768 resolution with vesa it writes that this resolution is not supported
and this is xorg.log for sis671 driver:


[ 58.579]
X.Org X Server 1.9.2.901 (1.9.3 RC 1)
Release Date: 2010-11-13
[ 58.579] X Protocol Version 11, Revision 0
[ 58.579] Build Operating System: Linux 2.6.24-28-xen i686 Ubuntu
[ 58.579] Current Operating System: Linux pusya 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:48 UTC 2011 i686
[ 58.579] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-25-generic root=UUID=542504f5-4658-424f-ad68-b59653fb30e6 ro quiet splash
[ 58.579] Build Date: 29 November 2010 03:29:38PM
[ 58.579] xorg-server 2:1.9.2.901+git20101129+server-1.9-branch.65f2ab20-0ubuntu0sarvatt2~maverick (For technical support please see http://www.ubuntu.com/support)
[ 58.579] Current version of pixman: 0.21.4
[ 58.579] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 58.579] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 58.579] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 13 23:31:06 2011
[ 58.580] (==) Using config file: "/etc/X11/xorg.conf"
[ 58.580] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 58.580] (==) No Layout section. Using the first Screen section.
[ 58.580] (**) |-->Screen "Default Screen" (0)
[ 58.580] (**) | |-->Monitor "wxga"
[ 58.580] (**) | |-->Device "sis"
[ 58.580] (==) Automatically adding devices
[ 58.580] (==) Automatically enabling devices
[ 58.580] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 58.580] Entry deleted from font path.
[ 58.581] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
[ 58.581] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 58.581] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 58.581] (II) Loader magic: 0x81fa7c0
[ 58.581] (II) Module ABI versions:
[ 58.581] X.Org ANSI C Emulation: 0.4
[ 58.581] X.Org Video Driver: 8.0
[ 58.581] X.Org XInput driver : 11.0
[ 58.581] X.Org Server Extension : 4.0
[ 58.581] (--) PCI:*(0:1:0:0) 1039:6351:1558:0804 rev 16, Mem @ 0xc0000000/268435456, 0xd8000000/131072, I/O @ 0x00009000/128
[ 58.582] (II) Open ACPI successful (/var/run/acpid.socket)
[ 58.582] (II) LoadModule: "extmod"
[ 58.582] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 58.583] (II) Module extmod: vendor="X.Org Foundation"
[ 58.583] compiled for 1.9.2.901, module version = 1.0.0
[ 58.583] Module class: X.Org Server Extension
[ 58.583] ABI class: X.Org Server Extension, version 4.0
[ 58.583] (II) Loading extension MIT-SCREEN-SAVER
[ 58.583] (II) Loading extension XFree86-VidModeExtension
[ 58.583] (II) Loading extension XFree86-DGA
[ 58.583] (II) Loading extension DPMS
[ 58.583] (II) Loading extension XVideo
[ 58.583] (II) Loading extension XVideo-MotionCompensation
[ 58.583] (II) Loading extension X-Resource
[ 58.583] (II) LoadModule: "dbe"
[ 58.583] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 58.583] (II) Module dbe: vendor="X.Org Foundation"
[ 58.583] compiled for 1.9.2.901, module version = 1.0.0
[ 58.583] Module class: X.Org Server Extension
[ 58.583] ABI class: X.Org Server Extension, version 4.0
[ 58.583] (II) Loading extension DOUBLE-BUFFER
[ 58.583] (II) LoadModule: "glx"
[ 58.583] (II) Loading /usr/lib/xorg/extra-modules/libglx.so
[ 58.617] (II) Module glx: vendor="NVIDIA Corporation"
[ 58.617] compiled for 4.0.2, module version = 1.0.0
[ 58.617] Module class: X.Org Server Extension
[ 58.617] (II) NVIDIA GLX Module 270.18 Tue Jan 18 22:02:12 PST 2011
[ 58.617] (II) Loading extension GLX
[ 58.617] (II) LoadModule: "record"
[ 58.618] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 58.618] (II) Module record: vendor="X.Org Foundation"
[ 58.618] compiled for 1.9.2.901, module version = 1.13.0
[ 58.618] Module class: X.Org Server Extension
[ 58.618] ABI class: X.Org Server Extension, version 4.0
[ 58.618] (II) Loading extension RECORD
[ 58.618] (II) LoadModule: "dri"
[ 58.618] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 58.619] (II) Module dri: vendor="X.Org Foundation"
[ 58.619] compiled for 1.9.2.901, module version = 1.0.0
[ 58.619] ABI class: X.Org Server Extension, version 4.0
[ 58.619] (II) Loading extension XFree86-DRI
[ 58.619] (II) LoadModule: "dri2"
[ 58.619] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 58.619] (II) Module dri2: vendor="X.Org Foundation"
[ 58.619] compiled for 1.9.2.901, module version = 1.2.0
[ 58.619] ABI class: X.Org Server Extension, version 4.0
[ 58.619] (II) Loading extension DRI2
[ 58.619] (II) LoadModule: "sis671"
[ 58.619] (II) Loading /usr/lib/xorg/modules/drivers/sis671_drv.so
[ 58.644] (II) Module sis671: vendor="X.Org Foundation"
[ 58.644] compiled for 1.9.0, module version = 0.8.0
[ 58.644] Module class: X.Org Video Driver
[ 58.644] ABI class: X.Org Video Driver, version 8.0
[ 58.644] (II) SIS: driver for SiS chipsets: SIS5597/5598, SIS530/620,
SIS6326/AGP/DVD, SIS300/305, SIS630/730, SIS540, SIS315, SIS315H,
SIS315PRO/E, SIS550, SIS650/M650/651/740, SIS330(Xabre),
SIS[M]661[F|M]X/[M]741[GX]/[M]760[GX]/[M]761[GX]/662, SIS340,
[M]670/[M]770[GX], [M]671/[M]771[GX]
[ 58.645] (II) SIS: driver for XGI chipsets: Volari Z7 (XG20),
Volari V3XT/V5/V8/Duo (XG40/XG42)
[ 58.645] (--) using VT number 8

[ 58.649] (WW) Falling back to old probe method for sis671
[ 58.649] (--) Assigning device section with no busID to primary device
[ 58.649] (--) Chipset [M]671/[M]771[GX] found
[ 58.650] (II) SIS(0): SiS driver (2006/10/17-1, compiled for X.org 1.9.0.0)
[ 58.650] (II) SIS(0): Copyright (C) 2001-2005 Thomas Winischhofer <thomas@winischhofer.net> and others
[ 58.650] (II) SIS(0): *** See http://www.winischhofer.at/linuxsisvga.shtml
[ 58.650] (II) SIS(0): *** for documentation, updates and a Premium Version.
[ 58.650] (II) SIS(0): RandR rotation support not available in this version.
[ 58.650] (II) SIS(0): Dynamic modelist support not available in this version.
[ 58.650] (II) SIS(0): Screen growing support not available in this version.
[ 58.650] (II) SIS(0): Advanced Xv video blitter not available in this version.
[ 58.650] (II) SIS(0): Advanced MergedFB support not available in this version.
[ 58.651] (--) SIS(0): sisfb not found
[ 58.651] (--) SIS(0): Relocated I/O registers at 0x9000
[ 58.651] (II) Loading sub module "ramdac"
[ 58.651] (II) LoadModule: "ramdac"
[ 58.651] (II) Module "ramdac" already built-in
[ 58.651] (**) SIS(0): Depth 24, (--) framebuffer bpp 32
[ 58.651] (==) SIS(0): RGB weight 888
[ 58.651] (==) SIS(0): Default visual is TrueColor
[ 58.651] (WW) SIS(0): Could not find/read video BIOS
[ 58.652] (==) SIS(0): Color HW cursor is enabled
[ 58.652] (II) SIS(0): Using VRAM command queue, size 512k
[ 58.652] (==) SIS(0): Hotkey display switching is enabled
[ 58.652] (==) SIS(0): SiSCtrl utility interface is disabled
[ 58.652] (II) SIS(0): For information on SiSCtrl, see
http://www.winischhofer.at/linuxsispart1.shtml#sisctrl
[ 58.652] (==) SIS(0): X server will not keep DPI constant for all screen sizes
[ 58.652] (==) SIS(0): DRI enabled
[ 58.652] (II) SIS(0): Checking OS for SSE support is not supported in this version of X.org
[ 58.652] (II) SIS(0): If your OS supports SSE, set the option "UseSSE" to "on".
[ 58.652] (--) SIS(0): 262144K shared video RAM (UMA)
[ 58.652] (--) SIS(0): DRAM type: DDR SDRAM
[ 58.652] (--) SIS(0): Memory clock: 596.582 MHz
[ 58.652] (--) SIS(0): DRAM bus width: 64 bit
[ 58.652] (--) SIS(0): Linear framebuffer at 0xC0000000
[ 58.652] (--) SIS(0): MMIO registers at 0xD8000000 (size 64K)
[ 58.652] (--) SIS(0): VideoRAM: 262144 KB
[ 58.652] (II) SIS(0): Using 20480K of framebuffer memory at offset 0K
[ 58.652] (II) Loading sub module "ddc"
[ 58.652] (II) LoadModule: "ddc"
[ 58.652] (II) Module "ddc" already built-in
[ 58.652] (--) SIS(0): Detected SiS307LV video bridge (Charter/UMC-1, ID 7; Rev 0xe1)
[ 60.421] (--) SIS(0): No CRT1/VGA detected
[ 60.421] (--) SIS(0): Detected LCD/Plasma panel (max. X 0 Y 0, pref. 0x0, RGB24)
[ 60.421] (**) SIS(0): Using gamma correction (1.0, 1.0, 1.0)
[ 60.421] (II) SIS(0): CRT1 gamma correction is enabled
[ 60.421] (II) SIS(0): Separate Xv gamma correction for CRT1 is disabled
[ 60.421] (II) SIS(0): CRT2 gamma correction is enabled
[ 60.421] (--) SIS(0): Memory bandwidth at 32 bpp is 1193.16 MHz
[ 60.421] (--) SIS(0): Detected LCD PanelDelayCompensation 0x00 (for LCD=CRT2)
[ 60.421] (--) SIS(0): Detected LCD PanelDelayCompensation 0x00 (for LCD=CRT1)
[ 60.421] (--) SIS(0): 302LV/302ELV: Using EMI 0x0a0d7038 (LCD)
[ 60.421] (--) SIS(0): CRT2 DDC probing failed
[ 60.421] (==) SIS(0): Min pixel clock is 10 MHz
[ 60.421] (--) SIS(0): Max pixel clock is 340 MHz
[ 60.421] (II) SIS(0): Replaced entire mode list with built-in modes
[ 60.421] (II) SIS(0): Correcting bogus CRT2 monitor HSync range
[ 60.421] (II) SIS(0): Correcting bogus CRT2 monitor VRefresh range
[ 60.421] (II) SIS(0): "Unknown reason" in the following list means that the mode
[ 60.421] (II) SIS(0): is not supported on the chipset/bridge/current output device.
[ 60.421] (II) SIS(0): wxga: Using hsync range of 30.00-80.00 kHz
[ 60.421] (II) SIS(0): wxga: Using vrefresh range of 59.00-61.00 Hz
[ 60.421] (II) SIS(0): wxga: Using vrefresh value of 71.00 Hz
[ 60.421] (II) SIS(0): Clock range: 10.00 to 340.00 MHz
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1280x1024" (width too large for virtual size)
[ 60.421] (II) SIS(0): Not using default mode "1280x1024" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x1024" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x1024" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x800" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x800" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x800" (width too large for virtual size)
[ 60.422] (WW) SIS(0): Mode pool is empty
[ 60.422] (EE) SIS(0): **************************************************
[ 60.422] (EE) SIS(0): ERROR:
[ 60.422] (EE) SIS(0): No valid modes found - check VertRefresh/HorizSync
[ 60.422] (EE) SIS(0): END OF MESSAGE
[ 60.422] (EE) SIS(0): **************************************************
[ 60.422] (II) UnloadModule: "sis671"
[ 60.422] (EE) Screen(s) found, but none have a usable configuration.
[ 60.422]
Fatal server error:
[ 60.422] no screens found
[ 60.422]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 60.422] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 60.422]
[ 60.425] ddxSigGiveUp: Closing log

ibiker
March 10th, 2011, 08:27 PM
xrandr settings don't help - when I'm trying to apply 1366x768 resolution with vesa it writes that this resolution is not supported
and this is xorg.log for sis671 driver:


[ 58.579]
X.Org X Server 1.9.2.901 (1.9.3 RC 1)
Release Date: 2010-11-13
[ 58.579] X Protocol Version 11, Revision 0
[ 58.579] Build Operating System: Linux 2.6.24-28-xen i686 Ubuntu
[ 58.579] Current Operating System: Linux pusya 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:48 UTC 2011 i686
[ 58.579] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-25-generic root=UUID=542504f5-4658-424f-ad68-b59653fb30e6 ro quiet splash
[ 58.579] Build Date: 29 November 2010 03:29:38PM
[ 58.579] xorg-server 2:1.9.2.901+git20101129+server-1.9-branch.65f2ab20-0ubuntu0sarvatt2~maverick (For technical support please see http://www.ubuntu.com/support)
[ 58.579] Current version of pixman: 0.21.4
[ 58.579] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 58.579] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 58.579] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Feb 13 23:31:06 2011
[ 58.580] (==) Using config file: "/etc/X11/xorg.conf"
[ 58.580] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 58.580] (==) No Layout section. Using the first Screen section.
[ 58.580] (**) |-->Screen "Default Screen" (0)
[ 58.580] (**) | |-->Monitor "wxga"
[ 58.580] (**) | |-->Device "sis"
[ 58.580] (==) Automatically adding devices
[ 58.580] (==) Automatically enabling devices
[ 58.580] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 58.580] Entry deleted from font path.
[ 58.581] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
built-ins
[ 58.581] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 58.581] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 58.581] (II) Loader magic: 0x81fa7c0
[ 58.581] (II) Module ABI versions:
[ 58.581] X.Org ANSI C Emulation: 0.4
[ 58.581] X.Org Video Driver: 8.0
[ 58.581] X.Org XInput driver : 11.0
[ 58.581] X.Org Server Extension : 4.0
[ 58.581] (--) PCI:*(0:1:0:0) 1039:6351:1558:0804 rev 16, Mem @ 0xc0000000/268435456, 0xd8000000/131072, I/O @ 0x00009000/128
[ 58.582] (II) Open ACPI successful (/var/run/acpid.socket)
[ 58.582] (II) LoadModule: "extmod"
[ 58.582] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 58.583] (II) Module extmod: vendor="X.Org Foundation"
[ 58.583] compiled for 1.9.2.901, module version = 1.0.0
[ 58.583] Module class: X.Org Server Extension
[ 58.583] ABI class: X.Org Server Extension, version 4.0
[ 58.583] (II) Loading extension MIT-SCREEN-SAVER
[ 58.583] (II) Loading extension XFree86-VidModeExtension
[ 58.583] (II) Loading extension XFree86-DGA
[ 58.583] (II) Loading extension DPMS
[ 58.583] (II) Loading extension XVideo
[ 58.583] (II) Loading extension XVideo-MotionCompensation
[ 58.583] (II) Loading extension X-Resource
[ 58.583] (II) LoadModule: "dbe"
[ 58.583] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 58.583] (II) Module dbe: vendor="X.Org Foundation"
[ 58.583] compiled for 1.9.2.901, module version = 1.0.0
[ 58.583] Module class: X.Org Server Extension
[ 58.583] ABI class: X.Org Server Extension, version 4.0
[ 58.583] (II) Loading extension DOUBLE-BUFFER
[ 58.583] (II) LoadModule: "glx"
[ 58.583] (II) Loading /usr/lib/xorg/extra-modules/libglx.so
[ 58.617] (II) Module glx: vendor="NVIDIA Corporation"
[ 58.617] compiled for 4.0.2, module version = 1.0.0
[ 58.617] Module class: X.Org Server Extension
[ 58.617] (II) NVIDIA GLX Module 270.18 Tue Jan 18 22:02:12 PST 2011
[ 58.617] (II) Loading extension GLX
[ 58.617] (II) LoadModule: "record"
[ 58.618] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 58.618] (II) Module record: vendor="X.Org Foundation"
[ 58.618] compiled for 1.9.2.901, module version = 1.13.0
[ 58.618] Module class: X.Org Server Extension
[ 58.618] ABI class: X.Org Server Extension, version 4.0
[ 58.618] (II) Loading extension RECORD
[ 58.618] (II) LoadModule: "dri"
[ 58.618] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 58.619] (II) Module dri: vendor="X.Org Foundation"
[ 58.619] compiled for 1.9.2.901, module version = 1.0.0
[ 58.619] ABI class: X.Org Server Extension, version 4.0
[ 58.619] (II) Loading extension XFree86-DRI
[ 58.619] (II) LoadModule: "dri2"
[ 58.619] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 58.619] (II) Module dri2: vendor="X.Org Foundation"
[ 58.619] compiled for 1.9.2.901, module version = 1.2.0
[ 58.619] ABI class: X.Org Server Extension, version 4.0
[ 58.619] (II) Loading extension DRI2
[ 58.619] (II) LoadModule: "sis671"
[ 58.619] (II) Loading /usr/lib/xorg/modules/drivers/sis671_drv.so
[ 58.644] (II) Module sis671: vendor="X.Org Foundation"
[ 58.644] compiled for 1.9.0, module version = 0.8.0
[ 58.644] Module class: X.Org Video Driver
[ 58.644] ABI class: X.Org Video Driver, version 8.0
[ 58.644] (II) SIS: driver for SiS chipsets: SIS5597/5598, SIS530/620,
SIS6326/AGP/DVD, SIS300/305, SIS630/730, SIS540, SIS315, SIS315H,
SIS315PRO/E, SIS550, SIS650/M650/651/740, SIS330(Xabre),
SIS[M]661[F|M]X/[M]741[GX]/[M]760[GX]/[M]761[GX]/662, SIS340,
[M]670/[M]770[GX], [M]671/[M]771[GX]
[ 58.645] (II) SIS: driver for XGI chipsets: Volari Z7 (XG20),
Volari V3XT/V5/V8/Duo (XG40/XG42)
[ 58.645] (--) using VT number 8

[ 58.649] (WW) Falling back to old probe method for sis671
[ 58.649] (--) Assigning device section with no busID to primary device
[ 58.649] (--) Chipset [M]671/[M]771[GX] found
[ 58.650] (II) SIS(0): SiS driver (2006/10/17-1, compiled for X.org 1.9.0.0)
[ 58.650] (II) SIS(0): Copyright (C) 2001-2005 Thomas Winischhofer <thomas@winischhofer.net> and others
[ 58.650] (II) SIS(0): *** See http://www.winischhofer.at/linuxsisvga.shtml
[ 58.650] (II) SIS(0): *** for documentation, updates and a Premium Version.
[ 58.650] (II) SIS(0): RandR rotation support not available in this version.
[ 58.650] (II) SIS(0): Dynamic modelist support not available in this version.
[ 58.650] (II) SIS(0): Screen growing support not available in this version.
[ 58.650] (II) SIS(0): Advanced Xv video blitter not available in this version.
[ 58.650] (II) SIS(0): Advanced MergedFB support not available in this version.
[ 58.651] (--) SIS(0): sisfb not found
[ 58.651] (--) SIS(0): Relocated I/O registers at 0x9000
[ 58.651] (II) Loading sub module "ramdac"
[ 58.651] (II) LoadModule: "ramdac"
[ 58.651] (II) Module "ramdac" already built-in
[ 58.651] (**) SIS(0): Depth 24, (--) framebuffer bpp 32
[ 58.651] (==) SIS(0): RGB weight 888
[ 58.651] (==) SIS(0): Default visual is TrueColor
[ 58.651] (WW) SIS(0): Could not find/read video BIOS
[ 58.652] (==) SIS(0): Color HW cursor is enabled
[ 58.652] (II) SIS(0): Using VRAM command queue, size 512k
[ 58.652] (==) SIS(0): Hotkey display switching is enabled
[ 58.652] (==) SIS(0): SiSCtrl utility interface is disabled
[ 58.652] (II) SIS(0): For information on SiSCtrl, see
http://www.winischhofer.at/linuxsispart1.shtml#sisctrl
[ 58.652] (==) SIS(0): X server will not keep DPI constant for all screen sizes
[ 58.652] (==) SIS(0): DRI enabled
[ 58.652] (II) SIS(0): Checking OS for SSE support is not supported in this version of X.org
[ 58.652] (II) SIS(0): If your OS supports SSE, set the option "UseSSE" to "on".
[ 58.652] (--) SIS(0): 262144K shared video RAM (UMA)
[ 58.652] (--) SIS(0): DRAM type: DDR SDRAM
[ 58.652] (--) SIS(0): Memory clock: 596.582 MHz
[ 58.652] (--) SIS(0): DRAM bus width: 64 bit
[ 58.652] (--) SIS(0): Linear framebuffer at 0xC0000000
[ 58.652] (--) SIS(0): MMIO registers at 0xD8000000 (size 64K)
[ 58.652] (--) SIS(0): VideoRAM: 262144 KB
[ 58.652] (II) SIS(0): Using 20480K of framebuffer memory at offset 0K
[ 58.652] (II) Loading sub module "ddc"
[ 58.652] (II) LoadModule: "ddc"
[ 58.652] (II) Module "ddc" already built-in
[ 58.652] (--) SIS(0): Detected SiS307LV video bridge (Charter/UMC-1, ID 7; Rev 0xe1)
[ 60.421] (--) SIS(0): No CRT1/VGA detected
[ 60.421] (--) SIS(0): Detected LCD/Plasma panel (max. X 0 Y 0, pref. 0x0, RGB24)
[ 60.421] (**) SIS(0): Using gamma correction (1.0, 1.0, 1.0)
[ 60.421] (II) SIS(0): CRT1 gamma correction is enabled
[ 60.421] (II) SIS(0): Separate Xv gamma correction for CRT1 is disabled
[ 60.421] (II) SIS(0): CRT2 gamma correction is enabled
[ 60.421] (--) SIS(0): Memory bandwidth at 32 bpp is 1193.16 MHz
[ 60.421] (--) SIS(0): Detected LCD PanelDelayCompensation 0x00 (for LCD=CRT2)
[ 60.421] (--) SIS(0): Detected LCD PanelDelayCompensation 0x00 (for LCD=CRT1)
[ 60.421] (--) SIS(0): 302LV/302ELV: Using EMI 0x0a0d7038 (LCD)
[ 60.421] (--) SIS(0): CRT2 DDC probing failed
[ 60.421] (==) SIS(0): Min pixel clock is 10 MHz
[ 60.421] (--) SIS(0): Max pixel clock is 340 MHz
[ 60.421] (II) SIS(0): Replaced entire mode list with built-in modes
[ 60.421] (II) SIS(0): Correcting bogus CRT2 monitor HSync range
[ 60.421] (II) SIS(0): Correcting bogus CRT2 monitor VRefresh range
[ 60.421] (II) SIS(0): "Unknown reason" in the following list means that the mode
[ 60.421] (II) SIS(0): is not supported on the chipset/bridge/current output device.
[ 60.421] (II) SIS(0): wxga: Using hsync range of 30.00-80.00 kHz
[ 60.421] (II) SIS(0): wxga: Using vrefresh range of 59.00-61.00 Hz
[ 60.421] (II) SIS(0): wxga: Using vrefresh value of 71.00 Hz
[ 60.421] (II) SIS(0): Clock range: 10.00 to 340.00 MHz
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "800x600" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "640x480" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1024x768" (unknown reason)
[ 60.421] (II) SIS(0): Not using default mode "1280x1024" (width too large for virtual size)
[ 60.421] (II) SIS(0): Not using default mode "1280x1024" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x1024" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x1024" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1600x1200" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1920x1440" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "2048x1536" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x800" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x800" (width too large for virtual size)
[ 60.422] (II) SIS(0): Not using default mode "1280x800" (width too large for virtual size)
[ 60.422] (WW) SIS(0): Mode pool is empty
[ 60.422] (EE) SIS(0): **************************************************
[ 60.422] (EE) SIS(0): ERROR:
[ 60.422] (EE) SIS(0): No valid modes found - check VertRefresh/HorizSync
[ 60.422] (EE) SIS(0): END OF MESSAGE
[ 60.422] (EE) SIS(0): **************************************************
[ 60.422] (II) UnloadModule: "sis671"
[ 60.422] (EE) Screen(s) found, but none have a usable configuration.
[ 60.422]
Fatal server error:
[ 60.422] no screens found
[ 60.422]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 60.422] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 60.422]
[ 60.425] ddxSigGiveUp: Closing log


Hi. Did you get any further with this? I am having the exact same problem.

Thanks
IanB

Temüjin
March 11th, 2011, 12:15 AM
IanB: Post your /var/log/Xorg.0.log


[ 58.583] (II) Loading /usr/lib/xorg/extra-modules/libglx.so
[ 58.617] (II) Module glx: vendor="NVIDIA Corporation"
[ 58.617] compiled for 4.0.2, module version = 1.0.0
[ 58.617] Module class: X.Org Server Extension
[ 58.617] (II) NVIDIA GLX Module 270.18 Tue Jan 18 22:02:12 PST 2011
@ookami.kb: you tried to install proprietary nvidia driver and you now have nvidia's proprietary libglx.so
Uninstall/purge the nvidia driver and reinstall xserver-xorg-core package.