View Full Version : [ubuntu] How to delete top and bottom faces of Compiz cube

February 11th, 2011, 10:52 AM
How can you delete the bottom and the top faces of the Compiz cube?

February 11th, 2011, 11:40 AM
Go into compiz-config settings manager --> desktop cube --> appearance and delete the graphic under "cube caps".

February 11th, 2011, 11:43 AM

I tried it but it still shows me the top and the bottom cube faces.

February 11th, 2011, 11:45 AM
How many faces are there in your desktop cube? Mine has four and when I delete the cube cap I get holes at the top and bottom of the cube.

February 11th, 2011, 11:49 AM
I got 6 faces counting the top and the bottom too. It doesn't work for me.

Copper Bezel
February 11th, 2011, 04:37 PM
Yeah, ditto. If I remove the image and have cube deformation going on, whether or not I have "draw cube caps" enabled, I get a square polygon set into the top and bottom of the cylinder. It's semi-transparent, but it's there, and I couldn't find any way to make it go away, either.

February 11th, 2011, 04:41 PM
So there is no way to have a cube with no top and bottom faces?

February 11th, 2011, 05:11 PM
Open CCSM, Open Cube reflection and deformation, you will be in cube caps, click appearance, click top color, set opacity to 0 do the same for the bottom, to remove any image top or bottom simply delete the image

February 11th, 2011, 05:19 PM
Thanks for the answer, I really appreciate your help.

I done it, but the cube still have a semi-transparent color in the top and in the bottom faces.

March 11th, 2011, 10:46 AM
Heya i just post a fix for this but i shoulda posted Fix here instead i suppose


" Do u want a sphere with no top or bottom ? (the sphere but with transparent top and bottom or u can make it look like a fishbowl etc.) , i was trying to delete the default images too but to no avail.

solution : in "Enable cube reflection and deformation " under "appearance" click the "New " button then click "close" this will give you an empty picture so move it to the top of the list to make it default . Now still in "Enable cube reflection and deformation " Appearance change the opacity to " 0 "

Ty Yetiman "just double check you've moved them to the TOP of the list where they're setup" (thats what helped me :grin:) this has been bothering me for hrs too , sighned onto forum just to share this simple fix, seems a few ppl have had this problem of getting rid of default images , i had the semitransparent square on top of fishbowl problem : http://ubuntuforums.org/archive/inde...t-1685702.html (http://ubuntuforums.org/archive/index.php/t-1685702.html)

this was already marked as solved nearly a year ago but i couldnt find a solution anywhere. "

P.S. just a BIG thankyou to all that have made Ubuntu a pleasure to work with.

March 13th, 2011, 07:42 PM
Thank you very much :D .

I did it :) .