PDA

View Full Version : [ubuntu] where is nm-applet?



genjix
February 8th, 2011, 04:45 AM
It's definitely running- it even connects when I restart but I cannot see it.

Must have deleted something while re-arranging my panel.

I add notification area and just get a tiny square,
http://img17.imageshack.us/img17/1139/screenshotty.png

If you look closely you'll see 3 small squares (I've added 3 notification areas to show you). Even on reboot nothing appears in them.

genjix
February 8th, 2011, 12:14 PM
bump

nogger
February 8th, 2011, 12:26 PM
Try changing the colour of your panel (so you can see what's up there more clearly) and removing all instances of the nm-applet. Then add one back.

Worked for me - I'd somehow got three of them up there and none of them displayed correctly.

genjix
February 8th, 2011, 03:30 PM
Hey,

I tried that but didn't work... By chance I did:

killall nm-applet
nm-applet
And then it appears!

But not on reboot? Any ideas?

wtf... This Ubuntu release has been very bug prone for me. :p

Frogs Hair
February 8th, 2011, 03:43 PM
Try reseting panels to defaults .
gconftool --recursive-unset /apps/panel && killall gnome-panel

genjix
February 8th, 2011, 04:13 PM
Thanks, I used that and found the problem.

I had set my window manager to awesome,
gconftool-2 --type string --set /desktop/gnome/session/required_components/windowmanager awesome

Seems GNOME + awesome don't work together... :(