PDA

View Full Version : [ubuntu] kismet conf file



raac
January 19th, 2011, 02:26 AM
I can't seem to run kismet, but i don't know what to put in source. I have an USB atheros adapter, using the ath9k_htc driver, and my interface is wlan1. I don't know what to put there. Since I installed it from the repository I don't know how to open the README file

# Sources are defined as:
# source=sourcetype,interface,name[,initialchannel]
# Source types and required drivers are listed in the README under the
# CAPTURE SOURCES section.
# The initial channel is optional, if hopping is not enabled it can be used
# to set the channel the interface listens on.
# YOU MUST CHANGE THIS TO BE THE SOURCE YOU WANT TO USE

source =

# Comma-separated list of sources to enable. This is only needed if you defined
# multiple sources and only want to enable some of them. By default, all defined
# sources are enabled.
# For example:
# enablesources=prismsource,ciscosource
.
.
.
.

chili555
January 22nd, 2011, 03:40 PM
I don't know how to open the README fileIn a terminal, do:
less /usr/share/doc/kismet/README.gzUse the arrow keys to review sections 9 and 12.

Reading section 12, I am not at all sure your device will work with Kismet. I suggest you try a few likely looking Atheros settings and see what works. Perhaps something like:
source=ath5k,wlan1,atherosYou might also Google for kismet and ath9k_htc.

chili555
January 22nd, 2011, 03:44 PM
Please see:

http://www.kismetwireless.net/Forum/General/Messages/1231702725.208456
ath9k should use the same capture code as ath5k so while I don't generally recommend using the "wrong" source that shouldn't be the problem here.