PDA

View Full Version : [ubuntu] PC to TV via HDMI = no sound



maryalesia
January 9th, 2011, 05:53 AM
When I connect my pc to my TV with an HDMI chord, I am unable to get the sound to come out of my TV speakers (it does come out of the pc speakers, though).

I have tried switching the audio hardware to HDMI output on the PC and making sure that HDMI input is selected as the audio source in the TV. All that succeeds in doing is turning off the sound altogether.

This wasn't a problem before, because I had this really nifty altec lansing USB speaker that kicked some USB speaker butt. My rabbit chewed through the wire.

And so I have returned the the forums. :D

Any ideas?

Kasami
January 9th, 2011, 06:37 AM
What graphics card are you using? When I tried to run sound through HDMI to the television I had to install the proprietary drivers for my graphics card. Hope that helps =]

maryalesia
January 9th, 2011, 06:40 AM
What graphics card are you using? When I tried to run sound through HDMI to the television I had to install the proprietary drivers for my graphics card. Hope that helps =]

Nvidia Geforce 9800M GTS. I have the proprietary drivers installed. :confused:

Kasami
January 9th, 2011, 06:47 AM
Have you tried this solution?

http://ubuntuforums.org/showthread.php?t=1173022

maryalesia
January 9th, 2011, 06:51 AM
Have you tried this solution?

http://ubuntuforums.org/showthread.php?t=1173022

No, but it should be noted that I couldn't even if I wanted to because I like me my graphical user interface. Command line? What command line?

Thanks, though. :)

Kasami
January 9th, 2011, 06:54 AM
Command line is what you are using when you open a terminal. Applications > Accessories > Terminal.

maryalesia
January 9th, 2011, 06:57 AM
Command line is what you are using when you open a terminal. Applications > Accessories > Terminal.

I know what it is ... I just would rather not use it. I don't know bash and I don't understand what I read in that thread. I really do appreciate you trying to help, though.

VincentLaw
February 19th, 2011, 08:58 PM
I know what it is ... I just would rather not use it. I don't know bash and I don't understand what I read in that thread. I really do appreciate you trying to help, though.

I had the same issue and didn't find any other solution than opening a terminal :biggrin:
In case of, here is the solution that worked for me :
* Open a terminal
* Type in "alsamixer"
You got someting like this :


┌─────────────────────────────────── AlsaMixer v1.0.23 ───────────────────────────────────┐
│ Card: HDA Intel F1: Help │
│ Chip: Nvidia MCP77/78 HDMI F2: System information │
│ View: F3:[Playback] F4: Capture F5: All F6: Select sound card │
│ Item: S/PDIF 1 [Off] Esc: Exit │
│ │
│ │
│ ┌──┐ ┌──┐ │
│ │▒▒│ │ │ │
│ │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
│ │▒▒│ │ │ │
│ │▒▒│ │ │ │
│ ┌──┐ └──┘ Mic In Mic In ┌──┐ ┌──┐ Digital ┌──┐ ├──┤ │
│ │OO│ │OO│ │OO│ │MM│ │OO│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 100<>100 0 │
│ Bass Spe PCM Front Mi Mic Jack S/PDIF S/PDIF D S/PDIF P<S/PDIF 1> Beep │
│ │
│ │
└───────────────────────────────────────────────── ────────────────────────────────────────┘As you can see, my output "S/PDIF 1" is tagged "MM" for mute

* Put the cursor on it and hit "M". You'll see "[Off]" disapearing on the left upper side of the screen
* Sound is now ON !
* ESC to exit

Hope this will help

maryalesia
February 26th, 2011, 07:21 PM
thanks for the help! I did what you said, and was pleased that it didn't involve editing a bunch of code, which frightens me to no end. (I know just enough about the terminal to really screw things up).

Question, though:

do any of those sound card options have anything to do with a USB speaker? Because I use one, but my computer keeps randomly defaulting back to the internal speakers. Sound still comes out of the USB speaker, but volume controls no longer work on it. :confused:

Praet0rian
April 21st, 2012, 10:14 PM
I had the same issue and didn't find any other solution than opening a terminal :biggrin:
In case of, here is the solution that worked for me :
* Open a terminal
* Type in "alsamixer"
You got someting like this :


┌─────────────────────────────────── AlsaMixer v1.0.23 ───────────────────────────────────┐
│ Card: HDA Intel F1: Help │
│ Chip: Nvidia MCP77/78 HDMI F2: System information │
│ View: F3:[Playback] F4: Capture F5: All F6: Select sound card │
│ Item: S/PDIF 1 [Off] Esc: Exit │
│ │
│ │
│ ┌──┐ ┌──┐ │
│ │▒▒│ │ │ │
│ │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
< │▒▒│ │ │ │
│ │▒▒│ │ │ │
│ │▒▒│ │ │ │
│ ┌──┐ └──┘ Mic In Mic In ┌──┐ ┌──┐ Digital ┌──┐ ├──┤ │
│ │OO│ │OO│ │OO│ │MM│ │OO│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 100<>100 0 │
│ Bass Spe PCM Front Mi Mic Jack S/PDIF S/PDIF D S/PDIF P<S/PDIF 1> Beep │
│ │
│ │
└───────────────────────────────────────────────── ────────────────────────────────────────┘As you can see, my output "S/PDIF 1" is tagged "MM" for mute

* Put the cursor on it and hit "M". You'll see "[Off]" disapearing on the left upper side of the screen
* Sound is now ON !
* ESC to exit

Hope this will help

I mean.. thanks alot for this! And I thank to myself as well trying this out before typing my fingers off in terminal with other proposed solutions ;)
The S/PDIF 1 was "MM" indeed..