PDA

View Full Version : [ubuntu] Restore Default for Terminal



J697
January 8th, 2011, 08:34 PM
I had my terminal and I messed around with the colors, and now it is not transparent anymore :(
I tried a few things around the internet and none of them worked. I just want to restore the default settings for the terminal so it is not so ugly.

Thanks in advance

nothingspecial
January 8th, 2011, 08:41 PM
WARNING - THIS COULD MESS UP THEME/ETC SETTINGS

But, to remove the gnome-terminal settings


rm -r ~/.gconf/apps/gnome-terminal

star123
January 8th, 2011, 08:41 PM
I had my terminal and I messed around with the colors, and now it is not transparent anymore :(
I tried a few things around the internet and none of them worked. I just want to restore the default settings for the terminal so it is not so ugly.

Thanks in advance

well open ur terminal->edit->profile.. set to default but other options include
terminal->edit->profile prefernces.to change ur color to default profile prefernces->colors->use color from system theme
to make it transparent profile prefernces->transparent background
default optoin is also present.. but i wud recmmend customise it..its ur own os make it ur own:P:P:P

J697
January 8th, 2011, 08:46 PM
WARNING - THIS COULD MESS UP THEME/ETC SETTINGS

But, to remove the gnome-terminal settings


rm -r ~/.gconf/apps/gnome-terminal

rm: cannot remove `/home/jarid/.gconf/apps/gnome-terminal': No such file or directory


well open ur terminal->edit->profile.. set to default but other options include
terminal->edit->profile prefernces.to change ur color to default profile prefernces->colors->use color from system theme
to make it transparent profile prefernces->transparent background
default optoin is also present.. but i wud recmmend customise it..its ur own os make it ur own:P:P:P

That was the first thing I tried :)

mikewhatever
January 8th, 2011, 08:47 PM
Try something like this:


mv .gconf/apps/gnome-terminal/profiles .gconf/apps/gnome-terminal/profiles-backup

Then restart gnome-terminal.

J697
January 8th, 2011, 08:49 PM
Try something like this:


mv .gconf/apps/gnome-terminal/profiles .gconf/apps/gnome-terminal/profiles-backupThen restart gnome-terminal.

mv: cannot stat `.gconf/apps/gnome-terminal/profiles': No such file or directory

nothingspecial
January 8th, 2011, 09:03 PM
Are you using Ubuntu?

or something else Xubuntu, Kubuntu, Lubuntu etc?

nothingspecial
January 8th, 2011, 09:06 PM
Or to rephrase the question --

Are you using gnome-terminal?

J697
January 8th, 2011, 09:06 PM
Ubuntu, and yes Gnome Terminal.

mikewhatever
January 8th, 2011, 09:08 PM
What version of Ubuntu do you have? Is it Kubuntu? Lubuntu?

Try looking for gnome-terminal settings:


find - -name *terminal

nothingspecial
January 8th, 2011, 09:10 PM
rm: cannot remove `/home/jarid/.gconf/apps/gnome-terminal': No such file or directory

You should have that directory, weird :-k

J697
January 8th, 2011, 09:10 PM
What version of Ubuntu do you have? Is it Kubuntu? Lubuntu?

10.10
AFAIK it is the one you get wgen you go go to:

www.ubuntu.com

nothingspecial
January 8th, 2011, 09:12 PM
find - -name *terminal

That should be


find ./ -name *terminal

J697
January 8th, 2011, 09:17 PM
That should be


find ./ -name *terminal

When I do that, the only thing that happens is that the cursor breaks to another line and repetabley flashes.

nothingspecial
January 8th, 2011, 09:23 PM
Does your terminal open in your home directory?


ns@ns-net:~$ cd .gconf/apps/gnome-terminal
ns@ns-net:~/.gconf/apps/gnome-terminal$ ls
%gconf.xml profiles
ns@ns-net:~/.gconf/apps/gnome-terminal$

ns@ns-net:~$ find ./ -name *terminal
./.gconf/apps/gnome-terminal

See, all this works for me. You have something different going on.

star123
January 8th, 2011, 09:28 PM
rm: cannot remove `/home/jarid/.gconf/apps/gnome-terminal': No such file or directory



That was the first thing I tried :)

can u pls tell wen u went through the procedure wat result u got i mean didnt u get the option to customize ur terminal or set it to default??

J697
January 8th, 2011, 09:28 PM
Well, I would rather not reinstall Ubuntu. I guess maybe I can live with how it looks :(

nothingspecial
January 8th, 2011, 09:31 PM
Well, I would rather not reinstall Ubuntu. I guess maybe I can live with how it looks :(

yeah, don`t do that just because you don`t like the way the terminal looks.

I`m interested though, as to why you don`t have that directory -- you should.

sigilbaram
February 18th, 2011, 03:44 AM
It seems gnome-terminal does not use ~/.gconf/gnome-terminal, at least any more. I moved the whole thing to ~/.gconf/gnome-terminal.bak and my customisations stayed the same. I was trying to restore Ubuntu's default color pallet because the "Custom" default one was lost when I looked at the other pallets, which I didn't like as much. From TTY1 I did


killall gnome-terminal
sudo dpkg-reconfigure gnome-terminal

which didn't help either. The color pallet isn't that big of an issue but this missing/ignored configuration files thing is kind of interesting.

Edit:
Oh and "find ~/ -name gnome-terminal" found nothing.