PDA

View Full Version : [ubuntu] vimtutor won't run



mucor49
January 6th, 2011, 11:39 AM
Hi, new to the forum, searched previous threads. I have 10.10 and unable to start vimtutor. I have vim. tried 'apt-get install vim-runtime' but when I enter 'vimtutor' as command, vim opens but no tutor. uninstalled>reinstalled vim-runtime, no luck. Tried 'apt-get install vim-full' and receive error message "unable to locate package".

In my GUI, admin>syanptic pkcg mgr, it shows: vim-runtime, vim-common, vim-tiny, -dbg, -gui common, and -gnome, as installed on my system. Please make a suggestion.

A year ago, two previous versions of Ubuntu, when I only had vi, I could run vimtutor. Now I want to 'brush up' on the features with the tutor.
thanks,
mucor49:confused:

gmargo
January 6th, 2011, 05:58 PM
If you have vim-gnome installed, then the tutor should work. If not you could install that or the vim-gtk package. (The problem is that by default only the vim-tiny package is installed, which is a small, limited version.)

mucor49
January 7th, 2011, 12:40 AM
Thank you gmargo! Didn't realize I "lied" when I said I had vim-gnome. Installed it and the vim tutor popped right up.):P
mucor49