PDA

View Full Version : [ubuntu] Acidrip produces incomplete movie file when ripping DVD



titere05
January 6th, 2011, 02:37 AM
Hi! I've searched this forum and the Internet up and down, but I haven't found anyone with this issue. I'm using Ubuntu 10.10 x64 on an AMD X2 6000+, 2 GB RAM, with a Sony DVD-R/RW drive (I provide the specs in case they happen to be relevant).

I'm trying to rip a DVD (Boondock Saints, in case you're curious) to divx/xvid, the only format my crap home DVD can recognize. First I tried dvd::rip encoding with divx to an AVI container, but I got an error. I was lazy enough not to pursue that. I switched dvd::rip to xvid4 (since xvid produces lower quality image) and that actually gave me the entire movie in AVI, but the image was jerky (as if the framerate varied constantly).

So I switched to Acidrip. This program is great and it gives me a perfect-looking xvid AVI, the problem is that no matter what I do, it only rips the first 58 seconds of the title! It's driving me insane. I've tried running it from the console but it doesn't return any kind of error. GUI indicates everything went down smoothly "("Encoding complete"). I've tried selecting the title and selecting all the chapters within it, but the problem's still there. Does anyone know what's going on? What am I missing?

EDIT: I thought maybe it was ripping just the first chapter of the title, but the first chapter is 40 seconds long, while the second chapter is a couple of minutes long. So it's ripping the entire first chapter plus a few seconds of the second one, then stopping with no error message. WTF?

MartyBuntu
January 6th, 2011, 02:57 AM
Could you post a screenshot of Acidrip open with the general tab?

titere05
January 6th, 2011, 03:08 AM
Sure, here's the DVD in Acidrip, everything ready to hit Start

http://img688.imageshack.us/img688/5186/acidrip.png (http://img688.imageshack.us/i/acidrip.png/)