PDA

View Full Version : [SOLVED] Can't check source code in software sources



Vexiphne
December 30th, 2010, 03:28 PM
I tried to install GIMP today and I got the message "Requires installation of untrusted packages". So I checked software sources and for some reason source code was suddenly not marked and when I tried to mark it, it wouldn't let me.

Does anyone know why and how I can fix this?

Wobblybob
January 2nd, 2011, 03:17 PM
you could try installing or re installing the ubuntu-keyring and ubuntu-extras-keyring packages in synaptic.

oldos2er
January 2nd, 2011, 06:31 PM
You can enable the source code repos manually, run
gksu gedit /etc/apt/sources.list and remove the comment mark # from the deb-src repos you want.

The "untrusted packages" warning means you're missing a gpg key for one of your repos. See https://help.ubuntu.com/community/SecureApt

Vexiphne
January 4th, 2011, 07:19 AM
You can enable the source code repos manually, run
gksu gedit /etc/apt/sources.list and remove the comment mark # from the deb-src repos you want.

The "untrusted packages" warning means you're missing a gpg key for one of your repos. See https://help.ubuntu.com/community/SecureApt

Thank you. That helped :)

Add1cken
April 8th, 2011, 04:10 PM
You can enable the source code repos manually, run
gksu gedit /etc/apt/sources.list and remove the comment mark # from the deb-src repos you want.

The "untrusted packages" warning means you're missing a gpg key for one of your repos. See https://help.ubuntu.com/community/SecureApt

thanks mate, did the trick for me to.

AndrewC312
January 24th, 2012, 12:19 AM
Hello, I'm sorry if this is something obvious that I'm missing but I am not very knowledgeable with this sort of thing. I'm having the same problem with being unable to check source code, but I'm not really sure what you did to fix it. I ran that line of code and the "sources.list" file opened. Is there to supposed to be a # mark to the left to the deb-src that I want to enable?

oldos2er
January 24th, 2012, 06:45 PM
Comment mark # in place, repository is disabled. Remove the comment mark to enable the repository.