PDA

View Full Version : 0.24 - mythweb not working - HTTP 500



Lem
December 19th, 2010, 10:46 AM
I'm running mythbuntu with the DE repo for 0.24 and I cannot get mythweb to run on my backend. Have tried uninstalling and re-installing to no avail.
I get the default 'it works' message if I enter the IP of my backend, so I'm reasonably confident that the apache install is ok. libapache2-mod-php5 seems to be installed ok, but I get a 500 error when I try [IP}/mythweb. Enabling password protection brings up the password dialog ok, before once again presenting me with the 500 error.

Any ideas out there? I'd rather not rebuild my backend.

thatguruguy
December 19th, 2010, 08:22 PM
Have you looked at your mythweb and/or backend logs?

ian dobson
December 20th, 2010, 01:04 PM
Hi,

Have a look in your apache log files. A 500 error usually means an interval server error/configuration error.

Regards
Ian Dobson

Lem
December 21st, 2010, 12:32 AM
Well.. my backend died, so I did a rebuild.. and encountered exactly the same issue.
Apache logs gives me;

[Mon Dec 20 23:30:34 2010] [error] [client 192.168.1.64] PHP Warning: file_get_contents(modules_path/_shared/lang/English.lang): failed to open stream: No s$
[Mon Dec 20 23:30:34 2010] [error] [client 192.168.1.64] PHP Fatal error: Failed to open translation file: modules_path/_shared/lang/English.lang in /usr/s$

elgordo123
December 21st, 2010, 01:31 AM
When you say you did a rebuild.. Do you mean you did a complete reformat/re-install of Mythbuntu using the ISO?

Lem
December 21st, 2010, 11:52 AM
When you say you did a rebuild.. Do you mean you did a complete reformat/re-install of Mythbuntu using the ISO?

Yes.. hard drive went AWOL.

Not sure if it's because I'm using the DE repo. I'll try switching it over and see if it helps.

elgordo123
December 21st, 2010, 08:23 PM
Make sure out of the box .23 works before you add on .24. I am using .24 from PPA.
It's happened about 3 times to me when I upgrade from nightly builds, but then I'll wait and upgrade again in the next day or so and then everything works fine.

kja999
March 18th, 2011, 08:50 PM
Hi,

Was there any solution to this as I have the exact same issue ?

On my installation I can still use 0.23 version (with protocol errors of course), but 0.24 just gives a 500 error.

The apache logs show nothing at all.
If there is no known solution, is there a way to make mythweb more verbose ?


Cheers