PDA

View Full Version : [ubuntu] 10.10: Vaio touchpad not detected



DJ Wings
December 8th, 2010, 05:23 AM
Hi,
The one thing on my Vaio that doesn't work out of the box (other than proprietary 3D acceleration, but that's another story (http://ubuntuforums.org/showthread.php?p=10213263)) is the touchpad. It's probably either ALPS or Synaptics (I haven't seen it mentioned anywhere), and works with Sony's drivers on Windows 7. On Ubuntu 10.10, it isn't even detected as a device:


$ dmesg | grep input
[ 2.104681] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
[ 2.116548] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1
[ 2.238070] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input2
[ 2.608456] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:56/LNXVIDEO:02/input/input3
[ 3.724460] input: Logitech USB RECEIVER as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.0/input/input4
[ 3.724659] generic-usb 0003:046D:C50E.0001: input,hidraw0: USB HID v1.11 Mouse [Logitech USB RECEIVER] on usb-0000:00:1d.0-1.5/input0
[ 27.777484] input: Sony Vaio Keys as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:01/SNY5001:00/input/input5
[ 27.777600] input: Sony Vaio Jogdial as /devices/virtual/input/input6
[ 28.250182] input: UVC Camera (05ca:18ba) as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/input/input7

Thoughts on this?

Rajven
December 15th, 2010, 10:36 PM
Same issue here. I have a Sony Vaio PCG-61611M with ubuntu 10.10 and over the fact that the sound time to time doesn't work, the alps touchpad is not even detected:


[ 0.386381] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0
[ 0.386434] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input1
[ 0.386512] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
[ 0.725282] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
[ 2.260347] input: Microsoft Microsoft® Nano Transceiver v2.0 as /devices/pci0000:00/0000:00:12.0/usb4/4-4/4-4:1.0/input/input4
[ 2.260434] generic-usb 0003:045E:0745.0001: input,hidraw0: USB HID v1.11 Keyboard [Microsoft Microsoft® Nano Transceiver v2.0] on usb-0000:00:12.0-4/input0
[ 2.268631] input: Microsoft Microsoft® Nano Transceiver v2.0 as /devices/pci0000:00/0000:00:12.0/usb4/4-4/4-4:1.1/input/input5
[ 2.268730] generic-usb 0003:045E:0745.0002: input,hidraw1: USB HID v1.11 Mouse [Microsoft Microsoft® Nano Transceiver v2.0] on usb-0000:00:12.0-4/input1
[ 2.294410] input: Microsoft Microsoft® Nano Transceiver v2.0 as /devices/pci0000:00/0000:00:12.0/usb4/4-4/4-4:1.2/input/input6
[ 2.294529] generic-usb 0003:045E:0745.0003: input,hiddev96,hidraw2: USB HID v1.11 Device [Microsoft Microsoft® Nano Transceiver v2.0] on usb-0000:00:12.0-4/input2
[ 12.804765] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:00/LNXVIDEO:00/input/input7
[ 12.872984] input: Sony Visual Communication Camer as /devices/pci0000:00/0000:00:13.2/usb2/2-3/2-3:1.0/input/input8
[ 13.002733] input: Sony Vaio Keys as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:2b/SNY5001:00/input/input9
[ 13.002819] input: Sony Vaio Jogdial as /devices/virtual/input/input10


I've already installed synaptic touchpad drivers but nothing. Any suggestion?
Thanks

jimbren
December 16th, 2010, 09:29 AM
I ran into the same issue myself and solved it with the solution provided here:
http://ubuntuforums.org/showthread.php?t=1565548&highlight=vaio+touch+pad