PDA

View Full Version : [ubuntu] 10.04 Netbook : monitor resolution causes crash



AlderStone
December 5th, 2010, 10:31 PM
I'm a relatively new Ubuntu user. I installed 10.04 Netbook edition (replacing moblin remix, which came on it) on my Dell Inspiron Mini-10 to try to wean myself off of Win XP on laptop. I'm reasonably capable of troubleshooting XP, but new enough to Ubuntu that it's still challenging.

[Note: Ubuntu Netbook edition is not listed as an option for thread 'prefix', only Netbook remix. Can anyone tell me which more appropriate prefix I should use? Moderators, please feel free to modify.]

The issue in question - described below - has been happening for 6 months, but I've tried to just ignore it. (An IT friend who uses Ubuntu has been unable to help me solve this, recommended that I come here, but I'm super busy, so just tried to live with it. Finally, I've lost so much work when the screen dies that I've got to deal. (I'm hoping I can get this post finished before it crashes again.)

Here's my problem. Everytime I reboot, it boots into native resolution which is a non-standard resolution of 1024 x 600 (16:9). Usually, within hours, the screen goes blank, I get an error message (that I can't copy; should have written it down) telling me something like, "your screen resolution is too high, so we're shutting you down."

The next screen as it's rebooting gives me several options, including trouble shooting, but clicking on any option other than "reboot at a lower resolution" (paraphrasing: again, it's not precise wording) doesn't get me anywhere.

It reboots in a lower resolution, which is annoying, but workable. (I need to be able to project via an Epson projector for professional reasons at higher native resolution, but can't risk a crash during a professional presentation.)

But here's the rub. I cannot just go into Monitor settings and set at that resolution (to which it usually reboots after a crash) as default. I'm given the option of either 1024x600 or 800x600. The former is not stable, the latter is grossly distorted on this screen.

So, I have 3 questions:

1) Is there a solution to this problem of crashing at native resolution of 1024x600?

2) If not, should I be using a different version of Ubuntu?

3) If not, is there a way that I can change to a lower default resolution that is not distorted?

Thanks for any help.

PS: I request that responses be worded in a way that recognizes I'm an Ubuntu novice, and don't understand how to use command lines yet. (Though am willing to learn with some clear tutoring.)

ajgreeny
December 5th, 2010, 11:24 PM
1024x600 is a standard resolution for 10.1 inch laptop/netbooks, so I am surprised by your question as I thought the Dell Mini was fine with ubuntu netbook edition. By the way, you have posted in the right place, it's just a change of name to the UNR/UNE etc etc.

Regarding your problem, have a look at https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks#Dell%20Mini%2010%20%28Inspiron%201010%29 which may give you some clues.

AlderStone
December 5th, 2010, 11:45 PM
Thanks for your help, AJ. More below.


Regarding your problem, have a look at https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks#Dell%20Mini%2010%20%28Inspiron%201010%29 which may give you some clues.

On that page, I find this. Most relevant part in bold:


Dell Mini 10 (Inspiron 1010)

Works well. Wifi, webcam, sound playing, usb, touchpad work fine. Defaults to VESA graphics, but can be configured for accelerated 2d/3d graphics (https://bugs.launchpad.net/netbook-remix/+bug/417804). While using the default VESA graphics, the menu (netbook-launcher) is extremely slow (https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-openchrome/+bug/358793). Switching to accelerated graphics fixes it, or simply switch to the traditional gnome menus using Preferences... Switch Desktop Mode.

Since I don't know (yet) how to switch to accelerated graphics, I'm trying the "or" part first: switch to traditional gnome menu using Preferences ... Switch Desktop Mode.

That is, I'm currently in "icon mode" (don't know what the official name is), but would really like to be in traditional menu mode, more like Win XP - especially if doing that alone will solve this resolution/crash issue (which that paragraph seems to suggest, but I'm not sure ....)

However, I've searched preferences (in "System") high and low, and find no place to "switch desktop mode". (I know it's in there somewhere - my IT friend showed me once upon a time - but I can't find it now.)

Pointers? Hints?

Thanks.

Alder

AlderStone
December 7th, 2010, 06:47 AM
However, I've searched preferences (in "System") high and low, and find no place to "switch desktop mode". (I know it's in there somewhere - my IT friend showed me once upon a time - but I can't find it now.)

Pointers? Hints?

Bump.

ajgreeny
December 7th, 2010, 09:43 PM
However, I've searched preferences (in "System") high and low, and find no place to "switch desktop mode". (I know it's in there somewhere - my IT friend showed me once upon a time - but I can't find it now.)


Bump.
I think what you refer to is a relic of an older UNR version (Karmic?).

You change the "Desktop Mode" now from UNR to standard gnome at the login screen; after entering username go to the session menu, bottom right and you will see "Ubuntu-desktop" and "Netbook edition" or something like that, the first of which is gnome.

AlderStone
December 8th, 2010, 12:01 AM
AJ,

Bingo!

Right where you said it was.
Thanks very much.

Feels good to have a more familiar desktop with menus.

Now, I'm eager to see if this solves the crash problem.

I'll update this thread about the results.

Alder

AlderStone
December 8th, 2010, 12:11 AM
PS.

Ok, after exploring for a few minutes, I see I'm now using Gnome 2.30.2.

So is THAT Lucid Lynx, or does the latter apply to 10.04?
And I guess I need to change my profile now.
(Sorry, learning slowing here.)

So far, I see no performance differences in terms of display, etc.

Second question: when I rebooted, entered username and went to that session menu, I chose Gnome.

One of the other choices was (I believe) Netbook Edition 2D (as opposed to just Netbook Edition).

Could those choices be related to this video/crash issue?

I'm willing to explore a bit, but if someone knows in advance, could save some time.

Thanks.

a'

ajgreeny
December 8th, 2010, 11:54 AM
I'm not sure about the netbook 2D version. I have 10.04 UNR on my netbook but still prefer the standard gnome desktop so that is what I always use.

Try them all out from the login screen; if they don't work, just go back to gnome again.

Gnome 2.30.2 is the desktop environment that ubuntu 10.04 (Lucid Lynx) uses, but is not Lucid Lynx, just the graphical display environment that LL uses.

Rizwanm
December 8th, 2010, 11:56 AM
Thanks for u help guys i was looking for this forum ...... :)

AlderStone
December 9th, 2010, 04:21 AM
Glad this helped, Rizwanm. I'm new here, too.


Gnome 2.30.2 is the desktop environment that ubuntu 10.04 (Lucid Lynx) uses,
but is not Lucid Lynx, just the graphical display environment that LL uses.OK, I think I understand that.

So far so good since switching to Gnome. No crash today.

We'll see how long it lasts.

AlderStone
December 11th, 2010, 01:42 AM
Well, I made it three days without a crash.

But it crashed again about an hour ago.

So, it appears that changing to the Gnone desktop is not enough. Something more is required.

I'm hoping that some of you can help me understand what that is and how to do it.

This time, I made some notes (using my Droid).

The screen simply goes black, the following error appears in a few seconds.


Ubuntu is running in low-graphics mode. Your screen, graphics card and input device settings could not be detected correctly. You will need to configure these yourself. (ok)Clicking "ok" takes me to the next screen:


What would you like to do?


- run ubuntu i low-graphics mode for just one session
- reconfigure graphics
- troubleshoot the error
- exit to console login
- Restart X

Clicking "troubleshoot the error" gets me 4 options:


- review the xserver log file
- review the startup errors
-edit configuration files
-archive configuration and logs

Clicking "reconfigure graphics" on 1st menu gets 3 options:


-use default (generic) config (this one and the next go nowhere when clicked; back to same menu)
-create new configuration for this hardware
- use your backed up configuration

Clicking "Restart X" just locks it up for many minutes - no change - w/ flashing cursor. A hard reboot is required to get out of it. Hard reboot leads back to the same "hi resolution" mode that crashes it everytime: 1024 x 900.

Thus, another crash is immanent.

(Tick, tick, tick, tick ...)

______________


Can any one help me resolve this?

Thanks very much in advance.

AlderStone
December 11th, 2010, 07:45 PM
Thus, another crash is immanent. I posted that around 9:30 pm last night.

I continued using the netbook for about another half hour, then logged off for the night.

I booted up about half hour ago and it crashed shortly thereafter.

I'm running in 'low graphics mode' right now.