PDA

View Full Version : [SOLVED] APT Authentifcation Issue



ericstrom
November 30th, 2010, 02:37 AM
Getting the following messages when the update manager runs. Any suggestions how to fix it ? I am running Lucid with DropBox.

Apt Authentication issue

Problem during package list update. The package list update failed with a authentication failure. This usually happens behind a network proxy server. Please try to click on the "Run this action now" button to correct the problem or update the list manually by running Update Manager and clicking on "Check".

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://linux.dropbox.com lucid Release: The following signatures were invalid: NODATA 1 NODATA 2

W: Failed to fetch http://linux.dropbox.com/ubuntu/dists/lucid/Release

W: Some index files failed to download, they have been ignored, or old ones used instead.

olalonde
November 30th, 2010, 11:23 AM
Got the same problem. I also asked advice over at http://askubuntu.com/questions/15484/error-caused-by-dropbox-in-update-manager

tajiknomi
November 30th, 2010, 11:51 AM
Try this..> Go to >System>admin>software-sources >Repositories >& Un-check http://linux.dropbox.com/ubuntu/dists/lucid/Release

then type "sudo apt-get update"

ericstrom
December 1st, 2010, 02:47 AM
tajiknomi recommended that I uncheck the following in my repository list:

http://linux.dropbox.com/ubuntu/dists/lucid/Release

However, when I look at the repository list per the instructions, I do not see the above line. In other words, it is not available to uncheck. The only line I see in the repository list that refers to dropbox is as follows:

http://linux.dropbox.com/ubuntu/lucid main

So it appears something is out of synchronization. What do you recommend ?

oldos2er
December 1st, 2010, 04:31 AM
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://linux.dropbox.com lucid Release: The following signatures were invalid: NODATA 1 NODATA

It looks like linux.dropbox.com is down; but you can get the gpg key with
sudo apt-key adv --keyserver pgp.mit.edu --recv-keys 5044912E

tajiknomi
December 1st, 2010, 07:39 AM
It looks like linux.dropbox.com is down; but you can get the gpg key with
sudo apt-key adv --keyserver pgp.mit.edu --recv-keys 5044912E


Can you explain a little bit , i means the code which you had posted i-e "5044912E"...?

oldos2er
December 1st, 2010, 07:32 PM
That is Dropbox's key. I copied it from https://www.dropbox.com/downloading

jmagsho
December 2nd, 2010, 02:49 PM
That is Dropbox's key. I copied it from https://www.dropbox.com/downloading

Ann, just want to say thanks for the solution. Much appreciated.

oldos2er
December 2nd, 2010, 04:47 PM
You're welcome.

Shellbak3
December 16th, 2010, 10:09 PM
10.10 64 bit
I followed the instructions above, JIC, but I'm still getting the error below.


W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://archive.canonical.com lucid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 40976EAF437D05B5

W: GPG error: http://security.ubuntu.com lucid-security Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 40976EAF437D05B5
W: GPG error: http://us.archive.ubuntu.com lucid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 40976EAF437D05B5
W: GPG error: http://us.archive.ubuntu.com lucid-updates Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 40976EAF437D05B5
W: Failed to fetch http://archive.canonical.com/ubuntu/dists/lucid/Release

W: Some index files failed to download, they have been ignored, or old ones used instead.