View Full Version : [all variants] nslookup error on ubuntu client cant find dns server

November 28th, 2010, 07:01 AM
Need help with nslookup mydomain.com

ok will try my best to give everything needed:

heres my db.mydomain.com file from my nameserver:

$mydomain.com. IN SOA ns1.$mydomain.com. support.$mydomain.com. (
1 ; Serial
24h ; Refresh
1h ; Retry
2w ; Expire
1h ) ; Negative Cache TTL
; NS Records
$mydomain.com. IN NS ns1.$mydomain.com.

; Host Addresses
localhost IN A
ns1.$mydomain.com. IN A $ipaddress

; Web Site Addresses
$mydomain. IN A $ipaddress
; Canonical Names
; ----- nexwrxdemo.com sites -----
www CNAME $mydomain.com.
support CNAME $mydomain.com.
;store CNAME $mydomain.com.

here is my outputted from my named.conf.default-zones file:

// prime the server with knowledge of the root servers
zone "." {
type hint;
file "/etc/bind/db.root";

// be authoritative for the localhost forward and reverse zones, and for
// broadcast zones as per RFC 1912
zone "mydomain.com" {
type master;
file "/etc/bind/db.mydomain.com";

zone "localhost" {
type master;
file "/etc/bind/db.local";

zone "127.in-addr.arpa" {
type master;
file "/etc/bind/db.127";

zone "0.in-addr.arpa" {
type master;
file "/etc/bind/db.0";

zone "255.in-addr.arpa" {
type master;
file "/etc/bind/db.255";

here is my output from running dig mydomain:

user@mydomain:/etc/bind$ dig mydomain.com

; <<>> DiG 9.7.0-P1 <<>> mydomain.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 63531
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

; mydomain.com. IN A

com. 222 IN SOA a.gtld-servers.net. nstld.verisign-grs.com. 1290922538 1800 900 604800 86400

;; Query time: 20 msec
;; WHEN: Sun Nov 28 00:47:30 2010
;; MSG SIZE rcvd: 105

here is the output after running nslookup mydomain

user@mydomain:/etc/bind$ nslookup mydomain.com

** server can't find mydomain.com: NXDOMAIN

also here is the /etc/resolv.conf file on the ubuntu client that I have made unwritable for further edits:

# Generated by NetworkManager
search mydomain.com
nameserver $nsIPAddress

any help would be great I really need Ubuntu to beable to access my dns server.

I can use nslookup on mac and it works great but my ubuntu cant hit it up?
Please help,
Thanks in advance,

November 28th, 2010, 05:18 PM
well gave it a $TTL statement now I don't have anything in syslog, but still no good on the nslookup.

Just fixed it it has to be the only name server in /etc/resolv.conf