PDA

View Full Version : [ubuntu] Asus G73 blinks once in a while (Nvidia GTX 460M)



Mobidoy
November 27th, 2010, 03:52 AM
I got a new laptop Asus G73JW which has a Nvidia GTX 460M. I have installed the latest Nvidia driver to see if it would prevent it fron blinking only once, once in a while but, no luck, I have also tried to disable Desktop effects but still no luck.

Anyone has an idea of what should I look at or try ?

Mobidoy
November 27th, 2010, 05:08 PM
it is getting on my verves lol, anyone has an idea ?

Mobidoy
November 28th, 2010, 03:43 AM
Anything ?

delca85
November 28th, 2010, 11:12 PM
I have the same notebook and the same problem.
Nobody can help us?

Mobidoy
November 29th, 2010, 05:29 PM
Lets give it some visibility AKA shameless bump

0_irishboy_0
December 15th, 2010, 02:39 AM
I just purchased the same laptop. Disabling PowerMizer Monitor corrected the issue for me.

System - Administration - NVIDIA X Server Settings

Then on the left hand menu, click nvidia-settings Configuration and uncheck "PowerMizer Monitor".

delca85
December 15th, 2010, 09:20 AM
I have tried your way but my screen keep on flickering!

Mobidoy
December 15th, 2010, 06:56 PM
Tried it too, issue still present...

easy to see, after you change it, scroll a webpage pretty fast and it will blink, just stay put for about 10 second and you will see it again.

Edit: But still, it is one heck of a Laptop :)

annemendez
December 15th, 2010, 07:06 PM
it's still under warranty i guess. you can have it checked by someone who's authorized. ;) they might be able to help you.

Mobidoy
December 15th, 2010, 07:39 PM
it's still under warranty i guess. you can have it checked by someone who's authorized. ;) they might be able to help you.

Naaah no need to get it check, the problem is with the Nvidia driver. It works without a glitch under Win 7 or under Ubuntu with other drivers other than proprietary...

lrgmmc
December 22nd, 2010, 07:30 PM
When you say the latest driver are you talking about the one from ubuntu repo's or the nvidia site?

delca85
December 23rd, 2010, 11:03 AM
@Mobidoy are you able to make 3d effects working without nvidia proprietary drivers?

Mobidoy
December 23rd, 2010, 05:33 PM
I am talking about the proprietary drivers, Nvidia, 260.19.29

I have not tried using the repo drivers so I cannot tell you if 3d effets works with them. SOrry

delca85
December 23rd, 2010, 05:37 PM
Naaah no need to get it check, the problem is with the Nvidia driver. It works without a glitch under Win 7 or under Ubuntu with other drivers other than proprietary...

I was referring about this. You have told that your pc works without a glitch under Ubuntu with no proprietary drivers. But are you able to make 3d effects working with these no proprietary drivers?

I hope I have understood well.

Mobidoy
December 23rd, 2010, 06:15 PM
I was referring about this. You have told that your pc works without a glitch under Ubuntu with no proprietary drivers. But are you able to make 3d effects working with these no proprietary drivers?

I hope I have understood well.


When I installed Ubuntu, I did not intall the proprietary drivers for a while and, never noticed the flickering. But I have not try to run the 3d settings. I only did it after I installed the drivers from Nvidia.

So yeah, I had no problems with the repo drivers (not that I noticed) but, no I have not gave 3d settings a try while I was on those drivers... :)

delca85
December 24th, 2010, 08:25 AM
Ok, I have understood and I have been in the dame situation.
Thanks for the reply!

Mobidoy
December 24th, 2010, 07:22 PM
Ok, I have understood and I have been in the dame situation.
Thanks for the reply!

I may be in error but I think that this issue can only be solved by Nvidia.

delca85
December 24th, 2010, 07:50 PM
Unfotunately, I think you are right.

efflandt
December 25th, 2010, 11:38 AM
I am talking about the proprietary drivers, Nvidia, 260.19.29

I have not tried using the repo drivers so I cannot tell you if 3d effets works with them. SOrry

Actually nvidia 260.19.29 drivers are in the repos for Lucid or Maverick if you add x-swat to your repositories. So you are apparently using 260.19.29 from nvidia.com website instead of from the repos. I don't know if video works any better for that card with same drivers from the repos, but kernel updates would certainly go smoother with repo drivers, because they would automatically include the necessary modules for the nvidia version.

http://www.ubuntuupdates.org/ppas/27

Or if default nouveau drivers work OK, you might want to try libgl1-mesa-dri-experimental to see if that allows you to do desktop effects (although, it is likely to be much slower than nvidia drivers).

airjaguar
December 27th, 2010, 09:59 AM
Hey guys! I just bought G73JW last week, and I had the same problem, but I found some method seems working for me. At least I haven't had that problem since I did it.

Its similar to what "0_irishboy_0" mentioned. but instead of go to graphical setting.

I edited /etc/X11/xorg.conf directly

just put

Option "RegistryDwords" "PowerMizerEnable=01; PerfLevelSrc=03322; PowerMizerDefaultAC=01"


between "Section Device" and "EndSection"

save it, then problem solved!
hope its helpful!!

regards,
Hao

delca85
December 29th, 2010, 10:29 AM
@airjaguar Yours is just one way to set gpu always at maximum performance. Indeed the gpu temperature go up immediately.
The flickering problem is solved, but I don't know it is very good for notebook health.