PDA

View Full Version : [ubuntu] Network connections in ubuntu



hrishi.nitk
November 24th, 2010, 11:02 PM
When I open my ubuntu Network connections, in the wired tab the list is as follows:
Auto Ethernet
Auto Ethernet
Auto eth0
Auto eth0

Is there anything abnormal in this? I am unable to get a wired connection.

grahammechanical
November 25th, 2010, 12:37 AM
My connections are Auto eth0 and Auto eth1. You can add connections. In which case you give it any name you wish. It is just a label. Have you done this in the past? You do not have 4 ethernet ports. Or do you?

Regards.

pricetech
November 25th, 2010, 12:37 AM
Yes it's unusual in that you should only have one entry, that being for ETH0. If you have more than one NIC, the second one should be ETH1.

hrishi.nitk
November 26th, 2010, 06:12 PM
I have only one ethernet port. Can anyone tell me the possible reasons for this kind of list?

Aerospaztic
December 21st, 2010, 07:52 AM
Right click on your NetworkManager Applet icon on the top right of the screen (has up and down arrows). If you go to edit connections, you can remove/add connections. It will immediately tell you the last time you used a connection. If you see "never" in the "last used" column, then obviously you don't need that connection and it is safe to remove.

You might want to delete them all and create another connection. If you end up getting stuck for some reason, you can select "edit" and enter your hardware MAC address in the "Wired" tab. This can be found by a simple "ifconfig" command in the terminal. Then go to "IPV-4 Settings" and apply "Automatic DHCP." That should get the connection working.

Note: You might want a wireless AND a wired connection. Also, you can have a network connection (with network switch), and a separate wired connection. Just depends on your configuration.