PDA

View Full Version : ASUS-1015PED MBR Destroyed



DeanG
November 23rd, 2010, 11:22 PM
Bought a new Asus Eee PC 1015PED.
http://www.amazon.com/ASUS-1015PED-PU17-BK-10-1-Inch-Netbook-Black/dp/B003UNOVCC
After firing it up and discovering the limitations of Win 7 starter (Basically a marketing tool to sell you Win 7 Home)I said to myself OK I've been bad mouthing Windows since win 95 - It's time for Linux. How bad can it be for an old fart who used to work with RSX-11m+.

Things went well at first: Put a couple of Distros on Thumb drives and started evaluating with Live CD. Tried Mint 10 the dropped back to Mint 9 since 10 seemed squirley. Tried Unbuntu Remix 10.10 - really strange (too much windows experience). Got wireless working on both distros - a pain but I managed.

Time to bite the bullet! Picked Mint 9 and installed. Had to do the wireless thing but that was OK.

The Problem:

Mint install only allocated a little more than 3 GIGs even though this netbook has a 250 Gig drive. Lot of stuff wouldn't fit so I began to try to figure out how to edit partition to make Linux bigger. I' not sure what I did but the next thing I know I boot into GRUB RESCUE> I think I hit tab at boot prompt then return after whatever garbage it put out for me.

I don't know GRUB from GRUB2 but the best directions I could find for recovery were in Ubuntu forums so I went back to Ubuntu Remix. Unfortunately they seem to be tailored for earlier version. No Places in V10 for example caused a lot of pain.

I can still boot to USB device but that's it. Apparently I have destroyed Grub 2 as well because now my boots end with GRUB>

I really need to get windows back - my wife is not ready for Linux and frankly at this point I'm having second thoughts. I'm still within the return period at Amazon but I don't know if they will take it back after what I've done to it.

This gadget is supposed to reload Win7 by pressing F9 three times during boot but obviously I'm well beyond that. It also has a small Vista partition - go figure