PDA

View Full Version : [ubuntu] Alsa problems with Dell (no Sound output at headphone jack)



Tand
November 4th, 2010, 11:02 AM
Hello,
I bought a new laptop (dell Precision M4500) and installed Ubuntu on it. But as mentioned above I can't get the sound to work properly.
In the german Wiki (http://wiki.ubuntuusers.de/Soundkarten_konfigurieren/HDA?redirect=no) it says to look up my codec in ALSA-Configuration.txt or HD-Audio-Models.txt but I can't find it there.
I have tried different entries (snd-hda-intel model=xxx) for various dell laptops in the alsa-base.conf but none of them seem to work.

cat /proc/asound/cards


0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xe9660000 irq 48
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xe3080000 irq 16

head -n 1 /proc/asound/card0/codec*



Codec: IDT 92HD81B1C5It would be really nice if somebody could help me with this because I don't know what else to try and I can't use Ubuntu like this.

Tand
November 5th, 2010, 12:15 PM
/sbin/alsa reload responds with


/sbin/alsa: Warning: Processes using sound devices: 1808(pulseaudio).
mkdir: kann Verzeichnis „/var/run/alsa“ nicht anlegen: Permission denied
/sbin/alsa: Warning: Failed to create /var/run/alsa/.
/sbin/alsa: Warning: Not keeping list of removed modules because /var/run/alsa is absent.
It will not be possible automatically to reload these modules.
Unloading ALSA sound driver modules:/sbin/alsa: 219: cannot create /var/run/alsa/modules-removed: Directory nonexistent
snd-hda-codec-nvhdmi snd-hda-codec-idt snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.
mkdir: kann Verzeichnis „/var/run/alsa“ nicht anlegen: Permission denied
Loading ALSA sound driver modules: (none to reload).