PDA

View Full Version : [ubuntu] 10.10 RNX-N250PC ralink chip rt3062 driver install need help



dasjr7
November 3rd, 2010, 05:02 AM
Hello,
I'm trying to get a Rosewill RNX-N250PC wireless card w/ ralink rt3062 chip to work in a new build. I am able to see the card in Device Manager, but can't get the driver to work despite trying many of the suggestions I've read elsewhere. I installed build-essentials and downloaded the driver from ralink. I unzipped the folder, and started to follow README as well as this thread rt3062http://ubuntuforums.org/showthread.php?t=1608095&highlight=3062. So, I've adjusted MODE and TARGET as instructed in Makefile. I also adjusted the following sections of red text from Makefile:

ifeq ($(PLATFORM),PC)
# Linux 2.6
LINUX_SRC = /lib/modules/$(2.6.35-22-generic)/build
# Linux 2.4 Change to your local setting
#LINUX_SRC = /usr/src/linux-2.4
LINUX_SRC_MODULE = /lib/modules/$(2.6.35-22-generic)/kernel/drivers/net/wireless/
CROSS_COMPILE =
endif

Then I set HAS_WPA_SUPPLICANT=y and HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y in /os/linux/config.mk in the driver folder.

Then I code: $ make (also tried sudo make with same result)
and get:

make -C tools
make[1]: Entering directory `/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/tools'
/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/tools/bin2h
cp -f os/linux/Makefile.6 /home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/os/linux/Makefile
make -C /lib/modules//build SUBDIRS=/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/os/linux modules
make: *** /lib/modules//build: No such file or directory. Stop.
make: *** [LINUX] Error 2
das@desktop:~/2010_07_16_RT3062_Linux_STA_v2.4.0.0$

I'm trying linux for the first time, so thanks for your patience. Any help is much appreciated.

MooPi
November 3rd, 2010, 08:11 AM
I think you've added a step that might not be needed. Can you give me
uname-r
It looks as if the make process stops when it gets to /lib/modules and you may have the wrong /lib/modules . I omitted this step while you have entered a specific module.
Can you also give me
lspci -v
Please just the Ralink Device info

dasjr7
November 3rd, 2010, 05:31 PM
Thanks for responding.

$ uname -r
2.6.35-22-generic

$ lspci -v
03:06.0 Network controller: RaLink Device 3062
Subsystem: RaLink Device 3062
Flags: bus master, slow devsel, latency 32, IRQ 20
Memory at fdce0000 (32-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: rt2800pci
Kernel modules: rt3562sta, rt2800pci

i can see why you only asked for the Ralink info.

MooPi
November 3rd, 2010, 07:33 PM
Lets blacklist and see if that gets the ball rolling

gksu /etc/modprobe.d/blacklist.conf
Add to the end of that file

#Ralink rt2800
blacklist rt2800pci
After this you may need to reboot
It seems as if the module is already part of the kernel and installation may not be necessary. After reboot remember if your ethernet cable is connected it will over ride a WiFi adapter, so disconnect to enable your wireless.

dasjr7
November 3rd, 2010, 07:48 PM
I tried the first step and this happened:

das@desktop:~$ gksu /etc/modprobe.d/blacklist.conf
das@desktop:~$

I then tried looking for modprobe.d in file system/etc/ but couldn't find it.

MooPi
November 3rd, 2010, 08:01 PM
I'm sorry I left out something important

gksu gedit /ect/modprobe.d/blacklist.conf

dasjr7
November 3rd, 2010, 10:22 PM
After blacklisting, unplugging my ethernet cable, and rebooting, I no longer have a "wireless network" category under my network icon in the upper right of my desktop menu bar. I opened a terminal and tried "make" again; same problem:

das@desktop:~$ cd 2010_07_16_RT3062_Linux_STA_v2.4.0.0/
das@desktop:~/2010_07_16_RT3062_Linux_STA_v2.4.0.0$ make
make -C tools
make[1]: Entering directory `/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/tools'
/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/tools/bin2h
cp -f os/linux/Makefile.6 /home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/os/linux/Makefile
make -C /lib/modules//build SUBDIRS=/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/os/linux modules
make: *** /lib/modules//build: No such file or directory. Stop.
make: *** [LINUX] Error 2
das@desktop:~/2010_07_16_RT3062_Linux_STA_v2.4.0.0$

Earlier you said "It looks as if the make process stops when it gets to /lib/modules and you may have the wrong /lib/modules . I omitted this step while you have entered a specific module." Should I try removing that specific module? And how do I do that? I don't think that fixes the "/lib/modules//build: No such file" problem though.

MooPi
November 3rd, 2010, 11:28 PM
Here is what my makefile looks like

ifeq ($(PLATFORM),PC)
# Linux 2.6
LINUX_SRC = /lib/modules/$(shell uname -r)/build
# Linux 2.4 Change to your local setting
#LINUX_SRC = /usr/src/linux-2.4
LINUX_SRC_MODULE = /lib/modules/$(shell uname -r)/kernel/drivers/net/wireless/
CROSS_COMPILE =
endif
As I did not specify the kernel requirement and the make process went off without a hitch.

chili555
November 4th, 2010, 01:17 AM
This change:
I also adjusted the following sections of red text from Makefile:

ifeq ($(PLATFORM),PC)
# Linux 2.6
LINUX_SRC = /lib/modules/$(2.6.35-22-generic)/build
# Linux 2.4 Change to your local setting
#LINUX_SRC = /usr/src/linux-2.4
LINUX_SRC_MODULE = /lib/modules/$(2.6.35-22-generic)/kernel/drivers/net/wireless/
CROSS_COMPILE =
endif...makes this error:
make: *** /lib/modules//build: No such file or directory. Stop.As MooPi says, you will probably have a perfect build if you revert to the unadjusted Makefile.

I assume you have build-essential and linux-headers installed.

dasjr7
November 4th, 2010, 02:59 AM
That appears to work to fix the [make] problem. I had to use sudo bash but [make install] appeared to return no errors either:

root@desktop:~/2010_07_16_RT3062_Linux_STA_v2.4.0.0# make install
make -C /home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/os/linux -f Makefile.6 install
mkdir: cannot create directory `/etc/Wireless': File exists
make[1]: Entering directory `/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/os/linux'
rm -rf /etc/Wireless/RT2860STA
mkdir /etc/Wireless/RT2860STA
cp /home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/RT2860STA.dat /etc/Wireless/RT2860STA/.
install -d /lib/modules/2.6.35-22-generic/kernel/drivers/net/wireless/
install -m 644 -c rt3562sta.ko /lib/modules/2.6.35-22-generic/kernel/drivers/net/wireless/
/sbin/depmod -a 2.6.35-22-generic
make[1]: Leaving directory `/home/das/2010_07_16_RT3062_Linux_STA_v2.4.0.0/os/linux'

sudo modprobe on the other hand...

root@desktop:~/2010_07_16_RT3062_Linux_STA_v2.4.0.0# sudo modprobe rt3562sta.ko
FATAL: Module rt3562sta.ko not found.
root@desktop:~/2010_07_16_RT3062_Linux_STA_v2.4.0.0# exit

I tried this from # and $ with same result. I navigated to /2010_07_16_RT3062_Linux_STA_v2.4.0.0/os/linux/rt3562sta.ko, so i don't know why modprobe can't find it. I'm sure my naiveté is shining through right now. :)

chili555
November 4th, 2010, 03:11 AM
Please try:
sudo modprobe rt3562staIf it clicks back to the command prompt, it worked.

The format for modprobe is without the file extension, in this case .ko.

dasjr7
November 4th, 2010, 03:24 AM
Different error, but error:

das@desktop:~/2010_07_16_RT3062_Linux_STA_v2.4.0.0$ sudo modprobe rt3562sta
FATAL: Error inserting rt3562sta (/lib/modules/2.6.35-22-generic/kernel/drivers/net/wireless/rt3562sta.ko): Device or resource busy
das@desktop:~/2010_07_16_RT3062_Linux_STA_v2.4.0.0$

chili555
November 4th, 2010, 03:27 AM
One wonders why the resource is busy. Could it be that another driver is running the device?
lsmod | grep -e rt2 -e rt3

dasjr7
November 4th, 2010, 03:33 AM
One does wonder.

das@desktop:~/2010_07_16_RT3062_Linux_STA_v2.4.0.0$ lsmod | grep -e rt2 -e rt3
rt2860sta 559618 0
crc_ccitt 1699 1 rt2860sta

chili555
November 4th, 2010, 03:37 AM
Was rt2860sta not driving your device correctly? Shouldn't we fix the native driver before we re-invent the wheel (aka Makefile)?

dasjr7
November 4th, 2010, 03:56 AM
I'm open to doing whatever to get this thing to work so i don't have to deal w/RMA. We can stick with 3562 or go with 2860. What ever is more efficient at this point. Prior to this thread, one of the two green lights on the adapter were working, but I was unable to enable wireless networking. To try and fix rt2860, do I...

- in Makefile change CHIPSET = 3562 to CHIPSET = 2860?
- take rt2800sta off blacklist?
- somehow [make], [make install], [sudo modprobe rt2860sta] for rt2860? Or is it already running?

Thanks for your time, by the way.

chili555
November 4th, 2010, 12:44 PM
No need to change the Makefile at all. The module rt2860sta is built-in and has attached the device. The question is, why isn't it working. So that we have a clean slate, detach the ethernet cable, if any, reboot and then run:
dmesg > dasjr7.txt
iwconfig >> dasjr7.txt
cat /etc/Wireless/RT2860STA/RT2860STA.dat >> dasjr7.txt
zip dasjr7.zip dasjr7.txtYou will find a file called dasjr7.zip in your home directory. Attach it to your reply.

I will examine the results and we'll get the native driver going.

dasjr7
November 4th, 2010, 03:47 PM
das@desktop:~$ dmesg > dasjr7.txt
das@desktop:~$ iwconfig >> dasjr7.txt
lo no wireless extensions.

eth0 no wireless extensions.

das@desktop:~$ cat /etc/Wireless/RT2860STA/RT2860STA.dat >> dasjr7.txt
das@desktop:~$ zip dasjr7.zip dasjr7.txt
adding: dasjr7.txt (deflated 73%)

chili555
November 4th, 2010, 04:01 PM
Well, there are a few problems:

[ 8.687713] Registered led device: rt2800pci-phy0::radio
[ 8.687723] Registered led device: rt2800pci-phy0::assoc
[ 8.687733] Registered led device: rt2800pci-phy0::quality
[ 8.874791] rt2860sta: module is from the staging directory, the quality is unknown, you have been warned.
[ 9.060480] Error: Driver 'rt2860' is already registered, aborting...Let's try a few things. First, do:
sudo gedit /etc/modprobe.d/blacklist.confAdd four separate lines at the end:
blacklist rt2800pci
blacklist rt2x00lib
blacklist rt2x00pci
blacklist rt2800libProofread carefully, save and close gedit. Reboot. Is your wireless working?

If not, repeat the test above, but now with dasjr8.

dasjr7
November 4th, 2010, 04:24 PM
Now there is no wireless option under my desktop menu bar network connections icon.

chili555
November 4th, 2010, 04:48 PM
[ 8.742825] rt2860sta: module is from the staging directory, the quality is unknown, you have been warned.
[ 8.812837] Error: Driver 'rt2860' is already registered, aborting...I wonder why it's loading and then unloading!

May I see:
lsmod | grep -e ndis -e rt2
lspci -nnPlease strip away the lines that are not your Rosewill.

I love a mystery! Thanks.

chili555
November 4th, 2010, 05:07 PM
May I also see:
cat /etc/modulesThanks.

dasjr7
November 4th, 2010, 08:21 PM
I tried several "fixes" prior to coming to ubuntuforums. Maybe I caused more issues. As unpleasant as it is not to have a device "plug and play", I am learning quite a bit. Per your request:

das@desktop:~$ lspci -nn
03:06.0 Network controller [0280]: RaLink Device [1814:3062]

I hope all you needed is that line. That's the only line that mentions the Rosewill/Ralink device. Also:

das@desktop:~$ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
rtc
rt2860sta

chili555
November 4th, 2010, 09:35 PM
It turns out that rt2800pci is the correct driver and not rt2860sta. Here is what modinfo has to say:
modinfo rt2800pci | grep 3062
alias: pci:v00001814d00003062sv*sd*bc*sc*i*Please remove the blacklists we added earlier. Also, let's remove rt2860sta from /etc/modules.

When rt2800pci was loaded, your iwconfig looked pretty normal, but not connected:
wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=8 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:offI wonder why it didn't work.

After you make these changes, please do:
sudo modprobe rt2800pciNow click the Network Manager icon. Do you see your network? Can you click it and try to connect?

dasjr7
November 4th, 2010, 09:59 PM
One of the two lights on my adapter came back on. Network manager icon menu looks like this

Wired Network
Auto eth0
Disconnect
Wireless Networks
disconnected
VPN connections
Connect to hidden wireless networks
Create new wireless network

chili555
November 4th, 2010, 10:13 PM
Please let me see:
sudo iwconfig wlan0 power on
iwconfig wlan0
sudo iwlist wlan0 scanDid any of the suspicious fixes ask you to amend /etc/network/interfaces?
cat /etc/network/interfacesThe specific errors, if any, from these commands may tell us about what's going wrong.

dasjr7
November 4th, 2010, 10:21 PM
das@desktop:~$ sudo iwconfig wlan0 power on
[sudo] password for das:
das@desktop:~$ iwconfig wlan0
wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=8 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on

das@desktop:~$ sudo iwlist wlan0 scan
wlan0 No scan results

Access Point: Not-Associated? That doesn't sound good. I don't remember /etc/network/interfaces, but here's what i get:

das@desktop:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

How do you get the code to show up in a text box in your message?

dasjr7
November 4th, 2010, 11:37 PM
Is it time for a new thread dealing with enabling wireless network? If so, what commands will you/others need to see? I've seen similar threads for Dell, HP, and Compaq, but I self built. Does that make a difference?

chili555
November 5th, 2010, 05:01 PM
Frankly, dasjr7, I am stumped. There are very few native, built-in to the kernel drivers that I can't coax into life. I hate to admit that yesterday was not my day.

Before I give up entirely, please let's try the driver you compiled again.

Please add the blacklists here: http://ubuntuforums.org/showpost.php?p=10071183&postcount=19

Also do:
sudo su
echo rt3562sta >> /etc/modules
exitNow reboot and tell me what the result is:
dmesg > dasjr9.txt
iwconfig >> dasjr9.txt
sudo iwlist ra0 scan >> dasjr9.txt
zip dasjr9.zip dasjr9.txtOf course, if it's working perfectly, you can just tell me that and maybe a "Woo Hoo!"

dasjr7
November 5th, 2010, 07:34 PM
Woo Hoo! It appears to be working perfectly! So, all good for now. You'll see me back in the forums eventually I'm sure. Thanks for all your help. Next time I'm in SC, I owe you an adult beverage, coffee, etc.
:guitar:

chili555
November 5th, 2010, 07:59 PM
Woo Hoo indeed! I am very glad it's working. It would be my pleasure to raise a beverage with you any time and thank you for your patience.

machr666
November 14th, 2010, 02:22 PM
The manual works like a treat, got my ADDON wireless card to work without any problems! Thx :)!

mrfr0g
December 14th, 2010, 06:24 AM
Just wanted to say thanks as well. Using this post, I was able to get my wireless card working.

nikonicanicanon
February 10th, 2011, 10:13 PM
i stop in this step, and i don't know what i do next... on my screen show this:

lsmod | grep -e rt2 -e rt3
rt2800pci 8565 0
rt2800lib 28897 1 rt2800pci
rt2x00usb 9779 1 rt2800lib
rt2x00pci 6029 1 rt2800pci
crc_ccitt 1351 1 rt2800pci
rt2x00lib 27275 4 rt2800pci,rt2800lib,rt2x00usb,rt2x00pci
mac80211 231959 3 rt2x00usb,rt2x00pci,rt2x00lib
cfg80211 144694 2 rt2x00lib,mac80211
eeprom_93cx6 1345 1 rt2800pci
led_class 2633 1 rt2x00libplease help me. I'm new user, and i don't have idea. this is really new, i use windows all my life, but no more:confused:

chili555
February 10th, 2011, 10:33 PM
03:06.0 Network controller [0280]: RaLink Device [1814:3062]Is yours the same device? Please run:
lspci -nnDoes the current rt2800pci driver not work for you? Do you see networks when you click the Network Manager icon? Does it try to connect?

nikonicanicanon
February 11th, 2011, 04:46 AM
03:02.0 Network controller [0280]: RaLink Device [1814:3062]

nikonicanicanon
February 11th, 2011, 04:54 AM
no, i don't see anything, i just keep on line only for the Ethernet, the wireless simply don't run

chili555
February 11th, 2011, 01:32 PM
Let's have a look at:
dmesg | grep -e rt2 -e wlan
sudo iwlist wlan0 scanThanks.

nikonicanicanon
February 11th, 2011, 05:53 PM
[ 12.439380] rt2800pci 0000:03:02.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 12.507057] Registered led device: rt2800pci-phy0::radio
[ 12.507071] Registered led device: rt2800pci-phy0::assoc
[ 12.507084] Registered led device: rt2800pci-phy0::quality
[ 12.971331] ADDRCONF(NETDEV_UP): wlan0: link is not ready

sudo iwlist wlan0 scan
[sudo] password for cliente:
wlan0 No scan results
I really appreciate your help on this topic has already portrays one crazy day I

chili555
February 11th, 2011, 06:31 PM
Before we take more drastic measures, can you confirm that these tests were run with the ethernet cable disconnected? Network Manager is designed to not allow a wireless connection if wired ethernet is available.

nikonicanicanon
February 12th, 2011, 12:54 AM
im sorry, but i have so work this weekend.
so, the message is the same with or without Ethernet

thanks for the patience and the time you are investing in helping!!

chili555
February 12th, 2011, 01:36 AM
but i have so work this weekend. No hay problema. I'll write out some instructions you can follow and post back. rt2800usb is not doing the job for us, is it?

nikonicanicanon
February 12th, 2011, 04:17 AM
now I have a new problem when turn on my pc i get a list of errors, usb, pci, and other things I could not read who do not respond ... gets stuck and after many attempts started very slow ... I have a 2.75MHz Core 2 Duo and 2GB of ram at 800MHz ....
I'm trying to use ubuntu, but I have a life using windows .... actually it is squeezing me, now believes that the original problem is the motherboard or something:confused::confused::confused::confused:

chili555
February 12th, 2011, 01:18 PM
You might get some clues by running:
sudo cat /var/log/syslog | grep -i error
sudo cat /var/log/syslog | grep -i warningI hope it is not the motherboard.

You might also repeat the tests with syslog.1

Shall I wait until you have the motherboard issue fixed before I proceed?

zombx
February 18th, 2011, 03:26 PM
Chili555, thanks for posting this. I think I have the same issue. I can go to "Connect to a hidden network" and enter the ssid and password which doesn't connect but tries to, but can't see wireless connections. Feels like I'm close.

03:06.0 Network controller [0280]: RaLink Device [1814:3062]

dmesg | grep -e rt2 -e wlan

rt2800pci 0000:03:06.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
Registered led device: rt2800pci-phy0::radio
Registered led device: rt2800pci-phy0::assoc
Registered led device: rt2800pci-phy0::quality
ADDRCONF(NETDEV_UP): wlan0: link is not ready

sudo iwlist wlan0 scan
wlan0 No scan results

I get this with or without the ethernet cable plugged in.

chili555
February 18th, 2011, 04:52 PM
Chili555, thanks for posting this. I think I have the same issue. I can go to "Connect to a hidden network" and enter the ssid and password which doesn't connect but tries to, but can't see wireless connections. Feels like I'm close.

03:06.0 Network controller [0280]: RaLink Device [1814:3062]

dmesg | grep -e rt2 -e wlan

rt2800pci 0000:03:06.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
Registered led device: rt2800pci-phy0::radio
Registered led device: rt2800pci-phy0::assoc
Registered led device: rt2800pci-phy0::quality
ADDRCONF(NETDEV_UP): wlan0: link is not ready

sudo iwlist wlan0 scan
wlan0 No scan results

I get this with or without the ethernet cable plugged in.Let's have a look at:
lsmod | grep -e rt2 -e rt3Thanks.

zombx
February 18th, 2011, 05:47 PM
Let's have a look at: Code:
lsmod | grep -e rt2 -e rt3
Thanks.




lsmod | grep -e rt2 -e rt3
rt2800pci 10233 0
rt2800lib 31970 1 rt2800pci
rt2x00usb 11316 1 rt2800lib
rt2x00pci 6993 1 rt2800pci
crc_ccitt 1699 1 rt2800pci
rt2x00lib 31575 4 rt2800pci,rt2800lib,rt2x00usb,rt2x00pci
led_class 3393 1 rt2x00lib
mac80211 267163 3 rt2x00usb,rt2x00pci,rt2x00lib
cfg80211 170485 2 rt2x00lib,mac80211
eeprom_93cx6 1789 1 rt2800pci

chili555
February 18th, 2011, 07:25 PM
This whole thread involves compiling rt3562sta and blacklisting rt2800pci and others. That's what you need to do: http://ubuntuforums.org/showthread.php?t=1608095

You need to blacklist rt2800 so that rt3562 functions.
Code:

gksu gedit /etc/modprobe.d/blacklist.conf

Add these lines at the end of the file
Code:

blacklist rt2800pci
blacklist rt2800lib
blacklist rt2x00pci
blacklist rt2x00lib

You may also need to edit /etc/modules as well by adding rt3562sta.
Code:

gksu gedit /etc/modules

Add to the end of that file
Code:

rt3562sta


Post back if you need more help.

zombx
February 19th, 2011, 05:27 AM
This whole thread involves compiling rt3562sta and blacklisting rt2800pci and others. That's what you need to do: http://ubuntuforums.org/showthread.php?t=1608095

You need to blacklist rt2800 so that rt3562 functions.
Code:

gksu gedit /etc/modprobe.d/blacklist.conf

Add these lines at the end of the file
Code:

blacklist rt2800pci
blacklist rt2800lib
blacklist rt2x00pci
blacklist rt2x00lib

You may also need to edit /etc/modules as well by adding rt3562sta.
Code:

gksu gedit /etc/modules

Add to the end of that file
Code:

rt3562sta


Post back if you need more help.

Yes I did all of this and my previous post is where I left off.

chili555
February 19th, 2011, 02:01 PM
I did all of this and my previous post is where I left off.Then you have made some errors. Please post:
cat /etc/modprobe.d/blacklist.conf
sudo modprobe rt3562sta
dmesg | grep rt3Thanks.

interzoneuk
March 8th, 2011, 09:58 PM
Hi

Does anyone know how to stop the ralink driver spamming dmesg ?

i'm getting lots of

[ 1235.011512] rt28xx_get_wireless_stats --->
[ 1235.011517] <--- rt28xx_get_wireless_stats
[ 1241.012140] MediaState is connected
[ 1241.012173] ==>rt_ioctl_giwmode(mode=2)
[ 1241.012189] ==>rt_ioctl_giwfreq 6
[ 1241.012226] rt28xx_get_wireless_stats --->
[ 1241.012230] <--- rt28xx_get_wireless_stats

(and I mean lots)

is there a way to install modules with less/no debugging ?

jbrid
August 27th, 2011, 01:12 PM
Chili if you are out there, I could really use your help. I know you will be able to solve this. I think it is trying to use the wrong driver. Here's some info.



$ uname -r
2.6.38-8-generic




$ lspci -nn | grep 0280
03:05.0 Network controller [0280]: Ralink corp. Device [1814:3062]




$ dmesg | grep -e rt2 -e rt3
[ 8.811346] rt3562sta: module license 'unspecified' taints kernel.
[ 8.820379] ===> rt2860_probe
[ 8.820408] rt2860 0000:03:05.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[ 8.821677] @rt2860_probe MAC address: 00:1a:ef:1d:94:22
[ 8.821678] <=== rt2860_probe
[ 9.434123] <==== rt28xx_init, Status=0


relavent output from ifconfig:


ra0 Link encap:Ethernet HWaddr 00:1a:ef:1d:94:22
inet6 addr: fe80::21a:efff:fe1d:9422/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:536 (536.0 B) TX bytes:0 (0.0 B)
Interrupt:20


relavent output from iwconfig:


ra0 Ralink STA ESSID:"" Nickname:"RT3562STA"
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s
RTS thr:off Fragment thr:off
Link Quality=10/100 Signal level:0 dBm Noise level:0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0




$ tail -10 /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
rtc
rt3562sta




$ tail -6 /etc/modprobe.d/blacklist.conf

# for rosewill wiresless adapter
blacklist rt2800pci
blacklist rt2x00lib
blacklist rt2x00pci
blacklist rt2800lib




$ iwlist scanning
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

ra0 Scan completed :
Cell 01 - Address: 00:1F:90:D4:BC:74
Protocol:802.11b/g
ESSID:""
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:44/100 Signal level:-72 dBm Noise level:-77 dBm
Encryption key:on
Bit Rates:54 Mb/s
IE: WPA Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK





$ lspci -v | tail -8

03:05.0 Network controller: Ralink corp. Device 3062
Subsystem: Ralink corp. Device 3062
Flags: bus master, slow devsel, latency 32, IRQ 20
Memory at ff500000 (32-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: rt2860
Kernel modules: rt3562sta, rt2800pci




$ modinfo rt2800pci | grep 3062
alias: pci:v00001814d00003062sv*sd*bc*sc*i*


Should it be using rt2860? I would think it should use rt3562sta. My only idea would be to blacklist rt2860 as well.

When I try to connect to my wireless network it just hangs and then fails to connect. I feel like I am close though.

jbrid
August 27th, 2011, 01:37 PM
Woo Hoo! I rebooted and re-entered my wireless credentials and it is working.

Sorry for the unessecary post.

chili555
August 27th, 2011, 01:50 PM
The module rt2860sta is not correct for your device:
chili@LAPTOP60:~$ modinfo rt2860sta | grep 3062
chili@LAPTOP60:~$ There is no result from this command because the rt2860sta module doesn't claim your device. Verify that it's not loaded:
lsmod | grep rt2I see only three problems.
ra0 Scan completed :
Cell 01 - Address: 00:1F:90:D4:BC:74
Protocol:802.11b/g
ESSID:""
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:44/100 Signal level:-72 dBm Noise level:-77 dBm
Encryption key:on
Bit Rates:54 Mb/s
IE: WPA Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSKI don't know if it's Network Manager, wpa_supplicant or your driver, but you will probably never connect to a hidden ESSID. As well, you will have great difficulty connecting to a weak signal.

Do you have the option to set a non-hidden ESSID? Is there a strength setting in your router? Is it dialed up to the maximum? Please see attached.

Finally, can you choose WPA2 only and not mixed WPA and WPA2 mode?

chili555
August 27th, 2011, 02:03 PM
Woo Hoo! I rebooted and re-entered my wireless credentials and it is working.

Sorry for the unessecary post.Awesome! Glad it's working.