PDA

View Full Version : [ubuntu] TP Link TL-WN722N strange connection



Glasgow.Tony
November 2nd, 2010, 06:34 AM
I just installed Ubuntu 10.10 yesterday, this is my first experience of Linux so I am a noob and have no idea how to go about troubleshooting this myself. I have been googling and searching forums for ages and have read a lot of threads of people having problems getting connected but have still to find anyone with the same issue I am having.

I managed to connect without any problem and I am not being periodically disconnected (which seems to be a frequent problem) but when I enter an address in firefox or click a link there is a 20-40 second delay before it will take me to the page, but once I am on the page if I click another link it will take me there straight away (as long as I am in the same tab, if I switch to a different window I have the 30 second delay again). Same with downloading files, when I click a download link it takes about half a minute to register that I have clicked, but once it establishes the connection my speeds are the same as they always are. speedtest.net is showing 8mbps, and the last file I downloaded came through at 900kbps once the connection established. It is very irritating since other than that I am loving Ubuntu and the more I read about Linux the more I want to drop my windows 7 altogether (running dual boot just now).

Thanks in advance :)

Glasgow.Tony
November 2nd, 2010, 06:03 PM
Bump. Maybe I should have included more details but not sure what.

I am using the TP-Link TL-WN722N USB dongle, x64 version of ubuntu, AMD chip, asus motherboard. Not sure if any of that makes any difference, I kinda just wanted to bump the thread :P

Glasgow.Tony
November 2nd, 2010, 08:06 PM
Ok this is solved. I stumbled across the answer in another thread by blind luck. Disabled ipv6 and now everything is working great.

tb5
December 12th, 2010, 07:05 AM
What was the solution? I'm experiencing a similar problem.

airtonix
December 14th, 2010, 10:45 AM
Ok this is solved. I stumbled across the answer in another thread by blind luck. Disabled ipv6 and now everything is working great.

An honourable person would link to said thread.

[ edit: Using 10.04...This is obviously not the mentioned thread, but it solved the problem for me :
http://ubuntuforums.org/showthread.php?t=1564278
]

Derathor
January 10th, 2011, 03:03 PM
Ok this is solved. I stumbled across the answer in another thread by blind luck. Disabled ipv6 and now everything is working great.

Please share the link of the solution, that way we ALL can benefit from it...

Thanks.