PDA

View Full Version : [ubuntu] laptop-mode-tools spin down settings not work!



ario
October 30th, 2010, 04:03 PM
Whatever I set in /etc/laptop-mode/laptop-mode.conf spin down timer for on Battery is 5 seconds. Which is dangerous. I set LM_BATT_HD_IDLE_TIMEOUT_SECONDS=90 but it is 5 seconds in action.
I think the main problem is that these commands:

hdparm -B 1 /dev/sda
hdparm -S18

Will enable spin down ability but will not change the drives default 5 seconds time out. No matter what number I use in hdparm -S command it will be always 5 seconds. I also tried these:
[CODE]hdparm -B 127 /dev/sda
hdparm -B 128 /dev/sda
hdparm -B 254 /dev/sda
hdparm -B 255 /dev/sda
[CODE]
But none of them made -S command able to change the default 5 second time out.
I do not know where else to change settings.
Please help me.

ario
November 1st, 2010, 11:16 AM
Bump!

ario
November 9th, 2010, 10:09 AM
Bump!

ario
November 16th, 2010, 02:57 PM
Bumpity Bump!

ario
November 23rd, 2010, 10:35 PM
Thanks for nothing. It seems that it's impossible in linux, which means you use a free operating system, so you have less quality!

efflandt
November 24th, 2010, 06:32 AM
You did not mention if you used sudo to do those commands as root. If you simply do them as a normal user, without using sudo, they may not have any effect (did you get any errors?).