PDA

View Full Version : [ubuntu] Ubuntu won't boot (blinking cursor) after drop.



SirBlain
October 25th, 2010, 10:06 PM
So my laptop suffered a bit of a drop. Everything was fine but when i go to start Ubuntu it just sits there and blinks it's cursor at me. Cute, I thought. I let it sit for a while and finally restarted, tried booting into the Linux Recovery mode. It gives me random I/0 errors and something about unreadable node?

I don't know if I should troubleshoot, reinstall, or if the hardrive has suffered irreversible damage.

I'm dual booting with Windows 7 and it starts right off (different hardrive).

I'll post more about the errors I get when I boot into recovery mode.

Thanks for the help guys!

sikander3786
October 25th, 2010, 10:33 PM
Most probably, your HDD couldn't resist the shock. Check it for damage. You can use a Live Ubuntu or Live Gparted CD. You can also use the diagnostic tools from manufacturer's website.

memtest from Grub menu is another thing that I will advise.

SirBlain
October 25th, 2010, 10:36 PM
ಠ益ಠ /frustration.

That was my next step. I'll try the memory test and post the results here. Thanks for the quick reply!

Ok I did the memory test twice. It said everything was fine. Tried booting into Ubuntu and got the same thing: buffer I/O error sda1 logical disk sector 70893564. This is when I'm trying the recovery mode. It keeps displaying the same thing over and over and doesn't get anywhere.

Oh and after the memtest Windows wouldn't boot, said the partition wasn't found. Took a few tries but eventually windows came up.

So can anyone help? I have just short of 100 gigs of important data. I just want Ubuntu to boot!