PDA

View Full Version : [ubuntu] Many Times, Titlebar is missing...



Rushyang
October 15th, 2010, 04:41 AM
Hey guys,

I am on ubuntu 10.10 (aka Maverick Meerkat) . My problem is many times when I log in into ubuntu.. My window's Titlebar is missing.. it won't come even if I change themes or anything else. If I'm going for restart, it will come back... It happens too often and I hate this.. Please advice.

Ctrl-Alt-F1
October 15th, 2010, 04:49 AM
Have you toyed around with Emerald for windows decoration? It sounds like a problem with that.

What happens if you hit Alt-F2 and when the dialog pops up you type --metacity replace (enter)?

BlazeFire247
October 15th, 2010, 04:54 AM
Try pressing Alt+F2 then put in gtk-window-decorator --replace

Rushyang
October 15th, 2010, 04:56 AM
Have you toyed around with Emerald for windows decoration? It sounds like a problem with that.

What happens if you hit Alt-F2 and when the dialog pops up you type --metacity replace (enter)?

Yes sir, I have installed "Compiz". & I would like to keep it if it's possible...
In another settings of compiz, "Select Window Decorator" is set to "GTK Window Decorator" (by default)..

Rushyang
October 15th, 2010, 04:59 AM
Try pressing Alt+F2 then put in gtk-window-decorator --replace

BlazeFire,
Thank you for that tip.. By typing that, My titlebar came back instantly.. But does that mean that i will have to type that whenever this happens?

Ctrl-Alt-F1
October 15th, 2010, 05:02 AM
Yes sir, I have installed "Compiz". & I would like to keep it if it's possible...
In another settings of compiz, "Select Window Decorator" is set to "GTK Window Decorator" (by default)..

For emerald:

To install them, go to: System > Preferences > Emerald Theme Manager and click the "Import" button and select the themes you want. To make your windows use Emerald, go to System > Preferences > CompizConfig Settings Manager and enable "Window Decoration", then click it and under "Command", enter:
emerald --replace
Then to run it for the first time, press Alt + F2 and type:
emerald --replace

For GTK:
CompizConfig Settings Manager and enable "Window Decoration", then click it and under "Command", enter:
/usr/bin/compiz-decorator

http://www.webupd8.org/2009/03/ubuntu-install-themes-emerald-compiz.html

BlazeFire247
October 15th, 2010, 05:06 AM
BlazeFire,
Thank you for that tip.. By typing that, My titlebar came back instantly.. But does that mean that i will have to type that whenever this happens?

Try going to System -> Preferences -> Startup Applications then click on "Add". Type it in the command and name it whatever you want.

Ronok
October 24th, 2010, 05:05 PM
Thanks,
This also fixed my situation instantly



BlazeFire247:
" Try pressing Alt+F2 then put in gtk-window-decorator --replace "

Ronok (http://www.gongkuo.com/linuxcli.htm)

fermulator
January 8th, 2011, 07:40 AM
any other suggestions?

I've tried all of the above and nothing restores the window decorations while running compiz.

Also a post exits: http://www.uluga.ubuntuforums.org/showthread.php?p=9971593