PDA

View Full Version : [ubuntu] Weather not showing on clock



Legeril
October 14th, 2010, 08:07 AM
My clock displays time / date a seems to function correctly, but even though I have added a location and the options to display weather conditions and temperature are checked it does not display them. I have an icon I've added to my upper panel but I would prefure to use the clock and save the space for other icons.

Is this a common problem? Has anyone fixed this before?

jtarin
October 14th, 2010, 08:39 AM
Possibly...the clock applet will NOT show your weather/temp unless the timezone in your location matches the TIMEZONE variable set for your system (in /etc/rc.conf). For me, I had to change mine from 'America/Los Angeles' to 'PST8PDT', which is what I had in my rc.conf. After that, everything worked as expected.

amjjawad
October 14th, 2010, 08:53 AM
My clock displays time / date a seems to function correctly, but even though I have added a location and the options to display weather conditions and temperature are checked it does not display them. I have an icon I've added to my upper panel but I would prefure to use the clock and save the space for other icons.

Is this a common problem? Has anyone fixed this before?

Do you have Ubuntu 10.04 or 10.10?

In my case (Ubuntu 10.04), I have to be connected to the Internet so that my Weather function could work probably. What I've done to add Weather was:
Directly after I installed Ubuntu 10.04, I clicked on the Time and Date then I clicked on Edit (Location). I set my location where I'm now and everything was and still working as long as I'm connected to the Internet. There's no problem at all.

I'm not sure what version/release of Ubuntu do you have but as I said, I have 10.04 :)

Legeril
October 14th, 2010, 01:38 PM
Yes I am using 10.04, although I am in a small city in China called Jining. This city isn't on the list of cities given, is there a way to add my city? Maybe that will fix the problem then

jtarin
October 14th, 2010, 01:50 PM
Yes I am using 10.04, although I am in a small city in China called Jining. This city isn't on the list of cities given, is there a way to add my city? Maybe that will fix the problem then
Setting the latitude and longitude will overcome that.
Example: Lat:43.116669 North Longitude:131.933334 West

irv
October 14th, 2010, 02:21 PM
I am using 10.10 and I have the same problem. Here are all my setting.
Time by no weather.
172301
Edit: I don't even have a /etc/rc.conf

Legeril
October 14th, 2010, 04:09 PM
I tried the Longitude and latitude option but still no fix, I'm making this thread as solved. I just jiggled a few icons around so now it 'looks' like my clock is doing what it's supposed to

Netscannur
October 15th, 2010, 06:46 AM
I think they may be having an issue with the weather servers... Weather was working just fine when I first installed 10.10 and then it went down a couple of days ago.

irv
October 15th, 2010, 02:13 PM
I gave up on using weather with the clock an am using screenlets. See screen shot.
172415

MAkerboom
October 23rd, 2010, 01:10 PM
I've found out that after I enable 'Automatic Time Synchronization' (which installs NTP) the problem is solved and the weather icon & temp. next to the date/time are displayed.

How to enable 'Automatic Time Synchronization':
http://www.watchingthenet.com/enable-auto-time-synchronization-in-ubuntu-and-kubuntu.html

mista-ace
October 23rd, 2010, 01:27 PM
hey after you set the place click on the time and go to Locations and then click on Set .. it will work... hope!

yorgos1
October 30th, 2010, 08:44 AM
Possibly...the clock applet will NOT show your weather/temp unless the timezone in your location matches the TIMEZONE variable set for your system (in /etc/rc.conf). For me, I had to change mine from 'America/Los Angeles' to 'PST8PDT', which is what I had in my rc.conf. After that, everything worked as expected.

Had the same problem with my ubuntu (10.10), followed your advice and corrected the problem, Thanks!!!

jtarin
October 30th, 2010, 11:23 PM
Had the same problem with my ubuntu (10.10), followed your advice and corrected the problem, Thanks!!!
Your welcome.:)

Knatchwa
October 31st, 2010, 05:35 AM
Was having the same problem for a few days, when I looked up the exact coordinates and modified the Longitude and Latitude - I found it working again. That was after closing the clock and adding it again to get it working.

kitno84
February 2nd, 2011, 10:17 PM
hey after you set the place click on the time and go to Locations and then click on Set .. it will work... hope!

worked for me, thanks.

ubu 10.10

astraluxkl
May 9th, 2011, 06:55 PM
My clock displays time / date a seems to function correctly, but even though I have added a location and the options to display weather conditions and temperature are checked it does not display them. I have an icon I've added to my upper panel but I would prefure to use the clock and save the space for other icons.

Is this a common problem? Has anyone fixed this before?
You have 2 solutions:

1. You can use "Weather Applet" from
<Gnome-panel> right click
<Add to Panel> click
.. select weather Applet and use It

2. Install "indicator-weather"
After installing indicator-weather you can find it in:
"Applications » Accessories » Weather Indicator"
Ubuntu 11.04

Weather Indicator has been accepted in the Natty repositories.
You can find and Install ‘indicator weather’ the the Ubuntu Software Centre.

Ubuntu 10.10
Weather-Indicator PPA The indicator can be installed in Ubuntu 10.10 via the official team PPA.
Simple add ppa:weather-indicator-team/ppa to your software sources
or run the following two commands in a new Terminal session:



sudo add-apt-repository ppa:weather-indicator-team/ppa
sudo apt-get update && sudo apt-get install indicator-weather

At last you can add indicator-weather it in "System»Preferences»Autostart Applications"