PDA

View Full Version : [SOLVED] How do I install Google Earth in 10.10?



TopFan
October 13th, 2010, 10:46 AM
Title says it all. I've tried numerous methods that have worked on past versions of Ubuntu, but none of them seem to work now.

alphacrucis2
October 13th, 2010, 10:56 AM
Title says it all. I've tried numerous methods that have worked on past versions of Ubuntu, but none of them seem to work now.

Medibuntu don't have it for Maverick yet.

Have you tried:


sudo apt-get install googlearth-package
make-googleearth-package --force
sudo dpkg -i *.deb

If you are running 64 bit you also have to make sure that the ia32-libs package is installed. I would be interested to know how you get on as for me it just crashes with a signal 6 error on startup just after displaying the googleearth splash screen.

oldos2er
October 13th, 2010, 04:58 PM
Download GoogleEarthLinux.bin (http://www.google.com/earth/download/ge/agree.html), open a terminal and run
cd Downloads
chmod a+x GoogleEarthLinux.bin
sudo ./GoogleEarthLinux.bin

oldos2er
October 13th, 2010, 04:59 PM
[delete]

TopFan
October 13th, 2010, 05:31 PM
I've cut and pasted both suggested codes into Terminal, but no luck.

After pasting Ann's code, terminal asks me for my password, but won't let me type anything.

emoguitarist06
October 13th, 2010, 05:46 PM
Check this site ;)
http://www.omgubuntu.co.uk/2010/10/google-earth-plays-nice-with-compiz-and-ubuntu-10-10/

natravis
October 13th, 2010, 05:55 PM
I've cut and pasted both suggested codes into Terminal, but no luck.

After pasting Ann's code, terminal asks me for my password, but won't let me type anything.

It will appear that you aren't typing anything, but if you type in your password then hit enter, stuff will happen. Magic!

TopFan
October 13th, 2010, 06:08 PM
It will appear that you aren't typing anything, but if you type in your password then hit enter, stuff will happen. Magic!

I tried that, but it didn't work.

Here's what I get when I paste Ann's code into terminal:

topfan@topfanlaptop:~$ cd Downloads
topfan@topfanlaptop:~/Downloads$ chmod a+x GoogleEarthLinux.bin
chmod: cannot access `GoogleEarthLinux.bin': No such file or directory
topfan@topfanlaptop:~/Downloads$ sudo ./GoogleEarthLinux.bin

It no longer asks me for my password. GoogleEarthLinux.bin is on my desktop, but terminal can't see it.

redbook4574
October 13th, 2010, 07:21 PM
I tried that, but it didn't work.

Here's what I get when I paste Ann's code into terminal:

topfan@topfanlaptop:~$ cd Downloads
topfan@topfanlaptop:~/Downloads$ chmod a+x GoogleEarthLinux.bin
chmod: cannot access `GoogleEarthLinux.bin': No such file or directory
topfan@topfanlaptop:~/Downloads$ sudo ./GoogleEarthLinux.bin

It no longer asks me for my password. GoogleEarthLinux.bin is on my desktop, but terminal can't see it.

Ok here goes, slightly convoluted but it worked for me.

1. install googleearth-package in synaptic
2. open a terminal window and run "sudo make-googleearth-package --force" (without the quotation marks).

3. This will take approx 10 mins to complete and will generate many errors, don't worry about these just now.

4. When step 3 has completed run the following command in terminal "sudo dpkg -i googleearth_5.2.1.1588+0.5.7-1_i386.deb"

5. All being well you should now have google earth in application-internet.

6. If it crashes on opening, in terminal run "gedit ~/.config/Google/GoogleEarthPlus.conf" and if the line enableTips=true exists change it to enableTips=false, if it does not exist add the line enableTips=false under the[General] heading and save the file.

Hopefully everything will then work.

oldos2er
October 13th, 2010, 07:25 PM
I tried that, but it didn't work.

Here's what I get when I paste Ann's code into terminal:

topfan@topfanlaptop:~$ cd Downloads
topfan@topfanlaptop:~/Downloads$ chmod a+x GoogleEarthLinux.bin
chmod: cannot access `GoogleEarthLinux.bin': No such file or directory
topfan@topfanlaptop:~/Downloads$ sudo ./GoogleEarthLinux.bin

It no longer asks me for my password. GoogleEarthLinux.bin is on my desktop, but terminal can't see it.

I thought you would download it to your ~/Downloads directory; if it's on your desktop, run cd Desktop instead.

empty_spaces
October 13th, 2010, 07:27 PM
I tried that, but it didn't work.

Here's what I get when I paste Ann's code into terminal:

topfan@topfanlaptop:~$ cd Downloads
topfan@topfanlaptop:~/Downloads$ chmod a+x GoogleEarthLinux.bin
chmod: cannot access `GoogleEarthLinux.bin': No such file or directory
topfan@topfanlaptop:~/Downloads$ sudo ./GoogleEarthLinux.bin

It no longer asks me for my password. GoogleEarthLinux.bin is on my desktop, but terminal can't see it.

Why are you doing a "cd Downloads" when you have GoogleEarthLinux.bin on your desktop?

HobbitTR
October 14th, 2010, 12:20 PM
1. install googleearth-package in synaptic
2. open a terminal window and run "sudo make-googleearth-package --force" (without the quotation marks).

3. This will take approx 10 mins to complete and will generate many errors, don't worry about these just now.

4. When step 3 has completed run the following command in terminal "sudo dpkg -i googleearth_5.2.1.1588+0.5.7-1_i386.deb"

5. All being well you should now have google earth in application-internet.

6. If it crashes on opening, in terminal run "gedit ~/.config/Google/GoogleEarthPlus.conf" and if the line enableTips=true exists change it to enableTips=false, if it does not exist add the line enableTips=false under the[General] heading and save the file.


I am using a Dell Inspiron 1520 with NVidia driver ver: 173.14.28
redbook's install steps worked GREAT for me :)

1) I used aptitude instead of synaptic.
2) I set the startup command to /usr/bin/googleearth because I got the following error from the default GoogleEarth command of:
googleearth %f
"Couldn't run Google Earth (googleearth-bin). Is GOOGLEEARTH_DATA_PATH set?"
3) When I used /usr/bin/googleearth it still crashed.
4) When I changed the enableTips to false it ran fine.
Thank you!

Dave"B"
October 14th, 2010, 01:41 PM
Hi Anne,
I tried your advice - alas, it gives me an error ( pasted below). I am brand new to UBUNTU, installed only last night.

david@david-Latitude-D620:~/Downloads$ chmod a+x GoogleEarthLinux.bin
david@david-Latitude-D620:~/Downloads$ sudo ./GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 5.2.1.1588........................................ ......................
setup.data/setup.xml:1: parser error : Document is empty

^
setup.data/setup.xml:1: parser error : Start tag expected, '<' not found

^
Couldn't load 'setup.data/setup.xml'

avanhel
October 14th, 2010, 03:02 PM
I use an easier method.
Have a look at the Medibuntu entry in the community documentation
https://help.ubuntu.com/community/Medibuntu

After you have added the medibuntu repository, you can just add Google earth using the ubuntu software centre.

oldos2er
October 14th, 2010, 04:19 PM
As was noted in post #2, Medibuntu doesn't have google-earth for 10.10.

gandaran
October 14th, 2010, 04:46 PM
Hi Anne,
I tried your advice - alas, it gives me an error ( pasted below). I am brand new to UBUNTU, installed only last night.

david@david-Latitude-D620:~/Downloads$ chmod a+x GoogleEarthLinux.bin
david@david-Latitude-D620:~/Downloads$ sudo ./GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 5.2.1.1588........................................ ......................
setup.data/setup.xml:1: parser error : Document is empty

^
setup.data/setup.xml:1: parser error : Start tag expected, '<' not found

^
Couldn't load 'setup.data/setup.xml'
probably the download is corrupted! download the .bin file again.
if you still have any problem installing the .bin file then try the other (only ubuntu 10.10) method

sudo apt-get install googlearth-package
make-googleearth-package --force
run the commands in terminal, the first one installs the google earth build utility and the second downloads the .bin package to the user directory and builds the .deb package out of it which you can install with ubuntu software center and also remove it the same way.

TopFan
October 14th, 2010, 07:19 PM
Hi Ann (and everyone).

Thank you for your help - I appreciate it.


I thought you would download it to your ~/Downloads directory; if it's on your desktop, run cd Desktop instead.

I've tried this with 'Desktop' and got the following:

topfan@topfanlaptop:~$ cd Desktop
topfan@topfanlaptop:~/Desktop$ chmod a+x GoogleEarthLinux.bin
topfan@topfanlaptop:~/Desktop$ sudo ./GoogleEarthLinux.bin
[sudo] password for topfan:
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 5.2.1.1588........................................ ......................
setup.data/setup.xml:1: parser error : Document is empty

^
setup.data/setup.xml:1: parser error : Start tag expected, '<' not found

^
Couldn't load 'setup.data/setup.xml'
topfan@topfanlaptop:~/Desktop$

Is it possible that Google Earth is not yet compatible with 10.10? Out of interest, does anyone know why GE is not available from the Software Centre - it is such a great piece of software!

TopFan
October 14th, 2010, 07:31 PM
Wow! I didn't see all the responses on pg 2 - I bookmarked this topic (i.e. page 1) yesterday and didn't spot pg 2 until after my last post. Schoolboy error - sorry! I'll review pg 2 tonight.


Why are you doing a "cd Downloads" when you have GoogleEarthLinux.bin on your desktop?

Because that's the code I was given! Being an 'Absolute Beginner' [the clue's in the forum title :P ] I haven't got a clue about 'Terminal'. Terminal is an out of date way of interacting with a computer. Everything should be done via menus of GUI. Until it's done that way in Ubuntu, this great OS will remain on the sidelines. But thanks for your contribution. :P

oldos2er
October 14th, 2010, 08:17 PM
For the parser error, try http://ca.ubuntuforums.org/showthread.php?p=9923137

"Terminal is an out of date way of interacting with a computer."

That's one opinion. :) I would've said it's a fundamental way of interacting with a computer, particularly a Linux machine.

Post back if you need more help.

alliance1975
October 16th, 2010, 02:43 AM
Tried all the suggestions and nothing works. Is there anyone out there that actually got GE to work in 10.10?

k3lt01
October 16th, 2010, 03:30 AM
Go to this page (http://packages.medibuntu.org/lucid/googleearth.html), scroll down to the bottom and download the version you need (amd64 or i386). Save it to your desktop. Right clock on it and select open with Ubuntu Software Centre. It will then install IF everything else you have done so far doesn't block it from doing so. If it is stopped from installing you will need to clean up the attempted installs you have done before this.

beew
October 16th, 2010, 05:02 AM
I am not sure why you must have google earth right the way. If you are having problems installing manually then just wait for it to appear in Medibuntu. Another option would be to install the package worldwind from Synaptic, it is similar to but probably better google earth (google "WorldWind" or "NASA Worldwind", I wanted to provide a link but it seems that the server is down at the moment)

beew
October 16th, 2010, 05:09 AM
Go to this page (http://packages.medibuntu.org/lucid/googleearth.html), scroll down to the bottom and download the version you need (amd64 or i386). Save it to your desktop. Right clock on it and select open with Ubuntu Software Centre. It will then install IF everything else you have done so far doesn't block it from doing so. If it is stopped from installing you will need to clean up the attempted installs you have done before this.

I hate to install .deb files with the SC, it just seems unnecessarily elaborate. gdebi should be the default way to install .deb packages like it is in Lucid(and before?), but for some reasons it is not even installed anymore by default and you have to install it via Synaptic (or the SC, which I never use)

k3lt01
October 16th, 2010, 05:31 AM
I hate to install .deb files with the SC, it just seems unnecessarily elaborate. gdebi should be the default way to install .deb packages like it is in Lucid(and before?), but for some reasons it is not even installed anymore by default and you have to install it via Synaptic (or the SC, which I never use)If you think this then post in the Natty forum and suggest it. Better still post your request in Launchpad.

The fact of the matter is the OP asked how to do it in 10.10. I have given the appropriate advice for the OP to succeed IF they haven't caused further complications by using the GE bin file.

alphacrucis2
October 16th, 2010, 05:39 AM
I hate to install .deb files with the SC, it just seems unnecessarily elaborate. gdebi should be the default way to install .deb packages like it is in Lucid(and before?), but for some reasons it is not even installed anymore by default and you have to install it via Synaptic (or the SC, which I never use)

Just install gdebi and make it the default program for deb files in Nautilus.

BTW. I had success with googleearth in 10.10. I had to reinstall the ia32-libs. Removing it took out skype, picasa and a couple of other 32 bit apps. After reinstalling ia32-libs, I installed the Lucid 64 googleearth package from Medibuntu and reinstalled the other apps that were removed and everything is now working ok. The medibuntu version is 5.1 rather than 5.2 but at least it works. I will have another go at 5.2 later in the week when I have time.

It's possible I had a funny version of the ia32-libs from a PPA when I was running Lucid that may have been the cause of my trouble.

beew
October 16th, 2010, 06:41 AM
If you think this then post in the Natty forum and suggest it. Better still post your request in Launchpad.

The fact of the matter is the OP asked how to do it in 10.10. I have given the appropriate advice for the OP to succeed IF they haven't caused further complications by using the GE bin file.

I did not say your advice was inappropriate. Why get so defensive?

k3lt01
October 16th, 2010, 08:05 AM
I did not say your advice was inappropriate. Why get so defensive?That post wasn't defensive. I was giving you some advice and re-enforcing my previous post for the OP so they didn't think they had to go and install gdebi.

TopFan
October 17th, 2010, 04:41 PM
Go to this page (http://packages.medibuntu.org/lucid/googleearth.html), scroll down to the bottom and download the version you need (amd64 or i386...

Yipee! Thanks for this. It's an old version of GE, so not perfect, but it'll do.

Thank you all for your contributions and help.

oldos2er
October 17th, 2010, 05:56 PM
Tried all the suggestions and nothing works. Is there anyone out there that actually got GE to work in 10.10?

Yes, v5.2.1.1588 works fine here.

lindsay7
October 18th, 2010, 06:27 PM
Ok here goes, slightly convoluted but it worked for me.

1. install googleearth-package in synaptic
2. open a terminal window and run "sudo make-googleearth-package --force" (without the quotation marks).

3. This will take approx 10 mins to complete and will generate many errors, don't worry about these just now.

4. When step 3 has completed run the following command in terminal "sudo dpkg -i googleearth_5.2.1.1588+0.5.7-1_i386.deb"

5. All being well you should now have google earth in application-internet.

6. If it crashes on opening, in terminal run "gedit ~/.config/Google/GoogleEarthPlus.conf" and if the line enableTips=true exists change it to enableTips=false, if it does not exist add the line enableTips=false under the[General] heading and save the file.

Hopefully everything will then work.

This work great for me, just had to change to ..amd64.deb for my system

ma3cs
October 18th, 2010, 06:53 PM
http://packages.medibuntu.org/pool/non-free/g/googleearth/

install from here .. just click

GiovanniEmex
October 18th, 2010, 09:37 PM
Go to this page (http://packages.medibuntu.org/lucid/googleearth.html), scroll down to the bottom and download the version you need (amd64 or i386). Save it to your desktop. Right clock on it and select open with Ubuntu Software Centre. It will then install IF everything else you have done so far doesn't block it from doing so. If it is stopped from installing you will need to clean up the attempted installs you have done before this.

I installed from the lucid repository, it installed quite easy, but every time I open it says it cannot connect to the server "http://kh.google.com:80/". In the Google site says that I must make an exception in the firewall... but as far as I know it is not activated. The gufw doesn't have a lot of help, either.

How can I make the application to work?

k3lt01
October 19th, 2010, 09:26 AM
Sorry Giovanni I don't know the answer to your question as I haven't come across that problem. I hope someone else is able to help.

k3lt01
October 19th, 2010, 09:35 AM
http://packages.medibuntu.org/pool/non-free/g/googleearth/

install from here .. just clickHere's a question for you, what one does a noob who doesn't know much about Ubuntu .. just click? I gave 1 link with 2 files (1 i386 and the other amd64 both of which are .deb files) so the person has 2 choices. The link you gave has 132 choices 10 of which are .deb files. Which one of 132 (or 10 if they know about .debs files) do they choose?

ma3cs
October 19th, 2010, 05:50 PM
googleearth_5.1.3533.1731-0medibuntu1_i386.deb 23-Jan-2010 19:09 17M

Work for me !

PS. Many files from there are changelog or copyright.

oldos2er
October 19th, 2010, 05:52 PM
Which one of 132 (or 10 if they know about .debs files) do they choose?

The most recent version. If they are unsure they can always ask here in the forums.

k3lt01
October 19th, 2010, 09:15 PM
googleearth_5.1.3533.1731-0medibuntu1_i386.deb 23-Jan-2010 19:09 17M

Work for me !

PS. Many files from there are changelog or copyright.I know what the files are, I'm not a noob anymore even though I don't know everything there is to know. I was trying to get you to be a little bit clearer for our noob friends who wouldn't have the foggiest idea what they are doing and that is often the reason they are here asking for help.

P.S. If you took a look at the link I gave that file is on that page. Talk about going the long way to do something ](*,)

ma3cs
October 19th, 2010, 09:40 PM
must be love if you insist so much ....

:guitar:

k3lt01
October 19th, 2010, 10:23 PM
To TopFan Don't forget to mark this thread as Solved so others can see it works without having to start a new thread.


must be love if you insist so much ....

:guitar:What?

alphacrucis2
October 19th, 2010, 10:45 PM
While Medibuntu's 5.1 package for Lucid 64 bit is now working for me in Maverick 64 bit, I'm still trying to get 5.2 to work. For me 5.2 crashes with Signal 11 shortly after the main window appears. I am following up with some ideas I read on the google support forums which I will try out later today and report back.

TopFan
October 20th, 2010, 01:11 PM
To TopFan Don't forget to mark this thread as Solved so others can see it works without having to start a new thread.
Good idea. How do I do that though? Can't see an obvious way.

k3lt01
October 20th, 2010, 09:48 PM
Go to the "Thread Tools" drop down menu at the top of the page and select Solved there.

TopFan
October 20th, 2010, 10:34 PM
Ta!

bedlam
October 23rd, 2010, 02:37 PM
Very helpful. I've just used your convoluted approach to install earth in 10.10
and it worked fine after it crashed and I added the line "Tips=false"

marwansherin
November 10th, 2010, 06:45 PM
hi, i was have too this error you only need do this
in terminal like root write this

./GoogleEarthLinux.bin --target /tmp/ge
cd /tmp/ge/setup.data/bin/Linux/x86/
mv setup.gtk setup.gtk2
cd /tmp/ge
./setup.sh

Good Luck,

grapperman
November 12th, 2010, 03:54 PM
hi, i was have too this error you only need do this
in terminal like root write this

./GoogleEarthLinux.bin --target /tmp/ge
cd /tmp/ge/setup.data/bin/Linux/x86/
mv setup.gtk setup.gtk2
cd /tmp/ge
./setup.sh

Good Luck,
Many thanks. Worked a treat!

L Campbell
November 12th, 2010, 04:25 PM
Go to this page (http://packages.medibuntu.org/lucid/googleearth.html), scroll down to the bottom and download the version you need (amd64 or i386). Save it to your desktop. Right clock on it and select open with Ubuntu Software Centre. It will then install IF everything else you have done so far doesn't block it from doing so. If it is stopped from installing you will need to clean up the attempted installs you have done before this.

Thanks for your suggestion here.

It worked like a trump card for me.

ulnsterile
November 13th, 2010, 12:54 PM
hey redbook4574 thanKs a million!!!...it worked for me...WOW

ulnsterile
November 13th, 2010, 12:59 PM
1. install googleearth-package in synaptic
2. open a terminal window and run "sudo make-googleearth-package --force" (without the quotation marks).

3. This will take approx 10 mins to complete and will generate many errors, don't worry about these just now.

4. When step 3 has completed run the following command in terminal "sudo dpkg -i googleearth_5.2.1.1588+0.5.7-1_i386.deb"

5. All being well you should now have google earth in application-internet.

yeah this one worked for me...hey redbook4574 thanKs a million!!!...it worked for me...WOW

wkhasintha
November 13th, 2010, 02:35 PM
Goody. I wanted to install GEarth too. awesome thread,

rmf1975
November 14th, 2010, 09:21 PM
Go to this page (http://packages.medibuntu.org/lucid/googleearth.html), scroll down to the bottom and download the version you need (amd64 or i386). Save it to your desktop. Right clock on it and select open with Ubuntu Software Centre. It will then install IF everything else you have done so far doesn't block it from doing so. If it is stopped from installing you will need to clean up the attempted installs you have done before this.


Thanks alot, Mr.k3lt01:)