PDA

View Full Version : [SOLVED] Unable to add Chrome to Unity launcher



knilsilooc
October 12th, 2010, 12:30 AM
I just installed Ubuntu Netbook Remix 10.10, and while everything seems to be working great, I have one problem: Google Chrome doesn't have the "Add to Launcher" option in Unity. I'm fairly experienced with Ubuntu, but I just can't figure this one out. I know I'm doing it right, because I added the Terminal, but for some reason I just can't add Chrome, and I'm really not sure why. Any assistance would be greatly appreciated!

awesomewin
October 12th, 2010, 10:59 AM
Had the same problem, but I actually think a reboot somehow just fixed the problem and I was able to right click Chromium and select "Keep in launcher".

knilsilooc
October 13th, 2010, 06:04 PM
A simple reboot doesn't work, unfortunately. Neither Chrome nor Chromium let me add them to the launcher, but other apps, like Firefox, work.

bachisanerd
October 13th, 2010, 06:44 PM
I'm having the same problem. Right-clicking Chrome in the launcher only displays a "Quit" option, no option to "Keep in Launcher."

Other applications do not seem to have this problem.

A bug, maybe?

[EDIT]
Looks like this has been reported in the bug tracker:
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/657771

Still looking into whether or not I have the latest version of libunity.

cariboo907
October 13th, 2010, 07:03 PM
The launchers in the panel are hard coded for now, there is a bug that allows some of us to add launchers by clicking keep in launcher.

You can add launchers, by following the instructions here (http://ubuntuforums.org/showpost.php?p=9910899&postcount=4)

knilsilooc
October 15th, 2010, 12:49 AM
Oddly enough, the "Keep in Launcher" option just appeared today! It may have been from an update, but I can't verify that. Either way, it works now! Even though I didn't wind up following any advice given in here, thanks to all who tried!

rykel
February 22nd, 2011, 06:26 PM
I installed Firefox 4 (Minefield) from the PPA and have the same problem... I cannot see any option to "Keep In Launcher"!

So I confirm that it is NOT a Chrome/Ubuntu problem, and from what I gathered from you all, it is a random bug.