PDA

View Full Version : [ubuntu] Ubu 10.04 won't connect thru usb wireless adapter



RealGomer
October 12th, 2010, 12:23 AM
I managed to get my usb wireless-n adapter to work in Ubuntu 10.04. Unfortunately, Windows managed to hose the hard drive while I was configuring it so I had reformat and reinstall both WinXP and U10. The USB wireless-n works perfectly under WinXP but nothing happen under U10. The icon in the Panel shows spinning arrows indicating there's a connection but I can't actually get out. Here are the outputs requested from the previous go around.

I then switched to WICD. I entered the WPA1/2 password using WICD to try to access my network. WICD sees the network plain as day. I get a message the password is bad. I then try using the preshared key in WICD. Same error message. I connect directly to the router from my other PC and verify both the password and preshared key. What I entered under WICD was correct. What gives? What should I try next?

root@Homebrew:/home/red# lsmod
Module Size Used by
binfmt_misc 6587 1
fbcon 35102 71
tileblit 2031 1 fbcon
font 7557 1 fbcon
bitblit 4707 1 fbcon
softcursor 1189 1 bitblit
vga16fb 11385 0
vgastate 8961 1 vga16fb
snd_intel8x0 25588 2
snd_ac97_codec 100646 1 snd_intel8x0
ac97_bus 1002 1 snd_ac97_codec
snd_pcm_oss 35308 0
snd_mixer_oss 13746 1 snd_pcm_oss
snd_pcm 70662 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy 1338 0
snd_seq_oss 26726 0
snd_seq_midi 4557 0
snd_rawmidi 19056 1 snd_seq_midi
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
radeon 674824 3
snd_timer 19098 2 snd_pcm,snd_seq
snd_seq_device 5700 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
ttm 49943 1 radeon
drm_kms_helper 29297 1 radeon
ppdev 5259 0
ns558 3056 0
rt2870sta 461811 1
drm 162409 5 radeon,ttm,drm_kms_helper
i2c_algo_bit 5028 1 radeon
snd 54148 14 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_ oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_ti mer,snd_seq_device
gameport 9089 2 ns558
k8temp 3024 0
amd64_agp 7025 1
parport_pc 25962 1
soundcore 6620 1 snd
shpchp 28820 0
agpgart 31724 3 ttm,drm,amd64_agp
i2c_nforce2 5199 0
snd_page_alloc 7076 2 snd_intel8x0,snd_pcm
lp 7028 0
parport 32635 3 ppdev,parport_pc,lp
usbhid 36110 0
hid 67032 1 usbhid
skge 35683 0
pata_amd 8766 2
floppy 53016 0
root@Homebrew:/home/red#
root@Homebrew:/home/red# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0d:61:68:d7:81
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)

wlan0 Link encap:Ethernet HWaddr 00:08:10:74:c7:c4
inet6 addr: fe80::208:10ff:fe74:c7c4/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:2114 errors:0 dropped:0 overruns:0 frame:0
TX packets:411 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:435195 (435.1 KB) TX bytes:29644 (29.6 KB)

root@Homebrew:/home/red#
root@Homebrew:/home/red# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
root@Homebrew:/home/red#
root@Homebrew:/home/red# cat /etc/resolv.conf
# Generated by NetworkManager
domain ZoomTown.com
search ZoomTown.com
nameserver 192.168.0.1
root@Homebrew:/home/red#
root@Homebrew:/home/red# lsmod | grep rt
rt2870sta 461811 1
gameport 9089 2 ns558
parport_pc 25962 1
agpgart 31724 3 ttm,drm,amd64_agp
parport 32635 3 ppdev,parport_pc,lp
root@Homebrew:/home/red#
root@Homebrew:/home/red# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0d:61:68:d7:81
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)

wlan0 Link encap:Ethernet HWaddr 00:08:10:74:c7:c4
inet6 addr: fe80::208:10ff:fe74:c7c4/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:4323 errors:0 dropped:0 overruns:0 frame:0
TX packets:1002 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:928075 (928.0 KB) TX bytes:72252 (72.2 KB)

root@Homebrew:/home/red#
root@Homebrew:/home/red# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 RTxx70 Wireless ESSID:"" Nickname:"RT3070STA"
Mode:Auto Frequency=2.462 GHz Access Point: 00:24:01:6FA:F1
Bit Rate=1 Mb/s
RTS thrff Fragment thrff
Encryption keyff
Link Quality=10/100 Signal level:-19 dBm Noise level:-97 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

root@Homebrew:/home/red# cat /etc/network/interfaces
auto lo
iface lo inet loopback

root@Homebrew:/home/red#
root@Homebrew:/home/red# cat /etc/resolv.conf
# Generated by NetworkManager
domain ZoomTown.com
search ZoomTown.com
nameserver 192.168.0.1
root@Homebrew:/home/red#
root@Homebrew:/home/red# lsusb #
Bus 003 Device 002: ID 046d:c01b Logitech, Inc. MX310 Optical Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 148f:3070 Ralink Technology, Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@Homebrew:/home/red#
root@Homebrew:/home/red# cat /etc/modprobe.d/blacklist
cat: /etc/modprobe.d/blacklist: No such file or directory
root@Homebrew:/home/red# cat /etc/modprobe.d
cat: /etc/modprobe.d: Is a directory
root@Homebrew:/home/red# cat /etc/modprobe.d/blacklist.conf
# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
blacklist i2c_i801

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_edac

#To prevent wireless module from loading
blacklist rt2800usb

blacklist rt2x00lib

blacklist rt2x00usb

RealGomer
October 16th, 2010, 09:08 PM
YAY!!!!! I installed the backport module and my wireless now works!!! The must be a bug in the 10.04 kernel or something. I posted this problem on Launchpad where another person had recommended loading the backport module.
IF your having problems with the RT2870 wireless driver, install the backport module mentioned there. It worked for me.